jerome (Créer un compte)

Toutes mes réponses sur les forums

15 sujets de 256 à 270 (sur un total de 287)
  • Auteur
    Messages
  • en réponse à : modifier …. haut de mon blog #618061
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Il faut mettre les mains dans le cambouis ! Comme dit ninfosman, ces deux liens correspondent à deux Pages qui existent par défaut sur ton thème. Tu peux supprimer, désactiver, créer, modifier, tout cela à partir de la console d’administration (gérer, écrire, Pages).

    Pour modifier ton « header », il faut trafiquer en testant header.php et style.css. Enfin, vérifie, ça dépend des thèmes.

    en réponse à : Balises autour de the_content() #617707
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Tu peux passer en mode « code » plutôt que « visuel » et essayer de coder directement avec tes balises. Et si tu as des problèmes tu peux désactiver l’éditeur visuel quelquepart dans les options ou le profil et installer une extension comme raw html (<- je viens de la découvrir donc t'es un veinard).

    en réponse à : Soucis dans l’administration sur article/page, categorie et liens #618120
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Est-ce que, quand tu écris ou modifies une Page ou un article, et que tu cliques sur « sauvegarde continue » puis sur le lien « voir », tu obtiens quand même quelque chose qui correspond (contenu, titre de la Page, chemin) ?

    en réponse à : Help : Désactiver les Corrections Automatiques de l’Editeur WP !! #618022
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Oh oh, on dirait qu’il y a eu de la casse sur le forum car le message de AmO et ma dernière réponse ont disparu !! Et comme hier soir c’était du « Database can’t.. » 🙂

    Merci pour ta réponse, Charlie_WA.

    J’ai installé cette extension RAW hier soir ; elle me semble simple à utiliser (juste à mettre deux balises start et end quand on veut plus que WP y fourre son nez). Et ça a l’air de bien fonctionner d’après mes quelques tentatives depuis ; comme j’avais besoin, le code que j’écris est le code qui s’affiche.

    Quel soulagement ! J’espère que l’équipe de développement de WP le mettra en natif.

    En tout cas, un GRAND merci à toi 🍺

    en réponse à : [Résolu] Page privée ne fonctionne pas #618187
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Tu veux dire que la restriction d’accès à une Page ou un article ne fonctionne pas ? Hum, comment privatises-tu ta page ? En mettant un mot de passe ?

    en réponse à : Inverser les articles #618196
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Il faut régler le ‘commutateur’ de la balise qui affiche les articles sur ‘DESC’ au lieu de ‘ASC (par défaut)’, non ? (ordre descendant / ascendant) ou un truc du genre. Ca peut peut-être se faire direct dans la console d’administration ; sinon avec un plugin ; ou enfin en allant changer le code de la page (index.php ou home.php selon celle que tu utilises).

    en réponse à : Help : Désactiver les Corrections Automatiques de l’Editeur WP !! #618020
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Merci de vos réponses.

    Editeur Visuel de Texte, désactivé 🙂 : ça résoud un de mes problèmes car j’en avais marre de retomber sur le visuel chaque fois que j’enregistrais une modification.

    Mais du coup l’accès aux options de formattage supplémentaires (ALT+MAJ+V) ne fonctionne plus du tout, lol.

    Enfin de toute façon, c’est pas l’éditeur lui-même (visuel ou code) qui gêne. C’est ce qui intervient après, dans la cuisine interne de WP.

    –> Quand on enregistre son document (Page ou article) –> il est happé par WP et malaxé quelquepart –> puis recraché sous une forme différente, où WP a procédé, arbitrairement il faut bien le dire, à un « toilettage » du code. C’est carrément de la chirurgie esthétique ! :D

    C’est cet ‘arbitraire’ que je voudrais cerner d’un peu plus près, sans devoir me transformer en programmeur pour autant. Je suppose que les mot-clefs en anglais pour trouver du matériel sur Google, c’est :  » WordPress fucked up my editing  » ? 😋 (19 500 réponses quand même)

    theNoic -> Salut ! voici la page du plugin « exec.php« . C’est pour le Php, pas pour le Xthml/Css, mais c’est exactement le genre de plugin indispensable pour ne pas se pourir la vie avec WP’s Editor. Merci ! Et si tu te souviens de pareil pour css, je suis preneur 🍺



    Changelog : pas encore trouvé la réponse.



    Bon, je vais au dodo, levé tôt demain. Bonne nuit les gens ! Et bonne année 2008 !

    YannC
    Membre
    Chevalier WordPress
    295 contributions

    🍺 Heureux !

    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Oui, le lien aide à voir le problème 🙂

    Je pense que tes épisodes sont publiés en tant que News (Articles d’actualité), pas en tant que Pages (Articles statiques), ok ?

    Donc sur ta page d’accueil (qui est soit index.php soit home.php ?), il y a le code du Loop qui va brasser la base de données et se remémorer toutes les news =>

    , puis il y a les balises WP qui font s’afficher 5 Articles

     » href= » » rel= »bookmark »>

    , (le chiffre 5 étant géré dans la console d’administration / Options / Lecture / « Pages du blog : montrer au plus : 5 articles » ), puis il y a le code que je t’ai montré qui boucle la boucle. Je ne parle pas des fioritures persos comme la balise pour éditer, pour mettre le nom de l’auteur, le contenu, etc etc, tout devant se trouver dans le Loop.

    Si les liens Précédents Suivants ne s’affichent pas alors qu’ils devraient, il est possible que tu aies mis une restriction genre query_post(‘showpost=5’), auquel cas je crois que le Loop ne s’inquiète que de ce nombre et le reste est ignoré d’où l’absence de liens Précédents.

    Il est aussi possible que ce soit simplement un problème css d’affichage de ce lien Précédent-Suivant (il est peut-être invisible, ou caché à -100px sur la gauche ou escamoté d’une autre manière).

    Il est aussi possible que les articles-news précédents qui manquent à l’appel aient été publiés en tant que Pages et pas Articles ? Ou un truc du genre ? :D

    en réponse à : Template pour pages de tags #617074
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Quand ta liste de catégories du tag cliqué apparaît, tu lui demanderas de n’afficher que le titre et le permalien, sans le content, non ?

    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Quand tu parle de pages, tu parles de Pages ou de News ?

    ….




    <p>  </p>



    <p></p>

    Voila le code qui me donne les deux liens Previous and Next quand il reste des News à afficher.

    YannC
    Membre
    Chevalier WordPress
    295 contributions

    tu la changes dans index.php ou home.php de ton thème. et tu actualises la page sur ton site

    en réponse à : Modification de la boucle LOOP pour creer une nouvelle PAGE #613264
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Pour répondre direct à ta question, non je n’ai pas d’idée dessus, il y a pas mal de choses que je ne pcapte pas dans WP.

    Par contre, j’ai une méthode que j’utilise pour résoudre ce genre de problème très précis : j’affiche et je passe en revue un maximum de thèmes WP différents et j’y cherche le truc qui se rapproche le plus de ce que je veux faire, puis j’examine son code et en général j’y trouve tous les tags qui m’intéresse pour ce que je veux faire. Puis je code ma propre page en passant par le Codex de temps en temps pour être sûr.

    Ca peut être long mais ça marche toujours. 🍺

    en réponse à : integration de WP dans un site existant #612932
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Bienvenu au royaume où il faut trouver seul ses réponses sauf miracle (qq’un passant par là, etc)

    Conseil qd même : quand qq’un te répond (exemple: Fleuretta), la moindre des choses est d’en tenir compte.. sinon tu risques pas d’avoir bcp de réponses du tout.

    Cerner ton problème : tu veux intégrer un article sur une page d’accueil qui est déjà en WordPress ou sur une page d’accueil qui n’est pas en WordPress ?

    Dans le 2eme cas je pense, il ne sert à rien de faire appel au Loop etc puisque le Loop ne concerne que les sites utilisant WP. Le Loop fonctionne « en aspiration » et pas .. en propulsion : « le Loop va chercher les infos et les ramène à lui », et non pas « Le Loop propulse les infos quelquepart sur une page étrangère à WordPress ». En gros. Ce qui implique que ta page d’accueil qui ne fonctionne pas sous WP, donc sans Loop, ne peut pas directement appeler des infos WP en utilisant des tags WP.

    solution : mettre ta page d’accueil en WP – ou utiliser un parser comme indiqué (je n’y connais pas grand chose) – ou peut-être faire apparaître dans ta page d’accueil le contenu statique d’une autre page, elle sous WP, que tu appeleras avec un simple include php ? (jamais essayé avec WP)

    Bonne chance

    en réponse à : J’ai ruiné mon Blog. Si vous pouviez m’aider :( #603280
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Amo > 🙂

    Raphy > Ton problème de points d’interrogation est lié à ta mise à jour. Tu devais auparavant être en charset caractères ISO 8859-1 et là tu es passé en UTF-8 (le nouveau WordPress est en UTF-8 par défaut). Vois sur le forum (recherche) car ça a du déjà arriver. Il faudra sûrement encore un peu bricoler ta base de données.

    Pour get_links, je crois que c’est une balise déclassée mais alors pôôôô sûr du tout. Tu dois vérifier sur le codex.wordpress.org.

    Quant à la gestion des nouvelles balises, tu peux l’affiner dans ta console de gestion (catégorie liens et pages je suppose) ; et si tu trouves la fiche sur les paramètres de get_links_list(), je suis preneur ! car sur cette fiche là (

    http://codex.wordpress.org/fr:Marqueurs_de_Modele/get_links_list ) il n’y a que deux (!?) paramètres.

15 sujets de 256 à 270 (sur un total de 287)