Timama (Créer un compte)

Toutes mes réponses sur les forums

8 sujets de 226 à 233 (sur un total de 233)
  • Auteur
    Messages
  • en réponse à : [Résolu] wordpress multisite pour site multilingue SANS plugin #936576
    Timama
    Participant
    Chevalier WordPress
    284 contributions

    merci pour ta réponse.

    Je reste sur le fait que je ne vais pas utiliser de PLUGIN (extension) même si cela est plus compliqué.

    Je pense toujours que le multisite, dans mon cas, reste une solution :
    Gestion multisite de WordPress pour simuler un site par langue, avec une seule instance de WordPress.
    Cette solution est peut-être un peu plus compliquée à mettre en place, mais c’est celle que je trouve la plus pertinente puisqu’elle offre une vraie indépendance des langues. Sans pour autant alourdir la maintenance puisque tout ce qui est commun est unique.

    Je vais tenter.. je n’y arriverai peut être pas !
    Mais si j’y arrive, je ferais un tuto :D

    Timama

    en réponse à : [Résolu] wordpress multisite pour site multilingue SANS plugin #936574
    Timama
    Participant
    Chevalier WordPress
    284 contributions

    hummm je ne sais pas comment on passe une question en “résolu”…..

    en réponse à : [Résolu] wordpress multisite pour site multilingue SANS plugin #936573
    Timama
    Participant
    Chevalier WordPress
    284 contributions

    TROUVÉ !!

    En fait, mes problèmes de non accès aux tableaux de bord des sous répertoires et aux mauvais affichages des sites qui se trouvent dnas ces sous répertoire était du au .htaccess.

    En effet, WordPress demande d’ajouter des lignes dans le htaccess.
    C’est ce que j’avais fait. MAIS apparement, c’est une erreur car il ne faut pas ajouter, mais REMPLACER
    les lignes situées entre

    et

    Après avoir fais ça, et bien j’ai eu accès aux tableau de bord et plus de problèmes d’affichage.

    En espérant que cela puisse être utile à qqun !

    Timama

    en réponse à : [Résolu] wordpress multisite pour site multilingue SANS plugin #936572
    Timama
    Participant
    Chevalier WordPress
    284 contributions

    re-bonjour,

    Alors, j’ai tout refais, ré-installer … etc….. en utilisant le virtualhost où j’avais un problème auparavant (apparement, j’avais laissé un vieux .htacces trainé et ça posait problème).
    J’ai nommé mon vistualhost multisite.

    Après avoir tout réinstaller, je me retrouver donc avec mon multisite et mon réseau composé des sous répartoires :
    http://localhost/multisite/fr
    http://localhost/multisite/de

    Malheureusement, quand j’essaie d’accéder à la page suivante (au tableau de bord)
    http://localhost/multisite/fr/wp-admin/
    http://localhost/multisite/de/wp-admin/

    j’ai le message suivant :
    “La page n’est pas redirigée correctement
    Firefox a détecté que le serveur redirige la demande pour cette adresse d’une manière qui n’aboutira pas.
    La cause de ce problème peut être la désactivation ou le refus des cookies.”

    Bien sûr j’ai accepté tous les cookie mais cela ne fonctionne toujours pas.

    Ensuite, la visualisation des sites suivants se présente en fait en colonne avec que du texte tout à gauche :
    http://localhost/multisite/fr
    http://localhost/multisite/de

    Donc un peu d’évolution mais cela ne fonctionne toujours pas…..

    Je continue mon investigation 🙂

    Timama

    en réponse à : [Résolu] wordpress multisite pour site multilingue SANS plugin #936571
    Timama
    Participant
    Chevalier WordPress
    284 contributions

    Bonjour fge,

    et merci beaucoup pour cette réponse. Je me sentais seule avec mon problème :D
    Oui, pardon, je me suis trompée, sous répertoire bien sur et pas sous domaine ….

    En fait, pour installer le wordpress multisite, et si on utilise le MAMP “de base”, le message suivant apparaît :
    “Vous ne pouvez pas installer de réseau de sites avec cette adresse serveur.
    Vous ne pouvez pas utiliser de numéro de port tel que :8888″

    Normalement il faut créer un virtualhost pour travailler dessus.
    Bon, je n’ai pas fait ça car je n’ai pas réussi à la faire fonctionner.
    je suis donc passée par modification des paramètres suivants :
    –> Dans Mamps, preferences, choisir “ports par défaut d’Apache et MySql”

    Ce qui me fait utiliser un port différent de :8888.
    Après j’ai pu créer mon réseau …. mais bon, j’ai un problème qui persiste et cela vient peut être de tout ça.

    Sinon, pourquoi “multilingue sans plugin”.
    Mon site existe déjà. Je dois le mettre sous CMS pour que la personne puisse modifier les textes comme elle veut.
    J’ai déjà mis un site sous wordpress, mais pas en multilingue.
    C’est pour ça que j’ai utiliser wordpress en multisite.
    Et je ne préfère utiliser aucun plugin, car la propriétaire du site ne saura pas forcément gérer cela (mise à jour, si il y a un problème un jour).
    Et puis, je l’avoue, c’est aussi un petit défi.

    Quand tu dis “le multilingue est possible avec une installation multisite, mais ce n’est pas forcément la solution la plus simple pour le faire”, quelles sont les autres méthodes ? je ne les connais pas.
    Quand tu parles “d’extentions non compatible”, de quoi parles tu exactement?

    bon et bien je continue mes investigations….. merci à ceux qui me répondent .. et je vous tiens au courant… ça pourra servir …

    Timama

    en réponse à : Sites créées non visibles #936122
    Timama
    Participant
    Chevalier WordPress
    284 contributions

    Bonjour,

    Ca à l’air d’être le même problème que moi.
    j’ai posté mon problème mais je n’ai pas de réponse (moi par contre je travaille en Local sur MAMP)
    Lien vers mon post

    J’espère que nous allons trouver !

    en réponse à : [Résolu] wordpress multisite pour site multilingue SANS plugin #936569
    Timama
    Participant
    Chevalier WordPress
    284 contributions

    RE-bonjour,

    En fait j’ai créé les sous domaines du réseau liés aux 2 langues.

    J’ai accès au tableau de bord http://localhost/wp-admin/
    mais je n’ai pas accès aux tableaux de bord pour les sous domaines
    http://localhost/fr/wp-admin/
    http://localhost/de/wp-admin/

    cela met l’erreur : Not Found
    The requested URL /fr/wp-admin/ was not found on this server.

    Quelqu’un a t’il déjà eu ce problème?
    Une suggestion à ce problème?

    merci beaucoup si vous pouvez m’aider !

    Timama

    en réponse à : [Résolu] wordpress multisite pour site multilingue SANS plugin #936568
    Timama
    Participant
    Chevalier WordPress
    284 contributions

    heu .. faute de frappe le “maintenant” … désolée

8 sujets de 226 à 233 (sur un total de 233)