thide

Toutes mes réponses sur les forums

15 sujets de 1 à 15 (sur un total de 58)
  • Auteur
    Messages
  • en réponse à : Woocommerce et Divi #2222838
    thide
    Participant
    Chevalier WordPress
    108 contributions

    Lorsque j’insère [ product_categories ], j’ai bien la liste des catégories de produit qui s’affichent mais alors pour mettre en page ça…

    • Cette réponse a été modifiée le il y a 1 month et 1 week par  thide.
    en réponse à : Woocommerce et Divi #2222834
    thide
    Participant
    Chevalier WordPress
    108 contributions

    Merci mais pas de gestion de paragraphe dans l’éditeur Divi. J’ai désactivé toutes les extensions autres sans succès.

    Je ne sais pas si c’est le shortcode qui n’est pas traduit ou s’il est mal utilisé puisque d’autres shortcodes fonctionnent…

    • Cette réponse a été modifiée le il y a 1 month et 1 week par  thide.
    en réponse à : Woocommerce et Divi #2222832
    thide
    Participant
    Chevalier WordPress
    108 contributions

    Il y a 1 bloc titre, 1 bloc texte dans lequel j’ai inséré le shortcode (ai essayé en visuel et en texte) et le bloc boutique.

    J’ai essayé sur une page vierge, ça ne fonctionne pas mieux.

    en réponse à : Woocommerce et Divi #2222806
    thide
    Participant
    Chevalier WordPress
    108 contributions

    Bonsoir,

    ça tourne sous WP 4.9.8 et Woocommerce 3.5.1

    Le site est ici : http://bit.ly/2FcbFK5

    Merci.

    • Cette réponse a été modifiée le il y a 1 month et 1 week par  thide.
    thide
    Participant
    Chevalier WordPress
    108 contributions

    Merci pour vos réponses. Le problème venait du fait que mon site WP « principal » était dans un dossier et non pas à la racine.

    Une fois déplacé à la racine, il est très simple d’installer d’autres WP dans des dossiers parallèles.

    Problème résolu donc.

    thide
    Participant
    Chevalier WordPress
    108 contributions

    Oui.

    À mon avis, le problème est en amont puisque de toute façon, mon sous-domaine est inaccessible… Je suis automatiquement renvoyé vers l’url canonique et donc « page sans résultat »

    thide
    Participant
    Chevalier WordPress
    108 contributions

    Merci pour la réponse.

    J’ai essayé en créant un sous domaine mais là aussi, impossible d’y accéder…

    en réponse à : Afficher dans la bonne case ;-) #954979
    thide
    Participant
    Chevalier WordPress
    108 contributions

    Je ne suis pas certain de la syntaxe pour le orderby. Il n’a pas l’air de le prendre en compte.

    en réponse à : Widgets et excerpt #930296
    thide
    Participant
    Chevalier WordPress
    108 contributions

    Il commence à y avoir de l’idée.

    Lorsque j’intègre ça dans mon code de widget de la manière suivante :

    
                  <?php 
      				$pages = get_pages(); 
      					foreach ( $pages as $page ) {
          					$list = '<h2><a>ID ) . ‘ »>’;
        					$list .= $page->post_title;
            				$list .= ‘</a></h2><p>‘;
            				$list .= $page->post_excerpt;
        					$list .= ‘</p>‘;
        						echo $list;
      					}
    ?>
            
             <p>
              <label for="get_field_id(‘title’); ?> »> :</label> 
              <input class="widefat" id="get_field_id(‘title’); ?> » name= »get_field_name(‘title’); ?> » type= »text » value= » » />
             </p>
            

    Sur ma page d’accueil s’affiche la liste des titres des pages avec un lien menant vers la page en question sur chacun des titres. Pas d’excerpt en vue par contre…

    Merci.

    thide
    Participant
    Chevalier WordPress
    108 contributions

    Mais oui, tu as raison, il me suffisait de reprendre exactement le même code…

    en réponse à : Marche sur tous navigateurs sauf FF #810670
    thide
    Participant
    Chevalier WordPress
    108 contributions

    Je rencontre ce problème en montant un site sous WordPress. Désolé d’avoir pensé que certains auraient pu rencontrer le problème avant moi.

    Je ne le ferai plus.

    Merci pour cette réponse constructive.

    en réponse à : Marche sur tous navigateurs sauf FF #810669
    thide
    Participant
    Chevalier WordPress
    108 contributions

    Firebug m’indique :

    L’attribut « coords » de la balise

    n’est pas au format « gauche,haut,droite,bas ».
    coords= » »

    Pourtant mes coordonnées sont correctes…

    J’avoue ne pas comprendre…

    en réponse à : Lister les posts de la même catégorie sauf celui sur lequel on est #809098
    thide
    Participant
    Chevalier WordPress
    108 contributions

    Du coup, j’ai fait un peu de mise en page mais comment faire pour insérer un lien vers l’article listé et afficher le titre dans le « alt » ?

    echo ‘

  • ‘; the_title(); echo ‘

  • ‘;

en réponse à : Lister les posts de la même catégorie sauf celui sur lequel on est #809096
thide
Participant
Chevalier WordPress
108 contributions

Avec un petit ; à la place de : après le else et ça marche 😉

Merci. Je vais essayer de mettre des liens sur les titres listés en bas de page maintenant.

en réponse à : Lister les posts de la même catégorie sauf celui sur lequel on est #809094
thide
Participant
Chevalier WordPress
108 contributions

J’ai l’impressions que quand on copie/colle dans le forum, on a des bouts de code qui disparaissent 😉

SI je mets :

<<h2 id="post-« >

<?php
$iscat3 = false;
if ( in_category(3) ) $iscat3 = true ?>
<?php endwhile;

if ($iscat3 == true)
{
// si on est dans la categorie 3, alors afficher les articles de la catégorie comme décrit plus haut
// je mettrai plutôt un appel à WP_Query qu’a query_posts pour faire une double boucle et eviter d’interférer avec la boucle principale, en particulier si il y a de la pagination.

$query = new WP_Query(array( ‘cat’ => 3, ‘order’ => ‘ASC’ , ‘post__not_in’ => array( $curID)));
while ( $query->have_posts() ) {
$query->the_post();
echo ‘

  • ‘; the_title();echo ‘
  • ‘;
    }
    wp_reset_postdata();
    }

    else {
    echo  » ?>

    Mon éditeur me dit que j’ai un problème dans les 3 dernières lignes.

    15 sujets de 1 à 15 (sur un total de 58)