Remi-L (Créer un compte)

Toutes mes réponses sur les forums

13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • en réponse à : Plus d’éditeur visuel après la MàJ 2.1.1 -FR #594007
    Remi-L
    Membre
    Initié WordPress
    16 contributions

    Même problème pour moi.

    Il ne s’agissait pas d’une mise à jour mais d’une nouvelle installation.

    en réponse à : Sauts de lignes #584511
    Remi-L
    Membre
    Initié WordPress
    16 contributions

    Oui, c’est intéressant…
    cela explique certaines disparitions bizarres dans l’éditeur.
    Il va falloir agir sur les 2 tableaux.

    en réponse à : Sauts de lignes #584509
    Remi-L
    Membre
    Initié WordPress
    16 contributions

    Bien vu ! 🙂
    C’est effectivement là que ça se passe apparemment…
    Mais je crois que le problème est un peu plus bas.

    Au début, il ne fait que de l’isolement de paragraphes.
    Ensuite, l’approche que le programmeur a adoptée est d’englober systématiquement chaque ligne dans un paragraphe avec
    $pee = preg_replace(‘/n?(.+?)(?:ns*n|z)/s’, “

    $1

    n”, $pee);
    puis de les enlever dans les cas où il y avait déjà des balises de structure.

    Le problème c’est que dans le cas d’un paragraphe vide, nous avons :

    qui donne

    et là ses lignes suivantes s’emmêlent les pinceaux en confondant contenu et structure.

    Je n’ai pas le temps tout de suite de faire des test en réel mais en lisant la routine, j’aurais tendance à dire que dans

    $pee = preg_replace(‘!<p>s*(]*>)!’, “$1”, $pee);

    il faudrait enlever ‘/?’ , c’est à dire ne pas traiter les structures

    et que dans

    $pee = preg_replace(‘!(]*>)s*</p>!’, “$1”, $pee);

    il faut remplacer ‘/?’ par ‘/’ c’est à dire ne pas traiter les structures

    J’aurais aussi tendance à ajouter   dans la ligne
    $pee = preg_replace(‘|

    s*?

    |’, ”, $pee); ==> $pee = preg_replace(‘|

    s*?

    |’, ‘ ‘, $pee);
    (ligne qui semble avoir été rajoutée après coup).

    Bon, mais il faudrait tester… et c’est un peu difficile de bidouiller sans connaître l’historique de cette routine. Si le programmeur a adopté cette solution, il doit avoir des raisons…

    Une autre solution serait de forcer les 2 conditions mentionnées ci-dessus à obligatoirement être respectivement en début et en fin de ligne, cela pourrait suffire…
    Et bien entendu, il reste la possibilité de traiter le cas d’une ligne vide en cas particulier avec un beau ‘if’ pour sauter la seconde partie de cette routine… 😉

    Edit : Le code que je regarde est celui de WP 2.0.5 et non celui de MU mais il y a des grandes chances que cette routine soit la même.

    en réponse à : Sauts de lignes #584507
    Remi-L
    Membre
    Initié WordPress
    16 contributions

    Je viens de regarder le stockage car cela m’étonnait que tu dises qu’ils sont stockés dans la BDD… et tu as raison, ils sont stockés,

    et
    , ces derniers étant sous la forme de simples n (sauf si on leur colle une classe).

    Donc le problème serait plutôt dans le module qui va extraire les données avant de les afficher, ce qui innocenterait TinyMCE.

    Mais là, j’ai une légère différence entre WP 2.0.5 et WP-MU :
    – Sur mon blog LeMonde.fr, si je fais une suite de paragraphes vides avec une classe, il me met   à la place de l’espace et tout est correctement conservé.
    – Sur un simple WP 2.0.5, il ne transforme pas l’espace d’un paragraphe vide en   et à l’affichage il supprime les

    (alors qu’ils sont dans la BDD), ce qui laisse une suite de

    ouvertes. Donc, là y’a bug de toutes façons.

    Bon, mais il faudrait plutôt chercher dans les routines qui vont extraire les posts. Ce seraient elles qui font une opération “Tout doit disparaître…”.

    en réponse à : Sauts de lignes #584506
    Remi-L
    Membre
    Initié WordPress
    16 contributions

    A moi aussi, cette histoire du double saut de ligne me semble surréaliste.
    Le problème existe aussi sous WordPress normal.

    Sur le WordPress-Mu du Monde, voilà ce que j’ai remarqué :

    – si je fais des sauts de lignes simples (

    ), ils sautent dès que l’on fait sauvegarder
    – si je fais des sauts de lignes sur un paragraphe avec une classe (

    ), ils survivent à la fois dans les données sauvegardées et apparaissent correctement à l’affichage.
    – les doubles-BR sont dans tous les cas remplacés par un saut de paragraphe, qu’on leur colle une classe ou pas. On peut en mettre 10 de suite, ils ne feront qu’un saut de paragraphe.

    Dans le WordPress normal (2.0.5 avec le TinyMCE d’origine, sans plugin pour ne pas interférer), c’est exactement pareil.
    Je n’ai pas eu vraiment le temps de regarder longuement le code du WordPress normal, mais j’ai commencé à osculter TinyMCE pour m’orienter ensuite vers wp-includes/kses.php et à mon avis le problème serait plutôt là-dedans, car on a là plein de routines qui font du nettoyage. Le fait de supprimer les paragraphes vides est peut-être un phénomène induit. A mon avis, il faut plutôt chercher l’endroit qui transforme les double-BR en saut de paragraphe (ce n’est pas facile car les
    sont transformés très tôt en n …). Je n’ai pas regardé comment sont stockés les sauts de paragraphe, la tuile serait qu’ils soient stockés en double n !

    Mais comme toi, ce qui me sidère, c’est que personne ne mentionne ce problème.
    Personne n’appuie 2 fois sur la touche Return ?! 🙂))

    en réponse à : Laisser une ligne vide #584324
    Remi-L
    Membre
    Initié WordPress
    16 contributions

    Merci pour ta réponse…
    … mais je ne cherche pas une solution pour moi (j’utilise les margin), je cherche une solution pour un utilisateur normal en mode “éditeur visuel” (la fenêtre html est hors de portée pour un utilisateur normal).
    🙂

    en réponse à : Euh … WordPress et Google .. petit souci :) Feed but not Feed. #584252
    Remi-L
    Membre
    Initié WordPress
    16 contributions

    Il y a un problème si le flux sort trop tôt dans les requêtes. Normalement Google devrait sortir la page et non le flux sur une requête normale.

    Si Google est en train de re-indexer ton blog, ne fais rien et attend les pages devraient remonter (le flux RSS est toujours l’un des tout premiers fichiers qu’il indexe).
    Si ton blog est indexé depuis longtemps, il faut utiliser robots.txt pour le tempérer un peu (mais à priori cela voudrait dire que tu as plus de contenu dans ton flux que dans ton blog…)

    en réponse à : WordPress-Mu sur LeMonde.fr #583342
    Remi-L
    Membre
    Initié WordPress
    16 contributions

    Pour vous donner des nouvelles : La situation s’éclaircit.
    Le webmaster du Monde met tout en oeuvre pour résoudre les problèmes, n’hésitant pas à se mettre en contact direct.

    Les blogs massacrés ont bénéficié d’un nouvel import amélioré. Le blog qui me posait le plus problème est presque dans son état initial, le seul problème restant étant les doubles br transformés en changement de paragraphe (sans reprendre les styles ou classes rattachés au paragraphe fermé…!) Donc, il va falloir remonter tout le blog petit à petit pour corriger cela.

    Le point le plus important à mes yeux est d’avoir obtenu de retrouver la possibilité d’utiliser les ‘style=”…’ et ‘class=”…’ et autres span…
    C’était le plus important non seulement pour la mise en page des nouvelles notes mais aussi pour pouvoir re-sauver une ancienne note sans l’exploser.

    La grogne reste importante parmi les bloggers qui ont bien du mal pour passer de Typepad à WordPress et aussi parmi nos visiteurs-commentateurs. Je vois pour ma part une baisse de fréquentation très nette (30% env), essentiellement sur les connexions directes (ce qui est un peu inquiétant, mais bon, il est top tôt pour en tirer des conclusions).

    en réponse à : Commentateurs sans adresse de site #583918
    Remi-L
    Membre
    Initié WordPress
    16 contributions

    En attendant, j’ai mis en place mon système de page externe.

    C’est vraiment dommage que WordPress n’accorde pas beaucoup d’importance aux commentaires car un blog, ce sont les commentateurs qui le font vivre. Là, on dirait que l’on veut les décourager… 😉
    C’est comme le fait de remettre toutes les zones à zéro en cas de message d’erreur : le pauvre gars qui a oublié une case, paf! il perd tout son beau commentaire. :-(

    en réponse à : Commentateurs sans adresse de site #583916
    Remi-L
    Membre
    Initié WordPress
    16 contributions
    matthieu – laza wrote:
    Je viens d’aller voir des blogs sous typepad mais je n’ai pas vu dans les commentaires des fonctions qui reprennent les emails des commentateurs, ça y étéait sur les blogs typepad du monde ?

    Oui, quand on indique email+site, le lien est sur le site, quand on met un email seulement, le lien est un mailto, qui est d’ailleurs protégé par une protection rudimentaire (du style &#xx;&#xx; etc… ), protection qui est loin d’être la plus efficace, mais qui protège tout de même un peu.

    >fantome :
    Mettre son adresse email en fin de message signifie qu’elle sera totalement en clair et il ne serait pas correct de suggérer cela à ses visiteurs. La mettre à la place du site web n’est pas possible et ce serait le même problème.

    en réponse à : WordPress-Mu sur LeMonde.fr #583340
    Remi-L
    Membre
    Initié WordPress
    16 contributions

    Pour l’insertion de l’image :

    Typepad est réellement plus avancé, surtout pour l’utilisateur lambda, car tout est fait en une seule opération : on sélectionne l’image son son propre disque dur et on a un petit menu pour :
    – donner la taille de la miniature qui sera affichée (soit la largeur soit la hauteur)
    – le positionnement
    – si on veut un lien avec un pop-up sur l’image plein pot
    et paf! c’est dans le billet… prêt à l’emploi. C’est intuitif.

    Dans WordPress, il faut raisonner comme un informaticien pour comprendre, donc ça rebute beaucoup de gens, c’est normal… 😉

    > Am0
    Non, même en débranchant l’editeur visuel, les onclick ne sont pas acceptés.

    Bon, mais les ‘onclick’, on va s’en passer… C’est seulement que tout le monde au Monde était habitué aus popups de gros plans sur les images et que ça plaisait.

    > Bellule

    Les balises DIV et IFRAME ne sont effectivement pas autorisées pour l’instant (enfin, pour Iframe ça se comprend 😉). Il va effectivement te falloir trouver un autre moyen…
    Ecris au support pour réclamer les STYLE, DIV et SPAN (ne réclame pas IFRAME parce qu’il faudrait être fou pour le donner)… 😉

    en réponse à : WordPress-Mu sur LeMonde.fr #583339
    Remi-L
    Membre
    Initié WordPress
    16 contributions

    Merci beaucoup Matthieu pour les codes. la comparaison est effectivement intéressante :

    Plus d’onglets dans LeMonde, sans doute des plugins, notamment celui qui permet de choisir son habillage et d’avoir une page de CSS personnalisés, + les portfolios + le support
    Pas d’onglet plugin par contre…
    Pas de page : Gérer les uploads

    Page “Ecrire”:
    LeMonde : pas d’onglets Editeur et HTML,
    pour passer une image dans l’éditeur, le mini menu vient en surperposition de l’image, il y a les mêmes fonctions mais c’est beaucoup moins clair,
    quand on passe une image dans l’éditeur en full-size, elle se place avec une hauteur à 96 (il faut l’enlever avec le mini menu de l’icone image).

    Dans les 2 cas, les ‘style=’ sur le balises IMG et P, les ‘onclick’ sur les A ne sont pas acceptés et il faut faire les marges avec les antiques ‘hspace’ et ‘vspace’.

    Les paramètres “class” sont acceptés sur ta version mais comme on ne peut avoir de page css perso ça ne sert pas vraiment (enfin, on peut toujours caser les définitons css quelque part “à la hussarde” mais bon…). Sur LeMonde c’est l’inverse, on a les CSS personnalisés mais pas moyen de mettre des “class”. 😉
    Ta version me fait plein d’erreurs javascript sous IE, l’onglet HTML étant inutilisable (est-ce pour cela que Le Monde l’a enlevé ? ). Sous FF, cela marche.

    Pour le reste, cela semble identique. Donc pas vraiment de grosses différences, sauf la possibilité d’utiliser les “class” (ce qui me comblerait d’aise, soit dit en passant…)

    en réponse à : WordPress-Mu sur LeMonde.fr #583333
    Remi-L
    Membre
    Initié WordPress
    16 contributions

    Bon, je ne fais pas recette avec mes questions… 🙂
    Ceci dit, après l’hurluberlu qui a trollé sur le blog de ce site, je comprends que personne n’ait envie de répondre… le pire est que ce zigoto n’a même pas de blog au Monde.

    Je me réponds à moi-même (j’ai fait mes recherches…)

    1. Certains paramètres de balises ont été interdits par les programmeurs pour des raisons de sécurité. Donc pas de “style : margin: 0px 8px;” sur les images, il faut utiliser l’horrible “hspace”. Pas de “class=”xxx” non plus sur les images (par contre “class” est autorisé sur les balises de lien , allez comprendre pourquoi). Les “onclick” sont bien évidemment bannis. J’ai fait une demande pour que soit autorisée “class” sur les balises IMG ce qui permettrait de retrouver des possibilités de mise en page.

    2. Non, il n’y a pas plus simple. La gestion et l’insertion d’images est l’un des gros points faibles de WordPress qui sur ce plan est très en retard par rapport à la facilité d’emploi de Typepad.

    3. Apparemment non. Toutes les miniatures font 96 de haut. Donc en pratique, il faut envoyer une image 2 fois : une fois à la taille d’affichage désirée dans la page (sauf si 96pix de haut nous suffit) et une fois à la taille d’affichage en gros plan (si désiré bien entendu). Cela nous fait 4 fichiers sur le serveur (dont 2 miniatures intulies mais bon…)

    4. Pb réglé, c’était une simple option du webmaster

    5. Apparemment non. Le problème reste donc entier pour moi. Le webmaster du Monde a accepté de me repasser l’un de mes 2 blogs à la moulinette mais l’autre, le plus gros, est toujours dans un état épouvantable, massacré lors de l’importation. [edit : problème réglé, une nouvelle importation est en cours]

    Donc, pour l’instant, la situation est loin d’être radieuse et la révolte gronde d’autant plus que Le Monde est une plateforme payante. Si j’ai bien compris WordPress-Mu est très récent et l’on apprécie moyennement d’être pris comme cobayes pour essuyer les plâtres.

    Je ne cherche pas à critiquer bêtement WordPress, cet épisode m’a permis de découvrir WordPress que je ne connaissais pas (je me suis installé une version de WordPress normal sur mon propre serveur pour comparer avec MU, le WordPress normal n’a pas le défaut mentionné en 1.). WordPress me semble meilleur que Dotclear mais il est nettement moins facile d’utilisation que Typepad.
    Il faudrait améliorer les 2 points faibles :
    – L’insertion d’image dans un billet en un seul clic
    – Autoriser les paramètres “class” et “style” dans les balises (défaut spécifique à WordPress-mu, pas à WordPress)

13 sujets de 1 à 13 (sur un total de 13)