petitecirce (Créer un compte)

Toutes mes réponses sur les forums

15 sujets de 16 à 30 (sur un total de 138)
  • Auteur
    Messages
  • petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    Je viens de remplacer le wp_reset_query () par
    Mais c’est tjs la même chose, les mêmes posts similaires apparaissent.

    C’est embêtant ce truc !

    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    Je viens de mettre le wp_reset_query () ; après (je n’ai pas trouvé ).

    Mais ça n’a rien changé. Les “posts similaires” proposés à la fin des articles sont toujours les mêmes.

    Voici le code du fichier single.php

    
    
    <div id="main-content">
    	<div class="container">
    		<div id="content-area" class="clearfix">
    			<div id="left-area">
    			
    				<?php if (et_get_option('divi_integration_single_top')  ” && et_get_option(‘divi_integrate_singletop_enable’) == ‘on’) echo(et_get_option(‘divi_integration_single_top’)); ?>
    
    				<article id="post-” >
    					<h1></h1>
    
    				<?php
    					if ( ! post_password_required() ) :
    
    						et_divi_post_meta();
    
    						$thumb = '';
    
    						$width = (int) apply_filters( 'et_pb_index_blog_image_width', 1080 );
    
    						$height = (int) apply_filters( 'et_pb_index_blog_image_height', 675 );
    						$classtext = 'et_featured_image';
    						$titletext = get_the_title();
    						$thumbnail = get_thumbnail( $width, $height, $classtext, $titletext, $titletext, false, 'Blogimage' );
    						$thumb = $thumbnail["thumb"];
    
    						$post_format = get_post_format();
    
    						if ( 'video' === $post_format && false !== ( $first_video = et_get_first_video() ) ) {
    							printf(
    								'<div class="et_main_video_container">
    									%1$s
    								</div>‘,
    								$first_video
    							);
    						} else if ( ! in_array( $post_format, array( ‘gallery’, ‘link’, ‘quote’ ) ) && ‘on’ === et_get_option( ‘divi_thumbnails’, ‘on’ ) && ” !== $thumb ) {
    							print_thumbnail( $thumb, $thumbnail[“use_timthumb”], $titletext, $width, $height );
    						} else if ( ‘gallery’ === $post_format ) {
    							et_gallery_images();
    						}
    					?>
    
    					<?php
    						$text_color_class = et_divi_get_post_text_color();
    
    						$inline_style = et_divi_get_post_bg_inline_style();
    
    						switch ( $post_format ) {
    							case 'audio' :
    								printf(
    									'<div>
    										%3$s
    									</div>‘,
    									esc_attr( $text_color_class ),
    									$inline_style,
    									et_pb_get_audio_player()
    								);
    
    								break;
    							case ‘quote’ :
    								printf(
    									‘<div>
    										%1$s
    									</div> <!-- .et_quote_content -->‘,
    									et_get_blockquote_in_content(),
    									esc_attr( $text_color_class ),
    									$inline_style
    								);
    
    								break;
    							case ‘link’ :
    								printf(
    									‘<div>
    										<a href="%1$s" class="et_link_main_url">%2$s</a>
    									</div> <!-- .et_link_content -->‘,
    									esc_url( et_get_link_url() ),
    									esc_html( et_get_link_url() ),
    									esc_attr( $text_color_class ),
    									$inline_style
    								);
    
    								break;
    						}
    
    					endif;
    				?>
    
    
    					<div class="entry-content">
    					 ‘<div class="page-links">‘ . __( ‘Pages:’, ‘Divi’ ), ‘after’ => ‘</div>‘ ) );
    					?>
    					</div> <!-- .entry-content -->
    
    					<?php
    					if ( et_get_option('divi_468_enable') == 'on' ){
    						echo '<div class="et-single-post-ad">‘;
    						if ( et_get_option(‘divi_468_adsense’)  ” ) echo( et_get_option(‘divi_468_adsense’) );
    						else { ?>
    							<a href="”><img src="” alt=”468 ad” class=”foursixeight” /></a>
    				<?php 	}
    						echo '</div> <!-- .et-single-post-ad -->‘;
    					}
    				?>
    
    <div class="relatedposts">
    
        <h3> Poursuivez votre lecture car… vous aimerez sans doute aussi : </h3>
        ID);
     
            if ($tags) {
                $tag_ids = array();
            foreach($tags as $individual_tag) $tag_ids[] = $individual_tag->term_id;
                $args=array(
                    ‘tag__in’ => $tag_ids,
                    ‘post__not_in’ => array($post->ID),
                    ‘posts_per_page’=>5, // Number of related posts to display.
                    ‘caller_get_posts’=>1
                );
     
            $my_query = new wp_query( $args );
     
            while( $my_query->have_posts() ) {
                $my_query->the_post();
            ?>
     
            <div class="relatedthumb">
                <a rel="external" href="”><br />
                <li> 
                </a>
            </div>
     
            
        </div>
    
    					
    				</article> <!-- .et_pb_post -->
    
    		
    
    
    				<?php if (et_get_option('divi_integration_single_bottom')  ” && et_get_option(‘divi_integrate_singlebottom_enable’) == ‘on’) echo(et_get_option(‘divi_integration_single_bottom’)); ?>
    			
    wp_reset_query();
    	</div> <!-- #left-area -->
    
    			
    		</div> <!-- #content-area -->
    	</div> <!-- .container -->
    </div> <!-- #main-content -->

    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    OK, merci beaucoup de votre aide.

    J’essaie et je reviens dire le résultat

    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    OK, il faut que je rajoute un nouvel

    wp_reset_query();

    A la fin de single.php ?

    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    heu…
    Pardon, mais je ne comprends pas.
    Il y a un reset query à la fin du code inséré :

    “wp_reset_query();”

    Je devrais en mettre un autre ?

    en réponse à : Piratage (site dans le site) #978823
    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    J’avais déjà fait un gros nettoyage après l’attaque MailPoet.
    Manifestement, ce n’est pas assez.

    Organiser et modifier un nouveau thème est tellement long…
    Mais au final, ça en vaut la peine ! Merci pour tes conseils en tout cas et ton retour d’expérience !!

    en réponse à : Piratage (site dans le site) #978821
    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    Merci Flobogo. Je continue l’inspection ce soir.

    Cela fait deux fois que je suis “attaquée” : en juillet à cause de Mailpoet (cela étant, mise à part cette faille corrigée depuis, ce plugin est très bien) et en septembre avec ce site pirate….

    J’ai installé All in one WP security qui me semble assez complet.

    Je crois aussi que je vais changer de thème. J’avais acheté l’extension pour rendre Graphène Responsive. Mais au final, comme ce plugin a besoin d’un autre plugin pour fonctionner, cela fait 2 extensions en plus et autant de possibles failles.
    Je me demande si je ne vais pas passer directement à un thème responsive. mais cela veut dire, refaire tout le travail d’adaptation du thème enfant soit beaucoup d’heures passées. D’un autre côté, ça allège le site de plugins, ça en vaut peut-être la peine.

    Mais si c’est nécessaire à la sécurité… je vais le faire. :(

    en réponse à : Piratage (site dans le site) #978819
    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    Merci beaucoup pour toutes ces informations.
    Je vais donc passer au peigne fin mes fichiers.

    Et oui, il faut que je me rachète un nouveau PC à cause de ce fichu XP. Ca devient urgent.

    en réponse à : Piratage (site dans le site) #978817
    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    Un grand merci fge pour ta réponse.

    J’ai la dernière version de Mailpoet.

    Question bête : comment vérifier qu’il n’y ait pas un script malveillant dans les répertoires ?

    Je vais scanner mon pC, d’autant que je suis sous xp…

    en réponse à : [Résolu] Estore, traduction française #929197
    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    Rebonjour,

    En cherchant des réponses en anglais (car en français je n’ai rien trouvé), il apparaît qu’en rajoutant ce code au fichier functions.php on empêche les liens des images :

    function wpb_imagelink_setup() {
    2	    $image_set = get_option( ‘image_default_link_type’ );
    3	     
    4	    if ($image_set !== ‘none’) {
    5	        update_option(‘image_default_link_type’, ‘none’);
    6	    }
    7	}
    8	add_action(‘admin_init’, ‘wpb_imagelink_setup’, 10);

    Article sourceici
    Le problème c’est que le fichier functions.php est écrasé à chaque màj de thème, même avec un thème enfant.

    Quelqu’un aurait une astuce pour contourner cet obstacle ?

    Bonne soirée

    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    En fait, je pense que c’est possible parce qu’un réglage… ça se modifie… mais savoir comment, c’est le problème :rolleyes:

    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    Oui, effectivement en cliquant sur l’image d’un article, on peut mettre sur lier à “aucun”, mais je voulais le paramétrer en “masse” pour éviter de passer les 200 articles et les 200 images un par un…
    possible, mais fastidieux.

    Et dans la galerie, je n’ai rien trouver pour appliquer ce nouveau réglage à toutes les images en une fois…

    en réponse à : Supprimer l’encadré des images sur Graphène #966913
    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    Bon j’ai trouvé. En faisant des tests et en farfouillant dans style.css, il faut mettre 0px (au lieu de 4px) sur la ligne

    .entry-content img,
    .child-page img {
    	[b]border: 0px solid #e3e3e3;[/b]
    	margin: 5px;

    Merci Flobogo pour ton aide (même à cette heure tardive). Cela va me permettre de mieux connaître Firebug, ça peut toujours servir.

    en réponse à : Supprimer l’encadré des images sur Graphène #966912
    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    Après avoir essayé Firebug ne me dit pas grand chose sur mes images…

    Si vous avez d’autres idées… ça m’aiderait bien

15 sujets de 16 à 30 (sur un total de 138)