Olivier C (Créer un compte)

Toutes mes réponses sur les forums

15 sujets de 1 à 15 (sur un total de 401)
  • Auteur
    Messages
  • en réponse à : [Résolu] WP modifie les couleurs de mes photographies #2415029
    Olivier C
    Participant
    Chevalier WordPress
    429 contributions

    Les liens de la page pour les sources d’optimisation sont morts, mais les conseils restent valables.

    Si vous voulez vous épargner la peine de devoir nettoyer vos images à chaque upload sur votre site, vous pouvez utiliser un plugin tel que celui-ci : wp-smushit.

    Je déteste les plugins, mais celui-ci ne ralentira pas votre site : il ne travaillera pas constamment, mais seulement lors de l’upload de vos images (pour les nettoyer/compresser/etc., en fonction de votre configuration pour le plugin).

     

     

    en réponse à : [Résolu] WP modifie les couleurs de mes photographies #2414819
    Olivier C
    Participant
    Chevalier WordPress
    429 contributions

    Donc il s’agissait bien de la métadonnée color profil dont j’avais donné le lien plus haut… J’en étais presque sûr car j’avais été confronté à cela vers 2009-2010, quand j’ai commencé à coder.

    Lisez-ceci pour être au point : Alsacréations, D’où viennent les différences de couleurs entre mes images et mes background CSS ?

    en réponse à : Désactivation de l’API REST #2414765
    Olivier C
    Participant
    Chevalier WordPress
    429 contributions

    Merci. Oui j’avais vu passer le code sur Stack pour la personnalisation du slug. Mais au final je pense que je vais adopter une solution apache, je traiterais ainsi les pages d’images attachées de la même manière (car pour l’instant j’utilise le fichier image.php avec une redirection, c’est pas glop). Je ne suis pas chez moi pour tester mais je pense que je vais adopter un truc comme ça :

    # .htaccess

    RewriteRule ^wp-json.*$ 404.php

    Vu que je n’utilise pas de plugins…

    en réponse à : Désactivation de l’API REST #2414757
    Olivier C
    Participant
    Chevalier WordPress
    429 contributions

    C’est bon, j’ai trouvé : Safely disable WP REST API. Mais qu’est-ce que l’on ne ferait pas sans Stackoverflow…

    Du coup c’est trop cool l’activation de ces fonctionnalités par défaut (rire) : grâce à ça vos données sont exposées suite à une mise à jour sans que vous n’ayez rien demandé. Si vous êtes encore en versions 4.7.0 ou 4.7.1 n’importe qui peut modifier vos données sans avoir à s’authentifier (il y a eu un path à partir de 4.7.2).

    Bravo WordPress.

    • Cette réponse a été modifiée le il y a 1 année et 10 mois par Olivier C.
    en réponse à : Désactivation de l’API REST #2414732
    Olivier C
    Participant
    Chevalier WordPress
    429 contributions

    A mince, ce que j’ai publié plus haut est la version legacy du code pour WordPress < 4.7, maintenant c’est bien plus compliqué

    N’y a t’il pas plus simple ? Même si plus radical (comme par exemple supprimer toutes les fonctionnalités JSON sous WP) ?

    en réponse à : [Résolu] WP modifie les couleurs de mes photographies #2414697
    Olivier C
    Participant
    Chevalier WordPress
    429 contributions

    Bonjour,

    À tout hasard, vous devriez essayer de virer les métadonnées EXIF de l’image (certaines peuvent être liées au RVB).

    Il existe des outils en ligne pour lire et/ou supprimer ces données : lien.

    En effet, ces métadonnées liées aux couleurs peuvent être interprétées différemment d’un système à l’autre, d’un navigateur à l’autre.

    J’avais eu ce problème quand j’avais débuté dans le web…

    • Cette réponse a été modifiée le il y a 1 année et 10 mois par Olivier C.
    • Cette réponse a été modifiée le il y a 1 année et 10 mois par Olivier C.
    • Cette réponse a été modifiée le il y a 1 année et 10 mois par Olivier C.
    Olivier C
    Participant
    Chevalier WordPress
    429 contributions

    C’est plus sûrement une purge + réinstallation de PHP qui a dû faire la différence.

     

    Comme j’avais rétrogradé la version de PHP, à un moment donné j’avais perdu l’interprétation du code, le temps que je retrouve la commande sudo a2enmod php8.1 l’interprétation du code était revenue avec comme par magie la connexion à MySQL ! Et comme j’avais fait tout un tas de trucs entre temps, je ne peu que déduire que je m’en suis tiré avec une installation plus propre que celle de départ…

     

    A+

    • Cette réponse a été modifiée le il y a 1 année et 10 mois par Olivier C.
    • Cette réponse a été modifiée le il y a 1 année et 10 mois par Olivier C.
    Olivier C
    Participant
    Chevalier WordPress
    429 contributions

    Eurêka ! J’ai trouvé ! Malheureusement j’ai fait tellement de manip’ que je suis incapable de savoir ce qui a fait la différence. C’est malin…

    J’ai notamment revu les droits du dossier WordPress, suis repassé en php8.1.8, et surtout (peut-être) ai tapé cette commande :

    sudo a2enmod php8.1

    Je l’avais déjà tapé, mais peut-être pas au bon moment lors de l’installation de ma config.

     

    Bonne soirée.

    Olivier C
    Participant
    Chevalier WordPress
    429 contributions

    J’ai déjà ça : php-mysql et php8.1-mysql.

    Et par sécurité je viens de refaire un :

    sudo apt install apache2 \
    ghostscript \
    libapache2-mod-php \
    mysql-server \
    php \
    php-bcmath \
    php-curl \
    php-imagick \
    php-intl \
    php-json \
    php-mbstring \
    php-mysql \
    php-xml \
    php-zip

    • Cette réponse a été modifiée le il y a 1 année et 10 mois par Olivier C.
    • Cette réponse a été modifiée le il y a 1 année et 10 mois par Olivier C.
    Olivier C
    Participant
    Chevalier WordPress
    429 contributions

    Oui, MySQL est installé, j’ai déjà créé la base de donnée.

    Je viens de tenter votre idée avec PHP 8.0, mais cela ne change rien, du coup je viens de repasser en PHP 8.1.

    Olivier C
    Participant
    Chevalier WordPress
    429 contributions

    @mathieu42 : php-mysqli c’est pour les version égales ou inférieures à PHP 5.6, pour ma version PHP 8.1 je dois avoir php8.1-mysql et c’est le cas.

    • Cette réponse a été modifiée le il y a 1 année et 10 mois par Olivier C.
    • Cette réponse a été modifiée le il y a 1 année et 10 mois par Olivier C.
    Olivier C
    Participant
    Chevalier WordPress
    429 contributions

    @ferman : Non, mais je suis allé voir : c’est un topic qui rentre dans le premier cas décrit plus haut. LAMP, sans le savoir vous connaissez forcément : c’est acronyme pour désigner un environnement Linux/Apache/MySQL.

    • Cette réponse a été modifiée le il y a 1 année et 10 mois par Olivier C.
    • Cette réponse a été modifiée le il y a 1 année et 10 mois par Olivier C.
    Olivier C
    Participant
    Chevalier WordPress
    429 contributions

    Ok, il faut creuser du côté de wp_get_attachment_metadata()…

    en réponse à : [Résolu] Traduction d’un plugin #1599698
    Olivier C
    Participant
    Chevalier WordPress
    429 contributions

    Bien vu Sébastien. J’allais publier la réponse justement dans ce but.

    en réponse à : Traduction non prise en compte #1571792
    Olivier C
    Participant
    Chevalier WordPress
    429 contributions

    @Benzouye : Oui, c’est automatique, d’ailleurs les traductions ajoutées postérieurement à cet item se chargent sans problème.

    La traduction dans son ensemble : fr_FR.po.

    Les lignes sources : Github.

    https://github.com/Scriptura/ScripturaTheme/blob/master/Functions/FunctionUsers.php#L132

15 sujets de 1 à 15 (sur un total de 401)