mycroft

Toutes mes réponses sur les forums

15 sujets de 1 à 15 (sur un total de 29)
  • Auteur
    Messages
  • en réponse à : Problème pour partager certains articles sur facebook #2245533
    mycroft
    Participant
    Initié WordPress
    37 contributions

    Le problème de facebook est qu’ils changent pleins de droits pour pouvoir en savoir toujours plus sur les connectes.
    C’est pour cela que j’ai abandonner la plupart des passerelles wordpress/facebook…
    Toujours a changer leur algorithme …. ça commençait à Etre fatigant.

     

    en réponse à : Problème pour partager certains articles sur facebook #2245428
    mycroft
    Participant
    Initié WordPress
    37 contributions

    Ha … tu es sur jetpack enfin wordpress.com ou un truc comme ça … la par contre je ne sais pas comment on fait … J’ai toujours utiliser mes wordpress avec de vrai hébergeurs ou on peut faire ce qu’on veut. Je pense que si tu leur écris peut être qu’ils peuvent te répondre pour ça dire que tu veux changer la forme des permaliens.

     

    en réponse à : Problème pour partager certains articles sur facebook #2245421
    mycroft
    Participant
    Initié WordPress
    37 contributions

    Bonjour,

    oui j’ai résolu le problème, en fait facebook étant sourd a toutes réclamations, il a fallu que je cherche et donc la solution est de changer les permaliens.
    Il faut choisir ceux qui mettent seulement le nom de la rubrique dans le lien et tout va bien. Apparemment c’est la forme avec la date dans le permalien qui fout la zone.

    en réponse à : serveur rtmp #2228416
    mycroft
    Participant
    Initié WordPress
    37 contributions

    Bonjour
    Je demande pour utiliser un add on wordpress, car apparemment pour tout ce qui est tchat vidéo il en faut un. Donc par extension cela a un réel rapport avec wordpress, il doit bien y avoir des gens qui ont installer un tchat video sur leur wordpress dessus.
    Enfin si vous trouvez que c’est hors sujet c’est pas un problème, je finirais bien par trouver quelqu’un qui s’en sert et qui pourra m’orienter.
    Merci

    en réponse à : [Résolu] Problème affichage après mise a jour du thème graphène #1930070
    mycroft
    Participant
    Initié WordPress
    37 contributions

    salut a toi bon deja rien ne fonctionne ca veut dire quoi ? tu as quoi comme erreur ? c’est quoi l’adresse de ton site ?

    en réponse à : [Résolu] Problème affichage après mise a jour du thème graphène #1929632
    mycroft
    Participant
    Initié WordPress
    37 contributions

    Merci !!!

    Tu peux me dire comment tu fais pour associer si vite un problème à une page ? Parce que du coup je suppose que le souci dans mon diaporama qui n’a pas son image ni son cadre noir bien centré ça doit aussi venir du css ?
    merci encore

    en réponse à : Intégrer Woocommerce dans le thème graphène #1799276
    mycroft
    Participant
    Initié WordPress
    37 contributions

    bonjour,

    je sais que c’est un vieux sujet mais vu que je viens d’avoir le même problème et que j’ai eu un peu de mal a trouver je me permet de mettre un message.

    Donc dans le cas de graphene et woocommerce il faut copier dans ton theme principal page.php ensuite tu le copies dans ton thème enfant et tu l’appelle woocommerce.php

    <?php
    /**
     * The Template for displaying all single pages.
     */
    
    get_header(); ?>
    
    <?php woocommerce_content(); ?>
                
    <?php get_footer(); ?>
    woocommerce.php

    Ensuite tu vas dans ton fichier fonctions.php qui est dans ton thème enfant et tu rajoute comme ligne : add_theme_support( ‘woocommerce’ );

    et voila pour moi ça a marché. Ma colonne de droite a retrouver sa place.

     

    en réponse à : [Résolu] Intégrer un programme en php sur wordpress #1707769
    mycroft
    Participant
    Initié WordPress
    37 contributions

    re bonjour

    J’ai continuer a chercher et du coup j’ai penser a contourner le problème en créant une simple page avec un choix et qui m’enverrait sur mon premier fichier  formulaire_priere.php (je mettrais le fichier dans un message en dessous)

    Cela bloque et me dit que la page ne fonctionne pas, comme precedement. Par contre histoire de voir plus loin j’ai zapper ce fichier et ai envoyer le formulaire de la page sur mon 2eme fichier priere_ange.php et la cela semble fonctionner.

    J’ai tester en local et le fichier formulaire_priere fonctionne mais ne veux pas afficher la page de mon thème correctement. Alors que si je sélectionne un choix il m’envoi bien sur priere_ange.php et cette page par contre est correctement intégré au thème. Donc est ce que dans mon code du premier fichier il y a quelque chose qui ne veux pas passer avec wordpress ?

    <? php
    require('wp-blog-header.php');
    include $_SERVER['DOCUMENT_ROOT']."/wp-content/themes/graphene/header.php";
    
    ?>
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>Prières Amour, Argent, Santé et Travail</title>
    
    </head>
     
    <body>
    <?php
    include("connexionpriere.php");
    $cat=$_POST['category'];
    
    ?>
    
    Vous avez choisi : <?php echo $cat; ?>
    <form method="post" action="priere_ange.php">
     
        <label for="ange">Vous recherchez une prière de quel ange ?</label><br />
         <select name="ange">
    
    <?php
     
    $reponse = $pdo->query('SELECT ange FROM ange_priere');
     
    while ($donnees = $reponse->fetch())
    {
    ?>
               <option value="<?php echo $donnees['ange']; ?>"> <?php echo $donnees['ange']; ?></option>
    <?php
    }
    ?>
    </select>
    <input type="submit" value="Valider" />
    </form>
    </body>
    </html>
    <?php
    require('wp-blog-header.php');
    include $_SERVER['DOCUMENT_ROOT']."/wp-content/themes/graphene/footer.php";
    ?>
    formulaire_priere.php

    Ceci est le fichier qui semble avoir un soucis

    <?php
    
    $resultat=$_POST['ange'];
    
    function priere_amour($ange) {
    	include("connexionpriere.php");
    $reponse = $pdo->prepare(
    	'SELECT priere1 FROM ange_priere WHERE ange= :ange && amour= 1');
    $reponse ->execute(['ange' => $_POST['ange']]);
    $donnees = $reponse ->fetch();
    return $donnees['priere1'];
    }
    {
    ?>
    
        <p>
    
        L'ange concerne est : <strong><?php echo $resultat; ?></strong>, et la priere est : <br>
    
        <?php echo (priere_amour([$_POST],1)); ?>
     
    <?php
    }
    ?>
    priere_ange.php

    ceci est mon 2eme fichier qui normalement vient après formulaire_priere.php

     

     

    en réponse à : [Résolu] Intégrer un programme en php sur wordpress #1706515
    mycroft
    Participant
    Initié WordPress
    37 contributions

    Arg pardon mon message precedant le code a disparue quand j’ai envoyer ..

    Je le remets :

    Bonjour

    Ma configuration WP actuelle :

    – Version de WordPress : 4.8.1
    – Version de PHP/MySQL : 5.6.25 / 5.7.14
    – Thème utilisé : Graphene child
    – Extensions en place : AWSM Team (1.1.1), Category Posts Widget (4.7.2), Forum_wordpress_fr (4.1)
    – Adresse du site : http://testphp
    – Nom de l’hébergeur : Apache/2.4.23 (Win64) PHP/5.6.25

    Problème(s) rencontré(s) :

    Je suis actuellement en local et je développe un programme en php pour mon site. Je souhaite passer cela ensuite sur mon site en production.

    J’ai un soucis d’intégration de ces fichiers php avec wordpress.
    J’en ai deja développer un qui a été beaucoup plus facile, en effet je faisais un simple formulaire et j’envoyais directement sur mon fichier pho et c’est passer du premier coup.
    Cette fois ci c’est plus compliquer, j’utilise un formulaire en liste déroulantes, mais la liste se rempli en lisant dans une table pour avoir les différentes options. Donc du coup je dois directement partir sur un fichier php et non plus passer par une page simple avec un formulaire.

    J’essaye d’appeler directement mon fichier machin.php par l’url et comme cele en local il n’y a aucun problème, par contre quand je teste la même chose en production sur mon hébergeur gandi ma page m’affiche un merveilleux

    Impossible de traiter cette demande via www.mediumnitemagnetisme.org à l’heure actuelle.

    HTTP ERROR 500

    Bref de toute facon cette methode ne m’interresse que pour developper et voir si mon programme fonctionne, car il s’execute sur une page vierge et sans utiliser le skin de mon theme.

    Donc j’ai ete faire des recherches sur internet. J’ai trouver une méthode qui utilise en Template mon premier fichier php (celui qui appelle le formulaire). J’ai bien mon formulaire mais il envoi une nouvelle fois sur une page blanche sans mon theme et en plus quand je valide le formulaire il refuse de charger la 2eme page qui traite ma variable. Car je passe par une page et le permalien embrouille le tout.

    2eme methode celle de transformer en plugin. C’est, je l’avoue celui qui me semblait le plus logique. Sauf que je suis aller voir les tutos et quand je mets les codes comme j’ai trouver sur open classroom par exemple sur plusieurs de leurs cours, mon formulaire s’affiche tout a fait en haut a gauche de ma page bien et cela ressemble a rien. par contre il est formidablement bien intégrer avec mon thème en niveau couleurs etc 🙂
    Par contre quand je valide un choix j’ai ceci :
    Erreur 404. Page Non Trouvée.

    Désolé, j’ai bien regardé partout sans trouver la page recherchée.

    Si vous suivez un lien d’un autre site, la page a peut-être été renommée ou déplacée. Vous devriez essayer une recherche sur la page désirée.

     

    Je pense que c’est sur cette méthode qu’il faut que je continu, mais je n’arrive pas a trouver d’info en français (et oui c’est ca aussi le problème, pour des trucs aussi précis mon anglais est un peu limite)
    Donc je suppose que je peux dire ou je veux mettre l’affichage de mon plugin, et lui indiquer aussi ou envoyer sa réponse quand je valide mon formulaire puisqu’apparement le  <form method=”post” action=”priere_ange_cible.php”> ne fonctionne pas ( il semble chercher une page et pas un fichier php)

    Par contre je ne sais pas si je dois vous mettre les contenus de mes fichiers php ? Si cela peut vous aider a m’orienter ?
    Bon comme ils sont assez courts je pense que je peux cela ne devrait pas perturber le post.
    Je vous remercie d’avance

    en réponse à : [Résolu] Soucis avec hébergement OVH #1679577
    mycroft
    Participant
    Initié WordPress
    37 contributions

    J avais compris le thème de base, pas celui enfant …  le thème book-rev-lite j’avais pas compris un thème autre. Mais bon c’est résolu et je te remercie.

    en réponse à : [Résolu] Soucis avec hébergement OVH #1671951
    mycroft
    Participant
    Initié WordPress
    37 contributions

    Les erreurs je sais pas gérer surtout que la dans cette version avec le thème de base moi je n’ai rien touché. C’est les fichiers totalement de base.
    Je viens d’avoir une illumination, j ai mis un autre thème, un de base et ça marche…
    Du coup j’ai réinstaller le thème book-rev-lite puis mon thème enfant que j’ai fait .. et ça fonctionne.
    Non je ne suis pas fou, vous aussi vous avez bien vu que ça ne marchait pas tout a l heure ….
    J’avais deja réinstaller comme ça, la seule chose que j’avais pas faite c’est mettre un thème de base entre les 2. Je comprend pas … Enfin c’est cool mais ca va me perturber un moment cette histoire.
    Si t’as une explication je suis preneur.
    Mais en tout ça merci de t’être interresse a mon problème, surtout que du coup ca a fait perdre du temps a tout le monde pour rien … J’suis désolé.

    en réponse à : [Résolu] Soucis avec hébergement OVH #1671122
    mycroft
    Participant
    Initié WordPress
    37 contributions

    avec le thème par défaut même truc : http://test.plume-direct.fr/

    Sauf que du coup tu es obliger de cliquer sur l article pour le voir car j’avais du changer du code pour pouvoir avoir les articles en entier sur ce theme, sinon il mettait que le résumé même en changeant les options de base.

    Et pour passer les fichiers, je l’ai fait a la main proprement, c’est a dire que j’ai installer wordpress, puis recopier juste le thème enfant et refais les articles. Comme si j’installais un nouveau site et pour tester au cas ou ca vienne justement d un problème de copie, j’ai effacer mon site gandi et fait pareil réinstaller wordpress et la même chose que sur ovh.

     

    en réponse à : [Résolu] Soucis avec hébergement OVH #1670891
    mycroft
    Participant
    Initié WordPress
    37 contributions

    Merci de ta réponse, donc j’ai essayer les 2. Shortcode ultimate donne pareil (1er exemple dans le message)
    tabs responsive donne un peu mieux, deja je n’ai plus les textes dessous, par contre on a beau cliquer sur les tab il ne fait rien

    voila les resultats gandi chez qui ca marche : http://test.esocculte.com/

    ovh où ca ne fonctionne toujours pas : http://test.plume-direct.fr

    Ca vous inspire quoi ? c’est un truc de fou …

    en réponse à : [Résolu] Ajouter un slogan avec un logo #1670205
    mycroft
    Participant
    Initié WordPress
    37 contributions

    Pour info (ça peut toujours servir aux autres) j’ai été changer la version de php, je l’ai mise en 5.6 comme sur les autres, et c’est la même chose, bon certes ça fonctionne du coup mais j’aimerais comprendre pourquoi sur un clone les choses ne fonctionnent pas pareil sur ovh.
    Bon j”ai toujours mon problème de jquery et le support d ovh ne veux pas me répondre en disant que c’est un problème de développement de site, alors que c’est juste une question de pourquoi chez eux ça ne passe pas.

     

    en réponse à : [Résolu] Ajouter un slogan avec un logo #1670031
    mycroft
    Participant
    Initié WordPress
    37 contributions

    bonjour c’est la  Version de PHP/MySQL : 7.0.17 / 5.5.55

    Donc en fait ça a fonctionner mais absolument pas dans Apparence/Widget comme sur mon local et gandi mais dans les widget directement. Je viens de m”apercevoir de ça en allant rajouter un widget …

     

15 sujets de 1 à 15 (sur un total de 29)