moniquewp (Créer un compte)

Toutes mes réponses sur les forums

11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • en réponse à : santé du site : pb avec API rest #2454564
    moniquewp
    Participant
    Initié WordPress
    16 contributions

    Bonjour,

    dans ce cas je parviens à accéder à wp-admin et donc ce n’est pas la même erreur.

    mais en effet, j’ai eu ces pbs d’accès à wp-admin que je n’ai plus actuellement en me connectant et déconnectant de wp-admin systématiquement. Je croise les doigts.

    mais l’accès est très lent ainsi que la prise en compte des modifications.

    cdt

    Monique

    moniquewp
    Participant
    Initié WordPress
    16 contributions

    Bonjour,

    Je reviens vers vous pour des erreurs qui perdurent en utilisant local by flywheel.
    L’an dernier quand j’ai suivi la formation wordpress, je n’avais eu aucun pb avec local et avait construit en local un premier petit site en local avec plusieurs types de contenus et de plugins.
    Depuis avril 2023, j’ai voulu créer un nouveau site destiné à être hébergé chez un hébergeur pour une entreprise qui se lance mais j’ai rencontré de multiples erreurs en créant ce nouveau site sans que je n’arrive à comprendre comment elles se produisent faisant tout pour que de telles erreurs ne se produisent (login et logout de wp-admin, start/stop de mon site sous local, sauvegarde des mes modifications).
    La plupart de ces erreurs se manifestent par une inaccessibilité à wp-admin de local empêchant toute modification du site en construction.
    J’ai trouvé une parade qui est de cloner le site non accessible par wp-admin et je retrouve l’accès à wp-admin au site clooné.
    J’ai même perdu l’accès à mon site d’essai de 2022 en wp-admin car en me loggant avec le même nom d’admin mon mot de passe n’est plus accepté alors que je ne l’ai pas changé; je n’arrive qu’à ouvrir ce site.
    J’ai donc réussi à le récupérer mais rien ne m’assure que les erreurs de non lancement de wp-admin ne vont pas recommencer.

    Donc j’ai deux demandes :
    – comment rétablir l’accès à wp-admin voir même réparer les sites d’origine devenus inaccessibles soit en wp-admin soit en open site? quels fichiers dois je aller consulter ? quelles vérifications dois y faire (par exemple pour le mot de passe d’admin qui aurait été modifié alosr que je n’y ai pas touché)?
    – comment développer de manière fiable avec wordpress? quels autres outils me conseillez vous sans investir trop de frais?

    En complément, j’ai une erreur récurrente de sur tous mes sites avec la dll php_imagick.dll qui semble introuvable alors qu’elle existe bien dan le répertoire où elle est recherchée soit C:\Users\mgibe\AppData\Roaming\Local\lightning-services\php-7.4.30+5\bin\win64\ext.

    Je ne suis pas une spécialiste de développement de sites web mais mon expérience de plusieurs années dans le domaine du développement informatique et du debug me facilitent la compréhension des réponses si elles sont clairement expliquées.

    Merci beaucoup de vos retours avisés. je compte bien arriver coûte que coûte à produire des sites WEB WordPress.

     

    • Cette réponse a été modifiée le il y a 1 année par moniquewp.
    moniquewp
    Participant
    Initié WordPress
    16 contributions

    Suite de mes recherches.

    1) en cherchant dans le logs j’ai constaté un pb avec le chargement de la dll php_imagick.dll. or elle existe bien dans le répertoire. Je ne comprens pas le pb. L’erreur est affichée comme suit dans la pièce jointe. J’ai vu sur des forums que c’était un pb de format de l’extension imagick dans le fichier php.ini mais je ne sais pas si c’est celà.

    2) par ailleurs, j’ai  essayé de créer un nouveau site et j’ai sur la santé de mon site cette erreur que je ne sais pas résoudre

    Lors du test de l’API REST, une erreur s’est produite :

    Point de terminaison de l’API REST : http://essai.local/wp-json/wp/v2/types/post?context=edit
    Réponse de l’API REST : (http_request_failed) cURL error 28: Operation timed out after 10003 milliseconds with 0 bytes received

    pouvez vous m’aider.

    J’ai quand même l’impression que ca vient des mises à jour que j’ai faites et que ca fonctionnait impeccablement l’an passé avec les anciennes version de wordpress, php et local.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    moniquewp
    Participant
    Initié WordPress
    16 contributions

    Merci pour l’info.

    Mon problème n’est pas entièrement réglé.

    Car parfois je me retrouve avec des erreurs diverses : bad gateway.
    J’arrive tout de même à accèder au site (je suis toujours en local).
    En revanche,  j’ai eu de la part de mon antivirus malwarebytes (très bon antivirus) un blocage car il a détecté un ransonmware dans php-cgi.exe depuis que j’ai réinstallé l’outil local.
    Que dois je faire pour arranger le problème car l’installation de php est due à l’installation de la dernière version de local by flywheel.
    Que me conseillez vous de faire si je veux développer un site avec wordpress de manière sécurisée?

    Cdt

    • Cette réponse a été modifiée le il y a 1 année par moniquewp.
    moniquewp
    Participant
    Initié WordPress
    16 contributions

    J’ai réinstallé local et ça a fonctionné

    j’ai importé le site que j’avais créé mais j’ai dû le renommer

    je chercherai comment le réutiliser avec son nom d’origine.

     

    en tous les cas j’ai tout récupéré.

     

    merci pour votre aide.

    moniquewp
    Participant
    Initié WordPress
    16 contributions

    Je vais essayer demain.

    sinon que me conseillez vous autre que local pour utiliser WordPress?

    merci

    moniquewp
    Participant
    Initié WordPress
    16 contributions

    et enfin en lançant wp admin j’ai un message du même acabit
    <h1>Error establishing a database connection</h1>
    This either means that the username and password information in your wp-config.php file is incorrect or that contact with the database server at localhost could not be established. This could mean your host’s database server is down.

    • Are you sure you have the correct username and password?
    • Are you sure you have typed the correct hostname?
    • Are you sure the database server is running?

    If you are unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.

    moniquewp
    Participant
    Initié WordPress
    16 contributions

    je viens enfin d’avoir un message en lancant open site

    error establihing a database connection

    moniquewp
    Participant
    Initié WordPress
    16 contributions

    je vois aussi en ouvrant open site shell l’erreur suivante

    Setting Local environment variables…
    —-
    WP-CLI: Warning: PHP Startup: Unable to load dynamic library ‘php_imagick.dll’ (tried: C:/Users/mgibe/AppData/Roaming/Local/lightning-services/php-7.4.30+5/bin/win64/ext\php_imagick.dll (Le module sp├®cifi├® est introuvable.), C:/Users/mgibe/AppData/Roaming/Local/lightning-services/php-7.4.30+5/bin/win64/ext\php_php_imagick.dll.dll (Le module sp├®cifi├® est introuvable.)) in Unknown on line 0
    WP-CLI: WP-CLI 2.7.1
    Composer: Warning: PHP Startup: Unable to load dynamic library ‘php_imagick.dll’ (tried: C:/Users/mgibe/AppData/Roaming/Local/lightning-services/php-7.4.30+5/bin/win64/ext\php_imagick.dll (Le module sp├®cifi├® est introuvable.), C:/Users/mgibe/AppData/Roaming/Local/lightning-services/php-7.4.30+5/bin/win64/ext\php_php_imagick.dll.dll (Le module sp├®cifi├® est introuvable.)) in Unknown on line 0
    Composer: Warning: PHP Startup: Unable to load dynamic library ‘php_imagick.dll’ (tried: C:/Users/mgibe/AppData/Roaming/Local/lightning-services/php-7.4.30+5/bin/win64/ext\php_imagick.dll (Le module sp├®cifi├® est introuvable.), C:/Users/mgibe/AppData/Roaming/Local/lightning-services/php-7.4.30+5/bin/win64/ext\php_php_imagick.dll.dll (Le module sp├®cifi├® est introuvable.)) in Unknown on line 0
    Composer: Composer version 2.1.5 2021-07-23 10:35:47
    PHP: Warning: PHP Startup: Unable to load dynamic library ‘php_imagick.dll’ (tried: C:/Users/mgibe/AppData/Roaming/Local/lightning-services/php-7.4.30+5/bin/win64/ext\php_imagick.dll (Le module sp├®cifi├® est introuvable.), C:/Users/mgibe/AppData/Roaming/Local/lightning-services/php-7.4.30+5/bin/win64/ext\php_php_imagick.dll.dll (Le module sp├®cifi├® est introuvable.)) in Unknown on line 0
    PHP: 7.4.3
    MySQL: mysql Ver 8.0.16 for Win64 on x86_64 (MySQL Community Server – GPL)

    moniquewp
    Participant
    Initié WordPress
    16 contributions

    je vous joins le fichier des copies d’écran en version pdf. Tous mes fichiers sont analysés par un antivirus à jour malwarebytes et sont sans virus.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    moniquewp
    Participant
    Initié WordPress
    16 contributions

    Oui d’accord  je suis désolée.
    J’ai cherché un peu dans des logs dont local-lightning et en voici les premières lignes:
    {« thread »: »main », »class »: »Process », »process »: »mysql », »level »: »warn », »message »: »2023-04-27T16:43:06.535903Z 0 [System] [MY-010116] [Server] %%resourcesPath%%\\lightning-services\\mysql-8.0.16+6\\bin\\win64\\bin\\mysqld.exe (mysqld 8.0.16) starting as process 13224″, »timestamp »: »2023-04-27T16:43:08.957Z »}
    {« thread »: »main », »class »: »Process », »process »: »mysql », »level »: »warn », »message »: »2023-04-27T16:43:06.537565Z 0 [Warning] [MY-013243] [Server] –character-set-server: The character set UTF8MB3 is deprecated and will be removed in a future release. Please consider using UTF8MB4 instead. », »timestamp »: »2023-04-27T16:43:08.958Z »}
    {« thread »: »main », »class »: »Process », »process »: »mysql », »level »: »warn », »message »: »2023-04-27T16:43:08.955593Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed. », »timestamp »: »2023-04-27T16:43:08.958Z »}
    {« thread »: »main », »class »: »Process », »process »: »mysql », »level »: »warn », »message »: »2023-04-27T16:43:08.957115Z 0 [ERROR] [MY-010262] [Server] Can’t start server: Bind on TCP/IP port: Une seule utilisation de chaque adresse de socket (protocole/adresse r seau/port) est habituellement autoris e. », »timestamp »: »2023-04-27T16:43:08.959Z »}
    {« thread »: »main », »class »: »Process », »process »: »mysql », »level »: »warn », »message »: » », »timestamp »: »2023-04-27T16:43:08.959Z »}
    {« thread »: »main », »class »: »Process », »process »: »mysql », »level »: »warn », »message »: » », »timestamp »: »2023-04-27T16:43:08.960Z »}
    {« thread »: »main », »class »: »Process », »process »: »mysql », »level »: »warn », »message »: »2023-04-27T16:43:08.957121Z 0 [ERROR] [MY-010257] [Server] Do you already have another mysqld server running on port: 10008 ? », »timestamp »: »2023-04-27T16:43:08.961Z »}
    {« thread »: »main », »class »: »Process », »process »: »mysql », »level »: »warn », »message »: »2023-04-27T16:43:08.957323Z 0 [ERROR] [MY-010119] [Server] Aborting », »timestamp »: »2023-04-27T16:43:10.298Z »}

11 sujets de 1 à 11 (sur un total de 11)