katia jarne (Créer un compte)

Toutes mes réponses sur les forums

15 sujets de 1 à 15 (sur un total de 25)
  • Auteur
    Messages
  • karpediem63
    Participant
    Initié WordPress
    33 contributions

    Bonjour,

    Le support de Addons Premium me dit que la fonctionnalité n’est pas implémentée pour le moment, ce qui veut dire qu’il n’est pas possible d’utiliser une page créée avec leur plugging de blog comme « Page de Blog », inutile de chercher ;-(

    Néanmoins, ne serait-il pas possible d’ajouter un bout de code (j’imagine dans index.php) qui réorienterait l’affichage vers cette page perso dans le genre « si la page demandée est ‘archive’ ou ‘category’ ou ‘blog’ => afficher ‘ma page perso’ ?

    Merci et très belle journée ensoleillée

    en réponse à : [Résolu] mes conteneurs elementor ne se mettent pas en pleine largeur #2462948
    karpediem63
    Participant
    Initié WordPress
    33 contributions

    ça y est, j’ai trouvé où je merdouillais !!!

    Il faut bien paramétrer le conteneur de page de Astra accessibles soit à partir de personnaliser, soit à partir de modifier / paramètres Astra.

    Ce qui est un peu déroutant, c’est de comprendre comment ça communique entre Elementor et Astra, qui prend le dessus sur qui ? Clairement, je ne suis pas encore au point ;o))

    Si ça peut aider quelqu’un…

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    en réponse à : [Résolu] mes conteneurs elementor ne se mettent pas en pleine largeur #2462946
    karpediem63
    Participant
    Initié WordPress
    33 contributions

    Bonjour,

    Alors moi j’ai un problème similaire, de Flexbox à 100% qui se comporte comme si c’était un Flexbox encadré.

    J’ai fait 2 pages pour essayer de comprendre ce qui pouvait générer ce comportement :

    J’ai simplement mis 2 conteneurs Flexbox dans chaque page et j’ai bien pris soin de construire mes 2 pages avec un thème Elementor Full width.

    J’utilise le thème Astra.

    La page Bad_flexbox est en fait une page de test que j’avais créée avant l’activation des Flexbox dans Elementor. J’ai juste supprimé les sections et ajouté des containers Flexbox, mais bizarrement ça ne se comporte pas correctement. Du coup j’ai fais une nouvelle page et ça se passe bien.

    J’ai regénéré les fichiers via l’outil Elémentor mais sans succès. Le problème c’est que je souhaiterai passer toutes mes pages en conteneur Flexbox plutôt qu’en section et ça m’embêterait d’avoir à refaire toutes mes pages, j’aimerai autant comprendre ce qui se passe.

    Si vous avez une idée, je serai ravie de les tester

    Un grand MERCI et très belle journée !

    en réponse à : Erreur 403 depuis quelques jours sur mon site #2364024
    karpediem63
    Participant
    Initié WordPress
    33 contributions

    Bonjour à tous,

    Après quelques jours, je reviens vers vous car mon problème n’est pas encore résolu…

    Je me suis attelée au « désindexage » des url dans Google, c’est comme ça que j’ai remarqué que j’avais un robots.txt virtuel avec le code suivant :

    User-agent: *
    Allow: /
    Sitemap: https://www.haubanconseil.com/sitemap.xml
    Sitemap: https://www.haubanconseil.com/sitemap_1.xml
    Sitemap: https://www.haubanconseil.com/sitemap_2.xml
    Sitemap: https://www.haubanconseil.com/sitemap_3.xml
    Sitemap: https://www.haubanconseil.com/sitemap_4.xml
    Sitemap: https://www.haubanconseil.com/sitemap_5.xml
    Sitemap: https://www.haubanconseil.com/sitemap_6.xml

    Les fichiers sitemap* sont également virtuels et chacun contient une liste d’url venues de je ne sais où…

    J’ai fait un sitemap.xml et un robots.txt que j’ai envoyé via FTP sur mon ovh, en pensant que ce serait ok…
    Le problème est que lorsque je transfère mon fichier robots.txt via filezilla, j’ai le message « transfert réussit », je vois bien mon fichier dans l’arborescence, mais dès que j’actualise la liste de mes fichiers, sans avoir rien fait d’autre, mon robots.txt disparait de la liste et il n’existe vraiment plus physiquement, du coup c’est le robots.txt virtuel injecté par les hackeurs qui est pris en compte !
    ça parait vraiment étrange, mais c’est vraiment ce qui se produit. Lorsque je renvoie mon robots.txt, je n’ai pas de message comme quoi il existe déjà, si je veux le remplacer etc. et encore une fois il disparaît…
    Je n’ai pas rencontré ce problème avec les fichiers sitemap.xml que je peux transférer et même consulter via l’url https://www.haubanconseil.com/sitemap.xml et vérifier que c’est le bon.
    Je dis « les fichiers » car en attendant de pouvoir résoudre mon problème, j’ai dupliqué mon fichier sitemap.xml pour en faire 6 copies, je les ai nommés comme dans le robots.txt virtuel des hackeurs, en espérant qu’ils soient pris en compte au lieu de ceux injectés par le hackeur.

    Maintenant, je cherche à trouver comment et où la création de ce fichier virtuel robots.txt a lieu (j’ai regardé dans le functions.php de wordpress, il y a le code de base) et pourquoi je ne peux pas ajouter le mien via FTP.
    Comme j’ai fait un réinstallation de wordpress via FTP, je n’ai plus les dates des fichiers modifiés pour les étudier…

    Quelqu’un aurait svp une idée ??
    Merci

     

    P.S : je devrais peut-être faire un autre sujet pour ce problème ?

    en réponse à : Erreur 403 depuis quelques jours sur mon site #2360628
    karpediem63
    Participant
    Initié WordPress
    33 contributions

    1- Ok pour le passage à la 7.3, je vais le faire… J’avais peur que wordPress n’aime pas ;o))

    2- Mon instruction dans .htaccess ne doit pas être bonne ou je ne l’ai pas mise au bon endroit car je vois toute l’arborescence et les fichiers de mes répertoires ;o(((

    3- Pour ce qui est de la consultation des logs…

    J’ai demandé les logs FTP, là c’est bizarre car je n’ai que 2 entrées disponibles, postérieures au 19…

    De plus, ça ne correspond même pas à mes propres actions qui ont été effectuées les 22 et 23, alors que là j’ai l’impression qu’il me propose l’activité du 20 et du 21… (copie d’écran jointe)

    Concernant les autres fichiers de logs, les ERRORS et WEB (copies d’écran également jointes). Est-ce que ce sont les fichiers que j’ai surlignés que je dois consulter pour une activité du 19 ?

    J’ai tout de même ouvert les fichiers correspondants, mais franchement, je n’y comprends rien ;o((( ça doit être mon côté blonde ;o))

    Sur celui concernant les logs WEB, j’ai vu des mises à jours de données, mais ça, c’est normal, il y a bien eu des mises à jours d’articles, mais pour le reste, je ne sais même pas ce que je dois chercher…

    Auriez-vous svp une suggestion pour orienter mes recherches ?

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    en réponse à : Erreur 403 depuis quelques jours sur mon site #2360603
    karpediem63
    Participant
    Initié WordPress
    33 contributions

    Bonjour à tous,

    Déjà un grand MERCI !!!

    Je reviens pour faire un retour des fois que ça puisse aider à d’autres…

    Donc oui, visiblement mon site a été hacké ;-(( Grace au retour de @pasglop, j’ai fait plus attention aux fichiers suspects et notamment, comme je l’avais précisé précédemment :

    • un fichier rindex.php sur “www” qui n’a pas lieu d’être dans wordPress
    • des .htaccess dans tous les répertoires à la racine de wp-admin, wp-content et wp-includes ; mais aussi dans d’autres répertoires
    • des fichiers avec des codes bizarres

    Ces nouveaux fichiers portaient tous la date du 19/11/2020

    • j’ai cherché tous les fichier ajoutés de cette date et je les ai supprimés
    • pour les fichiers modifiés à cette date, j’ai chargé le fichier de la dernière version de wordPress. Cette dernière opération n’est peut-être pas garantie, mais c’était un risque à prendre pour ne pas conserver un fichier hacké
    • j’ai supprimé tous les répertoires /cache/ que j’ai trouvé dans /www/
    • j’ai modifié mon code d’accès à OVH, à ma Base de Données, à mon FTP et à mon WordPress
    • j’ai fait le ménage dans mes users comme conseillé dans le lien https://wpfr.net/support/sujet/solutions-de-depannage-pour-un-site-hacke-pirate/

    Dès que j’ai eu accès à mon admin, je me suis empressée de mettre à jour mon wordPress et mes extensions dans les règles de l’art.

     

    Avant de mettre [Résolu] j’aurai quelques petites questions…

    1- Lorsque je demande une mise à jour de WordPress via mon admin, est-ce que si j’ai oublié un fichier qui pourrait éventuellement être un malware, sera-t-il supprimé ? Est-ce que la mise à jour ne fait qu’écraser les anciens fichiers avec les nouvelles versions ou est-ce que la mise à jour refait une installation propre ?

    2- Après avoir fait ma « remise à niveau », j’ai repassé l’outil fourni par @pasglop (https://sitecheck.sucuri.net/results/https/www.la-marine-immobilier.com) en espérant bien entendu qu’il me dise « BRAVO, tu as bien travaillé !! », mais non, j’ai tout de même un diagnostic « Medium Security Risk » car la version de PHP utilisée est inférieure à 7.2.31 ET que je n’ai pas désactivé la visualisation du contenu des répertoires, avec j’imagine un « Options – Indexes » dans .htaccess.

    J’ai ajouté dans mon .htaccess de /www/ avec une instruction magique (j’aime bien les instructions magiques ;o)))

    <IfModule mod_autoindex.c>
    Options -Indexes
    </IfModule>

    Encore Merci

    
    

     

    • Cette réponse a été modifiée le il y a 3 années et 7 mois par karpediem63.
    • Cette réponse a été modifiée le il y a 3 années et 7 mois par karpediem63.
    en réponse à : Erreur 403 depuis quelques jours sur mon site #2360543
    karpediem63
    Participant
    Initié WordPress
    33 contributions

    Via FTP, j’ai vu plusieurs fichiers qui datent du 19/11/2020 qui n’étaient pas là avant, notamment

    • rindex.php sur « www »
    • des .htaccess sur wp-admin, wp-content et wp-includes

    Comment peut-on encore se faire hacker avec leur système (super chiant soit dit en passant) de double identification ?

    Je vais supprimer tous ces fichiers et je reviens pour transmettre les résultats.

    En attendant, j’ai fait une sauvegarde de la base de données…

    Merci à tous

    en réponse à : Erreur 403 depuis quelques jours sur mon site #2360539
    karpediem63
    Participant
    Initié WordPress
    33 contributions

    Bonjour et merci pour vos réponses

    @mathieu42 : je ne vois pas mon fichier debug.log, il devrait être situé dans le dossier wp-content non ?

    @pasglop : ça ne sent pas bon ;o((( et pourtant je fais en sorte d’être plus ou moins à jour avec mes versions…

    Pensez-vous qu’Ovh soit un hébergeur sûr ou pas plus ni moins que n’importe quel autre hébergeur ?

    • Cette réponse a été modifiée le il y a 3 années et 7 mois par karpediem63.
    en réponse à : Erreur 403 depuis quelques jours sur mon site #2360516
    karpediem63
    Participant
    Initié WordPress
    33 contributions

    J’ai refait un test : j’ai supprimé les commentaires sur 2 lignes de ovhconfig.php et j’ai de nouveau ma page blanche avec mon message d’erreur sur mes 2 url ;o((((

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    en réponse à : Erreur 403 depuis quelques jours sur mon site #2360510
    karpediem63
    Participant
    Initié WordPress
    33 contributions

    Ah, j’ai du nouveau…

    Je peux afficher la page html, que ce soit à partir de haubanconseil.com ou de la-marine-immobilier.com

    En revanche, toujours pas accès à mon site, il y a visiblement un problème avec le fichier wp-blog-header.php

    Quelqu’un aurait-il svp une idée ?

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    karpediem63
    Participant
    Initié WordPress
    33 contributions

    Merci pour le conseil,
    C’est ce que j’ai fait, si je reçois une réponse, je posterai ici pour le cas où une autre personne serait intéressée.
    Merci

    en réponse à : Regrouper plusieurs sidebar (avec shortcode) en une seule #865907
    karpediem63
    Participant
    Initié WordPress
    33 contributions

    Merci pour cette réponse.

    En ce qui concerne le code qui appelle la sidebar dans mon template :

    property_type ) ) : ?>

    <div id="primary" class="property_type} »); ?> » role= »complementary »>
    <ul class="xoxo">
    property_type ); ?>
    </ul>
    </div><!-- #primary .widget-area -->

    Si j’ai bien compris ton idée, ce pourrait être par exemple de ne renseigner que la sidebar affectée au type de bien « appartement » et modifier ce code en remplaçant $post->property_type par « appartement », c’est ça ?
    ça me parait être une bonne solution. Faudra juste que je n’oublie pas que c’est la sidebar « appartement » que je dois modifier ;o)

    Quant à ta 2eme suggestion, je n’ai pas bien compris… Il est possible d’ajouter une sidebar via le menu admin/apparence/widget et de l’appeler après le code que je viens de citer dans mon template ? Si c’est ça, ça me parait encore mieux car ça me laisse la possibilité de personnaliser les pages de mes biens en fonction de leur type (maison, appartement, etc.) même si je n’en ai pas besoin pour le moment, ça me laisse une porte ouverte…
    C’est à ça que tu pensais ou j’ai compris de travers ?

    en réponse à : [Résolu] Trouver de la documentation sur les fonctions wp… #865904
    karpediem63
    Participant
    Initié WordPress
    33 contributions

    SUPER !!

    C’est exactement le complément qu’il me fallait.

    Un grand MERCI !!!

    en réponse à : [Résolu] Widget texte : ajouter une class au titre #864379
    karpediem63
    Participant
    Initié WordPress
    33 contributions

    Trop cool !
    Encore un grand MERCI !

    en réponse à : [Résolu] Attribut de page parent #860351
    karpediem63
    Participant
    Initié WordPress
    33 contributions

    Bonjour,

    Un grand MERCI !

    J’ai suivi votre conseil, j’ai changé de thème, mis en place un thème enfant, et tout fonctionne pour le mieux dans le meilleur des mondes ;o)

    Concernant l’ascenseur, je suis d’accord c’est vraiment TRES laid, mais ça va changer, tout est encore un peu en chantier…

    Encore un grand MERCI pour votre patience et vos précieux conseils !

15 sujets de 1 à 15 (sur un total de 25)