johnnoone (Créer un compte)

Toutes mes réponses sur les forums

15 sujets de 121 à 135 (sur un total de 139)
  • Auteur
    Messages
  • en réponse à : LightBox + : reglages du diaporama #596576
    johnnoone
    Membre
    Chevalier WordPress
    140 contributions

    c’est encore mon plugin d’origine qui permet d’afficher la description de l’image. En gros, il affiche tout ce qui est dans l’attribut alt de l’image comme étant une description.

    Donc pour que cela fonctionne avec myGallery, il faut modifier ce script. Mais là je n’ai pas les éléments pour te dire où. :(

    en réponse à : LightBox + : reglages du diaporama #596574
    johnnoone
    Membre
    Chevalier WordPress
    140 contributions

    les deux scripts s’annulent :( il va falloir modifier le plugin myGallery.
    idéalement propose à l’auteur du plugin d’implémenter mon plugin dans le sien.
    sinon essaie de remplacer son fichier lightbox.js par le mien.

    en réponse à : LightBox + : reglages du diaporama #596572
    johnnoone
    Membre
    Chevalier WordPress
    140 contributions

    pour l’affichage qui déconne :
    * est-ce que l’image se crée bien dans le répertoire wp-content/avatar/ ? et s’appelle-t-elle orig-***.png ?
    * créé-t-il les 2 entrées dans la base ? une dont la clé est orig-***, et une autre dont la clé est local-**** ?
    * as-tu rechargé les permalinks (très très important) ? si c’est le cas, quelle est la structure de tes permalinks ?

    pour ce qui est de l’administration :
    * bien sur que je ferai l’admin des avatars à partir de l’unique page de profil, c’est juste que c’est plus compliqué que ça. Avant de proposer cette amélioration esthétique, il me faut corriger tous les bugs critiques.

    enfin pour scriptaculous, je l’ai choisi pour rester cohérent avec ce que propose déjà WP21. en effet, quasiment tous les .js que j’utilise sont déjà dans l’installation de WP21 et se trouve dans le répertoire wp-includes/js/. j’ai juste doublonné les scripts pour assurer la compatibilité avec les WP plus anciens.

    en réponse à : LightBox + : reglages du diaporama #596569
    johnnoone
    Membre
    Chevalier WordPress
    140 contributions

    bin il fait ce qu’on lui demande, c’est l’essentiel 🙂

    en réponse à : Plugin Myavatars : problème image par défaut #587322
    johnnoone
    Membre
    Chevalier WordPress
    140 contributions

    ROD, j’ai mis en ligne une nouvelle version du plugin. Résout-elle les différents problèmes ?

    en réponse à : LightBox + : reglages du diaporama #596565
    johnnoone
    Membre
    Chevalier WordPress
    140 contributions

    ici le développeur du plugin 🙂

    Réglage du temps de défilement

    En bas du fichier lightbox.js se trouve cette ligne

    var pe = new PeriodicalExecuter(jumpImage, 10);

    C’est cette ligne de code qui appelle la fonction

    jumpimage

    toutes les 10 secondes. Il te suffit de changer le 10 par le nombre de secondes qui t’intéresse.

    Lancement automatique

    Je n’ai pas encore étudié la question. je vais m’y pencher

    D’autres questions

    sinon j’ai répondu à pas mal de questions directement dans le billet correspondant :
    http://www.john-noone.com/2006/10/22/lightbox/

    en réponse à : Erreur d’intégration de Gravatar2 #595519
    johnnoone
    Membre
    Chevalier WordPress
    140 contributions

    c’est parce que tu as 2 fonctions gravatar() 🙂 il va falloir que tu en squizzes une.

    en réponse à : [Résolu] Plugin Simple Tagging présenté en tag cloud ? #596092
    johnnoone
    Membre
    Chevalier WordPress
    140 contributions

    as-tu rechargé tes permaliens ?

    en réponse à : [Résolu] Plugin Simple Tagging présenté en tag cloud ? #596090
    johnnoone
    Membre
    Chevalier WordPress
    140 contributions

    il faut que tu mettes à jour la CSS de ton thème, comme on peut le voir dans la CSS du plugin à partir de la ligne 630.

    en réponse à : Plugin Myavatars : problème image par défaut #587321
    johnnoone
    Membre
    Chevalier WordPress
    140 contributions

    question, ta base est en UTF8 ?

    en réponse à : Plugin Myavatars : problème image par défaut #587320
    johnnoone
    Membre
    Chevalier WordPress
    140 contributions

    Je vois ce qui ce passe 🙂

    La table n’a pas pu se créer, donc la série d’erreur en cascades. peux-tu vérifier dans ton mysql qu’il a créé la table
    wp_identikit_user ?

    si ce n’est pas le cas, fait ça

    CREATE TABLE IF NOT EXISTS wp_identikit_user ( id varchar(200) NOT NULL, orig_id varchar(200) NULL, type varchar(50) NOT NULL, date_creation datetime NULL, date_update timestamp NOT NULL, text_log tinytext NULL, status varchar(50) NULL, PRIMARY KEY (id), KEY orig_id (orig_id, id)

    et s’il affiche encore un vieux message d’erreur, fait ça

    CREATE TABLE IF NOT EXISTS wp_identikit_user ( id varchar(100) NOT NULL, orig_id varchar(100) NULL, type varchar(50) NOT NULL, date_creation datetime NULL, date_update timestamp NOT NULL, text_log tinytext NULL, status varchar(50) NULL, PRIMARY KEY (id), KEY orig_id (orig_id, id)

    pour ma part, je vais encore bidouiller le script pour qu’il vérifie que la table existe bien 🙂

    en réponse à : [Résolu] Problème de CSS avec Lightbox #595964
    johnnoone
    Membre
    Chevalier WordPress
    140 contributions

    #lightbox img {margin:0; padding:0; border:0; }

    en réponse à : Plugin Myavatars : problème image par défaut #587314
    johnnoone
    Membre
    Chevalier WordPress
    140 contributions

    ce matin j’ai déposé une nouvelle version qui corrige les bugs bloquants de la veille. Maintenant j’attends que mes camarades testent le biniou afin d’affiner les particularités des différents serveurs.

    http://www.john-noone.com/2007/03/14/le-bout-du-tunnel/

    en réponse à : Plugin Myavatars : problème image par défaut #587309
    johnnoone
    Membre
    Chevalier WordPress
    140 contributions

    j’ai enfin avancé dans la nouvelle version d’Identikit.

    Bien que beta et bugé, il fonctionne bien sur des sites en production. il est disponible à cette adresse, http://www.john-noone.com/2007/03/14/le-bout-du-tunnel/

    en réponse à : [Résolu] Adaptation du PLug-in Lightbox #593966
    johnnoone
    Membre
    Chevalier WordPress
    140 contributions

    j’ai mis en ligne une beta de ma version de Lightbox. Avec, pas besoin de trifouiller le code, le plugin surcharge tout seul les images.
    Tu peux la télécharger et me donner ton avis à ce lien http://www.john-noone.com/2007/03/14/le-bout-du-tunnel/

15 sujets de 121 à 135 (sur un total de 139)