Jean-Marc (Créer un compte)

Toutes mes réponses sur les forums

15 sujets de 46 à 60 (sur un total de 115)
  • Auteur
    Messages
  • en réponse à : Erreur avec index.php hors du répertoire wordpress #577008
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    En effet le htaccess se met bien dans la racine, mais quand je démarre mon site, j’ai une page “index of /” avec tous les fichiers et répertoires cliquables, un peu comme un file manager.

    Comment fait-on pour ne pas avoir ça mais une erreur 404 si il n’y a pas d’index à la racine, par exemple ?

    en réponse à : Erreur avec index.php hors du répertoire wordpress #577006
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Quand je change les options il ne se passe rien dans ma racine. Pas de htaccess qui apparaisse, alors que si je change mon permalien (avec lequel j’ai aussi des pbl, mais ceci sera le sujet d’un autre post), il se crée (ou se transforme) un htaccess dans le répertoire wordpress.

    Je note que dans l’adresse du blog, je remplace /wordpress par /index.php.

    NB : c’est comme cela que cela fonctionne chez moi :
    – tout WP dans un dossier
    – une bonne config qui fait pointer mes requêtes WP sur le script WP

    C’est quoi la bonne config qui pointe les requêtes sur le script ?

    Actuellement j’ai remis l’index (sans la modif décrite dans mon post ci-dessus) dans wordpress et fait une redirection en html mais je n’aime pas ça.
    Si je fais un redirectpermanent en htacces, ça foire aussi et j’ai une page introuvable.

    Comment je fais pour avoir un WP propre dans le répertoire WP ?
    Je m’y perd un peu, là …

    Merci de vos z’avis z’avisés,
    Jean-Marc

    en réponse à : Blog WordPress 2.0.3 Anglais et Français #577087
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Salut Petrich,

    J’utilise Polyglot pour traduire un site que je mets au point (http://www.crorb.org/wordpress).
    Si je comprend bien, c’est ça que tu cherches.
    Le plugin s’appelle Polyglot et fonctionne bien chez moi. Par contre d’autres ont eu des problèmes. Je pense que ça dépend surtout de ton hébergeur, mais je n’en suis pas plus sur que ça. Le mieux étant encore d’essayer.
    Sinon, il y a aussi YammYamm qui a l’air très bien fait, mais avec lequel c’est moi qui ai eu des problèmes.
    Comme tu vois, il faut chercher et essayer pour trouver ce qui te conviendra.
    De toute façon, quel que soit le système de traduction que tu utiliseras, il te faudra un thème localisé ou que tu localiseras toi-même, c’est à dire avec des fichiers de langue à la place de la traduction en dur dans les fichiers eux-même.
    C’est malheureusement ce qu’on trouve dans 99% des thèmes parce que c’est bien plus simple et plus rapide à traduire, mais ça ne convient que pour les blogs unilingues. :(

    Pour polyglot, on a eu une discussion récemment et tu peux la trouver ici : http://www.wordpress-fr.net/support/viewtopic.php?id=1580

    Jean-Marc

    en réponse à : Erreur avec index.php hors du répertoire wordpress #577004
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    En effet j’ai remplacé require(‘./wp-blog-header.php’); par require(‘./wordpress/wp-blog-header.php’); et cela fonctionne, mais je ne comprend pas à quoi sert l’option générale si il faut changer le fichier index.php.

    en réponse à : Site complètement trilingue #575812
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    La seule idée que j’ai en voyant ton erreur est que polyglot ne supporterait pas tous les permaliens, mais je n’en suis pas plus sur que ça.
    Il semblerait bien que tu devrais essayer YammYamm. Je trouve qu’il a l’air TRES bien fait, mais c’est avec lui que j’ai eu des problèmes. Par contre, peut-être fonctionnera-t-il chez toi …

    en réponse à : Site complètement trilingue #575810
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Vérifie que tu as bien un fichier fr_FR.mo dans le thème, et qu’il porte bien ce nom. Sinon, ben je ne vois pas … :(

    en réponse à : [Pb parametrage] Plugin LightBox 2 #576790
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    J’ai une question qui pourrait paraître bizarre à propos de LightBox2.
    Je l’ai chargé sur le site de l’auteur, l’ai poussé sur le serveur dans un directory lightbox2 dans les plugins et j’ai voulu l’activer, mais je ne le vois pas.
    Est ce que tout doit être directement dans plugins ? J’aimerais éviter ça parce que ça va vite devenir un fouilli monstre si je mets tout dans plugins.
    A moins qu’il ne faille au préalable installer lightbox puis passer à lightbox2.

    Quelle est la solution ?
    En effet, ce plugin à l’air pas mal du tout.

    Merci de votre aide,
    Jean-Marc

    en réponse à : Ajouter une balise dans l’éditeur de texte #576086
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Je viens de le charger (Et de l’activer, il paraît que ça fonctionne mieux … 😋 ), mais je ne vois aucun bouton supplémentaire :(

    Comme j’avais Xinha comme wysiwyg, je l’ai désactivé et j’ai de nouveau le wysiwyg de base. Toujours rien de plus :(

    Quelqu’un sait ce que je devrais faire de plus ?

    Merci,
    Jean-Marc

    en réponse à : GD library #576665
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Bon, suite au lien qu C12 a donné ici plus haut, j’ai créé un fichier test et il me répond :
    Vous avez PHP 4.3.10
    Vous avez GD bundled (2.0.28 compatible)

    Il semblerait donc que le problème ne vienne pas de GD Library. Mais d’où est ce que ça pourrait venir ? Je n’en sais encore rien.

    Une idée, peut-être ?

    Merci,
    Jean-Marc

    en réponse à : wp-icq-status? #576641
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Salut,

    Avant tout, je te propose une petitemodification simple, mais qui t’évitera l’affichage d’erreur en cas de problème avec ton plugin.
    Remplace

    par

    Maintanant ton affichage. Dans le fichier sidebar.php (le nom du fichier reste en anglais, mais en français il s’agit du panneau latéral, dans l’éditeur de thèmes), tu dois avoir écris qqch du style :

    
    <h2>ICQ 236-447-022</h2>
    Robert Richard – Admin

    Place simplement ton code d’appel du plugin juste devant ton nom et la fleur s’affichera devant ton nom (n’oublie pas de laisser un espace entre la fleur et ton nom. Ce sera plus joli), comme ceci :

    <h2>ICQ 236-447-022</h2>
    
     Robert Richard – Admin

    en réponse à : Peut-on traduire les plugins via le fichier language de wordpress ? #572702
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Je viens d’essayer et il ne veut rien savoir.

    Que je mettre NomDuPlugin-fr_FR.mo ou fr_FR.mo dans le dossier du plugin, il ne traduit plus rien.
    J’ai même essayé en retiran le chemin de la commande load_plugin_textdomain(‘Nom du plugin‘, $path=’wp-content/plugins/’.$plugin_dir.’/languages/’);

    Pourtant je suis sur qu’il doit y avoir une solution. Mais laquelle … ?!

    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Dans un plugin j’utilise une traduction via un fichier NomDuPlugin-fr_FR.mo qui se trouve dans le répertoire Langages quis e trouve dans le répertoire du plugin.

    Ca fonctionne bien quand je change le WPLANG dans le wp-config.php.

    Le site étant “trilinguisé” (si si, ce mot existe. Je l’ai spécialement inventé il y a 4 secondes, et comme il a été inventé, il existe. 😆 ) via polyglot, j’utilise des fr_FR.mo, nl_NL.mo dans wp-includes/languages/ et dans le répertoire du thème et dans le wp-config.php le WPLANG est sur en_US, sinon certains “détails” ne se traduisent pas.

    Comme le WPLANG est sur en-US, le plugin reste invariablement en anglais.

    Je suppose que le plugin ne se traduit pas parce que le fichier porte le nom NomDuPlugin-fr_FR.mo et non fr_FR.mo, mais le fait de changer le nom du fichier en fr_FR.mo fait que le plugin ne se traduit plus du tout.

    Comment faire pour que le plugin accepte un fichier fr_FR.mo au lieu de NomDuPlugin-fr_FR.mo. Je me dis que ça doit être une variable quelque part ou qqch à change, mais quoi, et où ?

    Merci de vos z’avis z’avisé,
    Jean-Marc

    en réponse à : Traduire un blog en direct #573086
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Merci de cette proposition,

    cependant j’ai réussi à adapter polyglot et à le modifier pour les dates qui ne se traduisaient pas.
    Il ne me reste plus qu’un petit problème de catégories : Dans la sidebar tout est ok, mais dans l’archive de la catégorie, il me marque “Archives de la catégorie ‘[lang_fr]Non classé[/lang_fr] [lang_nl]niet ingedeeld[/lang_nl] [lang_en]unclassed[/lang_en]'” alors que, normalement, il ne devrait marquer que ce qui se trouve entre les balises de la langue sélectionnée.
    Pourquoi cela ne fonctionne pas à cet endroit uniquement, je ne sais pas. Je cherche mais je n’ai pas encore trouvé.

    Une fois que tout sera OK, je ferai un petit tuto. Je pense que ce sera utile pour certains parce qu’il semble que je ne sois pas le seul à rucher sur polyglot.

    Jean-Marc

    PS : Bien entendu, si qqn à une idée pour résoudre le problème des catégories, je suis preneur … :D

    en réponse à : Pas de pagination sur les archives #576498
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Je modifierais le fichier d’archives du thème (et avant ça, je ferais une copie de l’original. Un dicton dit qu’il faut savoir vivre dangereusement, mais il y a des limites 😉 )

    Quelque part dans ton fichier, normalement assez haut dans le fichier, tu devrais trouver une série de if qui déterminent le type d’archive à écrire sur la page.
    Ce que tu recherches doit ressembler à ceci :

    J’essayerais en ajoutant ceci directement sous cette ligne :

    Je ne l’ai pas testé pour la bonne et simple raison que je n’ai aucun mois avec assez de posts pour pouvoir l’essayer, mais je pense que la solution ne doit pas être loin de ça.

    Jean-Marc

    PS : Dis-nous si ça à fonctionné ou comment tu as fais lorsque tu auras trouvé la solution. Ca pourrait servir à d’autres. 🙂

    en réponse à : Problèmes de miniatures sur WP! #575875
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Salut,

    Utilise l’outil de recherche du forum. Tu y trouveras l’adresse suivante qui te mène aux réponses à ta question : http://www.wordpress-fr.net/support/viewtopic.php?id=603

    Jean-Marc

15 sujets de 46 à 60 (sur un total de 115)