gsmopige (Créer un compte)

Toutes mes réponses sur les forums

15 sujets de 1 à 15 (sur un total de 25)
  • Auteur
    Messages
  • en réponse à : Insérer une bannière #2301760
    gsmopige
    Participant
    Initié WordPress
    38 contributions

    <span class=”bbp-reply-post-date”>Dans ce forum et la réponse venait de toi le 11 juillet 2015</span>

    Merci pour ton aide

    Cordialement

    en réponse à : Insérer une bannière #2301754
    gsmopige
    Participant
    Initié WordPress
    38 contributions

    Bonjour,

    Les css du thème enfant ne portent pas sur la bannière.

    Je reprends ce qui est écrit dans “personnalisation/Image d’en tête” : “Votre thème fonctionne mieux avec une image de taille d’en-tête de 1200 × 280 pixels”. Je pense que le problème venait de là.

    Question : Je suppose que ce qu’il faut respecter c’est le ratio 1200/280 soit 4,29 pour éviter que l’image ne soit coupée (Vrai ou Faux).

    Je construit la bannière avec PowerPoint, il n’est donc pas facile de viser juste. Après plusieurs essais, j’ai retenu dans un premier temps 733×179 soit 4,09.

    En parallèle sur le forum dans la question “Taille d’image header recommandée” il est écrit qu’il faut mettre dans le css les lignes suivantes :

    header-image {

    max-height: 350px;

    width: 50%;

    margin: 0 auto;  }

    J’ai mis respectivement 300 et 70 et j’obtiens ce qui est sur le site coutglobal-risque.fr. Si je modifie ces valeurs cela ne change pas beaucoup.

    Merci

    en réponse à : [Résolu] Fihier CSS du thème enfant #2296264
    gsmopige
    Participant
    Initié WordPress
    38 contributions

    Bonjour,

    Merci pour le conseil.

    J’ai ajouté “background-color: transparent;” dans la balise “body” et l’encadré a disparu.

    Cordialement

    en réponse à : Problème d’affichage de paragraphes #2291784
    gsmopige
    Participant
    Initié WordPress
    38 contributions

    Bonsoir,

    Merci pour ta réponse et désolé pour cette longue interruption car j’ai dû m’absenter pendant les vacances.

    Dans Réglage/Options d’écriture j’ai fais les choix suivants:

    • Éditeur par défaut pour tous les utilisateurs               Éditeur classique
    • Autoriser les utilisateurs à changer d’éditeur            Oui

    Pour me former, il m’est arrivé de changer d’éditeur sur certaines pages pour voir la différence. Comme beaucoup, je préfère évidemment le classique qui offre plus de souplesse et de possibilités.

    Sur toutes les pages, je n’ai aucun problème avec le Titre1 (h1). De plus, sur la page où j’ai un problème avec l’éditeur classique, j’ai remplacé h1 par h2 mais cela ne change rien.

    en réponse à : [Résolu] Comment faire exécuter un calcul coté serveur ? #2290081
    gsmopige
    Participant
    Initié WordPress
    38 contributions

    Bonjour,

    Merci pour votre réponse. Je ne connais rien aux filtres. Je vais me renseigner sur ce sujet avant de continuer.​

    en réponse à : Lancer une application php à partir d’un formulaire html #2289797
    gsmopige
    Participant
    Initié WordPress
    38 contributions

    Bonjour,

    Merci pour votre aide.

    1/ J’ai placé la fonction “equation” affichée dans le message de ferman du 15/12 à 21h21 dans le fichier functions.php qui se trouve dans le répertoire contenant le thème.

    www/cgrisq/wp-content/themes/twenty16-child1/functions.php

    En local, cgrisq est le répertoire contenant le site et twenty16-child1 est un theme enfant.

    Bonjour,

    Merci pour votre aide.

    1/ J’ai placé la fonction “equation” affichée dans le message de ferman du 15/12 à 21h21 dans le fichier functions.php qui se trouve dans le répertoire contenant le thème.

    www/cgrisq/wp-content/themes/twenty16-child1/functions.php

    En local, cgrisq est le répertoire contenant le site et twenty16-child1 est un theme enfant.

    2/ J’ai placé le code CSS du même message dans le fichier style.css qui se trouve dans le même répertoire.

    3/ J’ai recopié le code suivant dans une page vierge du site.

    <form class="comment-form" action="#" method="POST" name=" equation"> <!-- target="_blank"   -->
    premier paramètre <input id="param1" name="param1" type="text" value="" />
    deuxième paramètre <input id="param2" name="param2" type="text" value="" />
    <input id="submit" class="submit" name="equation" type="submit" value="Envoyer" /></form>

    Remarque: pour avoir l’affichage dans un autre onglet on met target=”_blank” dans la balise form. Je l’ai placé en commentaire ici, et donc l’affichage se fait dans le même onglet.

    4/ J’ai ajouté add_action(‘template_redirect’, ‘equation’); dans le fichier functions.php

    Résultat, ça marche, mais :

    1. a) le message “radin” ou “merci” ou “merci mon prince” apparaît en haut à gauche de la page WordPress. Je pense qu’en modifiant le CSS on doit pouvoir le faire afficher au milieu, par exemple.
    2. b) quand je réintègre target=”_blank” dans la balise form, le résultat s’affiche bien dans un nouvel onglet. C’est OK.
    3. c) Cependant, l’affichage reprend tous ce qu’il y avait dans l’onglet d’appel, même dans le nouvel onglet, et en particulier le formulaire. Hors je souhaite n’afficher que le résultat.

    Dans mon cas, le formulaire permet de saisir un tableau de données. Ma fonction php fait de la simulation de Monte-Carlo et affiche les résultats sous forme numérique et graphique. Il est donc nécessaire que cet affichage se fasse dans une page vierge, qui ne reprend pas tout le texte et le formulaire de la page d’appel.

    Il me reste donc à résoudre ce problème, avec l’aide éventuelle de quiconque aurait une solution pour l’affichage du résultat. C’est pour cette raison que je préfèrerais que l’affichage s’effectue sur une page hors WP.

    Merci encore pour vos conseils. Je suis bien sûr intéressé par tout autres conseils complémentaires.

    en réponse à : [Résolu] Comment faire exécuter un calcul coté serveur ? #2289667
    gsmopige
    Participant
    Initié WordPress
    38 contributions

    Bonjour,

    J’ai exactement le même problème sur un site que je développe actuellement en local.

    Je le rappelle ici bien qu’il soit exposé dans le sujet “Lancer une application php à partir d’un formulaire html” ouvert il y a 2 jours et pour lequel je n’ai reçu aucun commentaire.

    Dans une page WordPress, j’ai installé un formulaire dans lequel l’utilisateur saisit des données puis lance le traitement. Pour effectuer le traitement des ces données, j’ai développé un script en php que j’installe sur le serveur. Ce script affiche le résultat du traitement dans un nouvel onglet, en dehors de WordPress.

    A noter que cette procédure fonctionne parfaitement en dehors de WordPress, uniquement avec du code html, javascript et php.

    Question 1 : Est-il possible d’exécuter un fichier php à partir d’une page WordPress pour afficher le résultat dans un nouvel onglet, en dehors de WordPress?

    Actuellement, j’appelle le fichier php avec cette instruction placée dans le formulaire.

    <form action=”simuRisq.php” method=”post” name=”lesva” target=”_blank”>

    Question 2 : si oui, l’appel du fichier php est-il correct et où placer ce fichier dans le dossier contenant le site. Lorsque je lance le traitement, j’obtiens le message suivant : “Oups ! Cette page est introuvable”.

    Merci pour votre aide qui répondrait probablement aussi à la question initiale posée par Gilles BILLARD.

    en réponse à : Nettoyage d’un site développé en local avant la mise en ligne #2289419
    gsmopige
    Participant
    Initié WordPress
    38 contributions

    Bonjour,

    Merci pour cette information rassurante

    en réponse à : Nettoyage d’un site développé en local avant la mise en ligne #2289359
    gsmopige
    Participant
    Initié WordPress
    38 contributions

    Bonsoir,

    Merci pour l’info. J’ai installé WP Optimize.

    1/ Dans les optimisations à sélectionner dans le menu, je pense avoir une réponse à mon premier problème concernant la base de données.

    2/ En ce qui concerne l’affichage des permaliens, j’obtiens actuellement des adresses comme suit :

    L’onglet “coût Global” affiche l’adresse http://localhost:8000/cgrisq/cout-global/, ce qui satisfaisant

    L’onglet “Analyse de Risque” affiche l’adresse http://localhost:8000/cgrisq/page-d-exemple/; pas génial

    je préfèrerais avoir http://localhost:8000/cgrisq/analyse-de-risque/

    J’ai 2 autres onglets avec le même problème.

    Je n’ai pas vu dans le menu de WP Optimize d’option permettant ce traiter ce problème. Est-ce qu’il y en a une? Sinon je vais le faire manuellement. Comment procéder pour remplacer les slugs incorrects ?

    Par exemple, dans pages/Analyse de risque/Modification rapide/, le slug “page-d-exemple” est affiché pour le titre “Analyse de risque”. Est-ce que je peux modifier le slug dans cet écran sans risque, sachant que le site n’est pas encore mis en ligne.

    Merci pour votre aide

    en réponse à : Sauvegarde site en local avec UpdraftPlus WordPress Backup #2288473
    gsmopige
    Participant
    Initié WordPress
    38 contributions

    Bonjour,

    Après quelques jours d’interruption, je récapitule ce que j’ai fait et ce que j’ai compris.

    Après avoir installé l’extension “UpdraftPlus WordPress Backup” le 1<sup>er</sup> décembre, j’ai lancé une sauvegarde du site. A l’issue de cette sauvegarde, j’ai eu 3 messages : (M1) Réponse inattendue ; (M2) La sauvegarde a réussie. Elle est maintenant terminée ; (M3) Sauvegarde existante = 0 / Vous n’avez effectué aucune sauvegarde jusqu’à présent.

    Suite aux conseils obtenus sur le forum, j’ai effectué la sauvegarde manuelle

    Dans le dossier contenant le site, il y 3 sous dossiers (wp-admin, wp-content et wp-includes) et plusieurs fichiers, surtout des php. J’ai recopié la totalité de ce dossier dans un dossier sauvegarde. Pour la base de données, j’ai fait une sauvegarde en passant par phpMyAdmin. Pour ces 2 sauvegardes, je sais où elles se trouvent.

    Sauvegarde automatique avec UpdraftPlus

    Dernière information : dans Réglages/Sauvegarde UpDraftPlus, la sauvegarde effectuée initialement est mentionnée dans la rubrique “Sauvegarde existante”. Il semble donc que la sauvegarde ait été effectuée, malgré les messages contradictoires affichés lors de la sauvegarde. Pour les fichiers, la sauvegarde se trouve bien dans le dossier wp-content/updraft, que j’ai rangé ailleurs. Pour la base de données, je ne sais pas ou se trouve la sauvegarde !!!

    Restauration automatique

    Après avoir supprimé des pages et modifié du texte dans une page du site, j’ai lancé une restauration automatique, en ne cochant que la BD. Je retrouve bien le site initial avant les suppressions et modifications.

    Mystères. Pourquoi le message M3, alors que les fichiers et la BD ont été sauvegardés. Où est rangée la BD sauvegardée ?

     

    Merci pour votre aide les jours précédents. Si quelqu’un a des réponses aux 2 dernières questions, j’en prendrai connaissance avec plaisir.

    en réponse à : Sauvegarde site en local avec UpdraftPlus WordPress Backup #2287671
    gsmopige
    Participant
    Initié WordPress
    38 contributions

    Complément au message précédent

    Il n’y a pas de sauvegarde de la base de données dans phpMyAdmin

    en réponse à : Sauvegarde site en local avec UpdraftPlus WordPress Backup #2287670
    gsmopige
    Participant
    Initié WordPress
    38 contributions

    Merci pour toutes ces informations

    Pour développer en local j’utilise Wampserver 3.1.4 64 bit.

    Avec le tutoriel HostPapa et d’autres, j’ai constaté que la sauvegarde de la base est simple, et je l’ai effectuée.

    Pour les fichiers, la sauvegarde se trouve bien dans le dossier wp-content/updraft, que j’ai rangé ailleurs. La sauvegarde a donc fonctionné au moins partiellement.

    J’ai le défaut de bloquer quand je ne comprends pas quelque chose, et je n’aime pas continuer mon chemin en laissant des erreurs cachées sur le bas-côté. S’il y a un problème, il faut le trouver car il peut provenir soit de mon site, soit du plug-in. Si la base de données avait été sauvegardée, comme le dit le message M2 (La sauvegarde a réussie. Elle est maintenant terminée), où se trouverait-elle? Quand au message M3 (Sauvegarde existante = 0 / Vous n’avez effectué aucune sauvegarde jusqu’à présent), il est au moins partiellement faux car les fichiers ont été sauvegardés.

    j’ai bien compris que vous n’avez pas utilisé ce plug-in, mais je suppose que parmi tous les abonnés à ce forum, il y en a quelques-uns qui l’utilisent et qui pourraient me renseigner à ce sujet. Je les remercie par avance de nous faire profiter de leur expérience.

    Concernant l’utilisation de plugins, je suis comme vous, je préfère les éviter quand c’est possible, et dans le cas présent ça reste un essai car la sauvegarde manuelle est très simple.

    Merci encore pour votre soutien

    en réponse à : Sauvegarde site en local avec UpdraftPlus WordPress Backup #2287513
    gsmopige
    Participant
    Initié WordPress
    38 contributions

    Merci à nouveau pour cette réponse rapide, et désolé de poser des questions probablement basiques.

    Bien compris pour les dossiers du site.

    Je croyais que la base de données se trouvait dans un des dossiers du site. Comme ce n’est pas le cas, où se trouve-t-elle? Comment fait-on pour exporter la base de données dans le dossier (ou le fichier?) sauvegarde/base de données que je vais créer.

    D’après votre réponse, on peut sauvegarder en local (oui, non?) avec UpdraftPlus WordPress Backup. Comment paramétrer pour qu’il en soit ainsi, en particulier doit-on préciser le nom d’un dossier? Pourquoi ma première sauvegarde mentionnée au début n’a pas fonctionné (messages M2 et M3)?

    Désolé pour toutes ces questions, mais je souhaite comprendre comment ça fonctionne pour la suite du développement.

    Merci

    en réponse à : Sauvegarde site en local avec UpdraftPlus WordPress Backup #2287507
    gsmopige
    Participant
    Initié WordPress
    38 contributions

    Merci pour cette réponse rapide et efficace

    Dans le dossier contenant le site, il y 3 sous dossiers (wp-admin, wp-content et wp-includes) et plusieurs fichiers, surtout des .php. Je recopie la totalité de ce dossier dans un dossier sauvegarde. Est-ce que cela recopie aussi la base de données. Si non, que dois-je faire de plus.

    Question subsidiaire pour mon éducation : Est-il possible de sauvegarder ce site en local et non sur le Cloud avec l’extension que j’ai utilisée.

    Merci

    en réponse à : Problèmes : Style et insérer une page html #2276661
    gsmopige
    Participant
    Initié WordPress
    38 contributions

    Bonjour,

    Dans la solution 1, la page WP ne contient pas de PHP, elle lance une application PHP extérieure à la page. Est-il possible de lancer une application PHP à partir d’un site développé avec WP? Je suppose oui.

    La question concerne l’introduction de balises <p>…</p> dans le code JavaScript lors de la copie d’une page HTML dans une page WP. Est-ce normal, et si oui pourquoi ? Est-ce un bug de WP ? Est-il possible de copier du code html contenant du JS dans une page WP ?

    Merci de m’indiquer où je peux trouver des réponses à ces questions

15 sujets de 1 à 15 (sur un total de 25)