Elizabeth

Toutes mes réponses sur les forums

15 sujets de 1 à 15 (sur un total de 75)
  • Auteur
    Messages
  • en réponse à : Sous-site inaccessible mais visible depuis le site principal #2136807
    Elizabeth
    Participant
    Padawan WordPress
    94 contributions

    Personne n’a rencontré ce problème ?

    en réponse à : Changement hébergeur + erreurs php #2128066
    Elizabeth
    Participant
    Padawan WordPress
    94 contributions

    Alors, depuis mon FTP, j’ai déplacé deux dossiers qui semblaient poser problème : better-wp-security et wp-super-cache.

    Le message d’erreur sur la page d’accueil du site est plus court, mais ce qui reste est totalement incompréhensible.

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/XXX/rubrique-osef.fr/wp-content/plugins/category-icons/category_icons.php on line 1047 and defined in /home/XXX/rubrique-osef.fr/wp-includes/wp-db.php on line 1222

    Qu’est-ce que ça veut dire ?

    En revanche, énorme progrès, je peux me connecter sur mon tableau de bord de rubrique-osef.fr MAIS impossible d’accéder au sous-site 3615elizabeth depuis ce tableau de bord : « adresse introuvable » J’imagine que c’est lié au message d’erreur cité ci-dessus ?

    • Cette réponse a été modifiée le il y a 1 month par  Elizabeth.
    • Cette réponse a été modifiée le il y a 1 month par  Elizabeth.
    en réponse à : Changement hébergeur + erreurs php #2122577
    Elizabeth
    Participant
    Padawan WordPress
    94 contributions

    Merci pour votre réponse.

    L’une de mes premières idées était d’installer simplement WP, en téléchargeant la dernière version, mais impossible ensuite de réussir à installer mon sous-site / sous-domaine (3615elizabeth). C’est pour cela que j’ai suivi ensuite le tuto de la Marmite, en important ma BDD chez mon nouvel hébergeur, puis en envoyant ensuite tous les mes fichiers.

    En effet, la solution la plus simple serait de « supprimer » tous les plugins, mais je ne vois pas comment réussir l’installation de mon sous-domaine ainsi ? Je peux supprimer mes plugins directement depuis ma BDD ?

    Car malheureusement, je n’utilise que celui-ci… et jamais mon domaine principal.

    en réponse à : Changement hébergeur + erreurs php #2121224
    Elizabeth
    Participant
    Padawan WordPress
    94 contributions

    Je me permets de faire remonter ce post, car je n’arrive pas à comprendre ce que je peux faire ?

    Merci !

    en réponse à : Back-office inaccessible + problème d’url #1618931
    Elizabeth
    Participant
    Padawan WordPress
    94 contributions

    Les articles sont dans wp_3_posts. Tu as raison, j’ai eu plus ou moins le même problème l’année dernière, je n’avais pas réussi à comprendre comment le résoudre, malgré une lecture attentive de nombreux articles, et j’avais fini par contourner le problème.

    Je finis par me résoudre à devoir réinstaller mon site, en espérant vraiment ne pas perdre de données… ma plus grande inquiétude puisque j’y ai rapatrié mes articles de différents sites, et qu’ils remontent donc à 2009.

    En revanche, j’aurais toujours un multisite, puisque l’url 3615elizabeth.rubrique-osef.fr n’est pas un nom de domaine mais un sous-domaine de rubrique-osef.Fr, donc l’opération ne sera pas forcément plus simple ? Serait-ce possible que l’url 3615 soit considérée comme un simple site chez WP ?

    Si je veux plus de réponses sur mon problème initial pour essayer de le comprendre, je peux aussi reposer ma question dans la rubrique Multisite du forum ?

    en réponse à : Back-office inaccessible + problème d’url #1618679
    Elizabeth
    Participant
    Padawan WordPress
    94 contributions

    Merci Franck pour ta réponse. J’aurais peut-être dû poster ma demande dans la rubrique Multi-sites, mais la description de cette rubrique me semblait plus adéquate.

    Dans mon réseau, je n’ai que « deux sites » : le réseau principal (rubrique-osef.fr), et un sous-site (3615Elizabeth), le seul que j’utilise. Je me connecte via rubrique-osef.fr/wpmachintruc et ensuite, je sélectionne mon sous-site (3615elizabeth) depuis le back-office.

    Je n’ai pas fait grand chose dans la BDD, parce que je ne m’y connais pas suffisamment. De mémoire, les seules actions réalisées sont les suivantes :

    • Analyse / réparation des tables (de manière automatique)
    • Dans les tables wp_2_options et wp_3_options, j’ai essayé de modifier les urls, mais sans succès. Dans wp_2_options, je n’ai qu’un choix possible (actuellement : siteurl = 3615elizabeth.rubrique-osef.fr), et dans wp_3_options, j’ai deux choix possibles : actuellement : siteurl = 3615elizabeth.rubrique-osef.fr ; home = 3615elizabeth.rubrique-osef.fr).

    Modifier l’url de l’une de ces tables pourrait m’aider à résoudre mon problème ?

    en réponse à : Back-office inaccessible + problème d’url #1618503
    Elizabeth
    Participant
    Padawan WordPress
    94 contributions

    Je me permets de faire remonter ce post, car je n’arrive pas à trouver de solution ! 🙁 Je cherche dès que j’ai quelques minutes, mais je ne sais pas comment / que chercher.

    Vais-je être obligée de désinstaller / réinstaller mon site ? Cela m’ennuierait beaucoup, car j’aurais trop peur de perdre mes données / articles depuis 2009…

    Merci à celles & ceux qui prendront le temps de me répondre, cela m’aiderait tellement… parce que je sèche sur les solutions possibles

    en réponse à : Back-office inaccessible + problème d’url #1617665
    Elizabeth
    Participant
    Padawan WordPress
    94 contributions

    Petit UP, où je viens de tenter de nouvelles choses, en suivant les conseils de WP channel, avec cet article.

    Voici ce que je viens de faire aujourd’hui :

    dans le fichier wp-login, ajout de :

    connexion à http://rubrique-osef.fr/wp-login.php: OK, donc connexion possible

    MAIS 3615elizabeth inaccessible dans le back-office (pourtant, apparait bien)

    Tentative de modification de wp-login:
    update_option(‘siteurl’, ‘http://rubrique-osef.fr/’ );
    update_option(‘home’, ‘http://3615elizabeth.rubrique-osef.fr/’ );

    3615Elizabeth toujours inaccessible dans le back-office

    Nouvelle analyse des tables : RAS

    Du coup, à votre avis, comment puis-je réussir à me connecter à mon site ? Car si je supprime les deux lignes ajoutées dans wp-login, le site est inaccessible…

    Merci !

    en réponse à : [Résolu] Sous-domaine inaccessible #1617280
    Elizabeth
    Participant
    Padawan WordPress
    94 contributions

    Bon, j’ai continué à chercher de mon côté, j’avais une table cassée, que j’ai pu réparer dans via phpmyadmin chez OVH. Beaucoup de progrès, j’ai apparemment récupérer mon sous-domaine, qui maintenant apparait de nouveau dans mon back office, ET J’AI RÉUSSI !!!!

    Il suffisait de penser à vérifier l’url du sous-domaine dans le back office, et tout fonctionne de nouveau ! Je vais clôturer ce post 😉

    en réponse à : [Résolu] Sous-domaine inaccessible #1617248
    Elizabeth
    Participant
    Padawan WordPress
    94 contributions

    Je viens d’éplucher les rapports d’erreur de BackWPup, qui ont plusieurs semaines, et l’un d’entre eux me semble bizarre :

    [08-Jan-2017 04:35:32]AVERTISSEMENT : Le résultat de la vérification de la table wp_3_404_to_301 est: 2 clients are using or haven’t closed the table properly

    message qui se répète six fois…

    Depuis hier, j’ai donc désactivé la quasi totalité des plugins, mais le sous-domaine 3615elizabeth reste toujours inaccessible, du moins, il renvoi toujours automatiquement au domaine rubrique-osef.fr

    Je continue à sécher… Devrais-je supprimer dans ma BDD tout ce qui fait référence au plugin T404 to 301 ? Mais comment ?

    J’ai également réussi à renommer mon sous-domaine directement dans le back-office de WP, mais sans succès (cf la PJ)

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    en réponse à : [Résolu] Sous-domaine inaccessible #1616947
    Elizabeth
    Participant
    Padawan WordPress
    94 contributions

    Ma configuration WP actuelle
    Version de WordPress : 4.7.2–fr_FR
    Thème utilisé : ?
    Plugins en place : 404 to 301, Akismet, BackWPup, DB cache reloaded, Google Analytics Dashboard for WP, Google XML Sitemaps, Hellocoton, iThemes Security, Jetpack, mailPoet Newsletters, share button par AddThis, subscribe to comments reloaded, tinyMCE advanced, wp missed schedule, wp super cache, wp ultimate recipe, wp-optimize, yoast SEO
    Nom de l’hébergeur : OVH
    Adresse du site : 3615elizabeth.rubrique-osef.fr

    Bonjour,

    Je me permets de revenir sur ce post, certes plus d’un an après, parce que je me retrouve avec plus ou moins le même problème. Subitement, sans action de ma part (je crois), mon sous-domaine a disparu (domaine principal : rubrique-osef.fr). Je suis allée sur mon site début janvier pour rédiger un article, et je ne me rappelle plus si j’ai fait une MAJ de WP ou d’un plugin.

    Comme en 2015, mon domaine est accessible, mais mon sous-domaine renvoyait initialement à une erreur de connexion de la BDD. J’ai relu l’intégralité de la conversation ci-dessus, mais je n’arrive toujours pas à comprendre ce qui a pu planter. Lorsque j’ai réalisé ce problème, je suis allée sur mon interface OVH, j’ai mis à jour ma version php de 5.4 à 5.5, mais cela n’a pas résolu le problème.

    En 2015, malgré tous les conseils prodigués plus haut, je n’avais pas réussi à réinjecter mes articles / commentaires qui avaient visuellement disparu, mais étaient toujours présents dans ma BDD. J’avais donc contourné le problème en travaillant « à l’ancienne », en renvoyant individuellement tous mes articles / commentaires sur mon site via un copié collé des infos trouvées sur la BDD.

    Je me retrouve maintenant avec deux « tables » (???) dans ma BDD : wp_2_comments et wp_3_comments, et la dernière contient les articles / commentaires de la « table 2″, puisque je les avais remis manuellement sur mon blog.<code class= »sql »>

    J’ai désactivé tous mes plugins, mais sans conséquence positive.

    Du coup, j’ai de nouveau plusieurs questions :

    1. comment puis-je réussir à réactiver mon sous-domaine (retrouver le thème / articles / commentaires), puisqu’il existe toujours dans ma BDD ? Toutefois, dans le back office de WP, curieusement, mon sous-domaine n’a plus de « nom », il est toujours là, mais sans être nommé. Et si je veux le modifier, en lui forçant la main pour l’url, il la refuse, et me met : « :/// » dès que j’enregistre (alors qu’avant de faire cette manip’, le sous-domaine apparaissait dans le champs correspondant, mais ainsi : « :///3615elizabeth.rubrique-osef.fr », et comme les trois /// me perturbaient, j’ai voulu les supprimer en remettant l’url correcte.
    2. si je veux faire la MAJ du réseau avec la dernière version de WP, j’obtiens ce message : « Attention ! Un problème est survenu lors de la mise à jour de . Votre serveur peut ne pas être en mesure de se connecter à certains sites qui y sont installés. Message d’erreur : L’URL fournie n’est pas valide.. » Je ne le comprends pas o_O
    3. ai-je un moyen de réinjecter quelque part les infos de ma BDD pour récupérer mon site ? Ou vais-je devoir recommencer à zéro ? Du coup, comment être sure de ne pas obtenir de nouveau ce problème dans un an ???

     

    Merci pour votre aide !

     

     

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    en réponse à : Soucis avec BackWP up #1026945
    Elizabeth
    Participant
    Padawan WordPress
    94 contributions

    NB : si je décoche cette table pour la sauvegarde BackWPup, elle se passe pratiquement sans problème, je n’ai plus que ces deux messages d’erreurs :
    AVERTISSEMENT : L’opération a été relancée pour cause d’inactivité depuis plus de 5 minutes.
    AVERTISSEMENT : L’opération s’est terminée avec des avertissements en 559 seconds. Merci de les corriger pour une exécution correcte.

    Qu’est-ce qu’ils veulent dire ?

    en réponse à : Soucis avec BackWP up #1026943
    Elizabeth
    Participant
    Padawan WordPress
    94 contributions

    Je me permets de faire remonter ce post car je n’arrive pas à comprendre le problème lié à la table WP_2_options.

    En effet, lorsque je me connecte à phy My admin, je ne peux y accéder, j’ai le même message d’erreur : Table ‘./rubriquemod1/wp_2_options’ is marked as crashed and should be repaired

    Or, je ne peux accéder à cette table : du coup, comment puis-je la réparer ? Quel est le rôle de cette table dans WP ?

    Merci !

    en réponse à : [Résolu] Sous-domaine inaccessible #1026484
    Elizabeth
    Participant
    Padawan WordPress
    94 contributions

    Merci pour tes réponses, j’ai renvoyé à la main mes articles individuellement, et j’ai reçu une réponse détaillée d’OVH pour essayer de copier ma table 2 dans ma table 3 pour les articles et les commentaires. Je vais voir si j’y arrive. Je te tiens au courant…

    Si non, tant pis, je suis déjà super contente d’avoir contourné le problème (parce que le problème de base est toujours incompréhensible), et merci infiniment pour ton aide.

    en réponse à : [Résolu] Sous-domaine inaccessible #1026482
    Elizabeth
    Participant
    Padawan WordPress
    94 contributions

    Je commence à avoir du mal à suivre, pour les prochaines étapes, j’ai donc réactivé mon nouveau sous-site 3615elizabeth, identique au précédent.
    Si l’on va sur l’url l’url de l’actuel sous-domaine activée, on tombe donc sur un site existant, mais vierge.

    Dans mon back-office, j’ai maintenant trois sites :
    rubrique-osef.fr
    3615elizabeth.rubrique-osef.fr (l’historique, celui qui plante)
    3615elizabeth.rubrique-osef.fr (le nouveau, qui existe, mais sans contenu)

    Or, si je vais dans les réglages de l’historique, je vois que l’url est inexistante et impossible à modifier (à la suite d’une erreur de ma part, en voulant la modifier) :
    mini_127900sousdomainehistorique.jpg
    Et ce sous-domaine est celui totalement inaccessible… Lorsqu’on tapait 3615elizabeth.rubrique-osef.fr, on tombait sur rubrique-osef.fr directement.

    En revanche, tout fonctionne pour le nouveau sous-domaine / sous-site créé la semaine dernière.

    Du coup, pour parer au plus simple : comment déplacer tous mes articles dans mon nouveau sous-site de la manière la plus efficace possible ? Si je vais dans mon FTP, je constate maintenant deux dossiers 3615elizabeth :
    – l’ancien, qui était au même niveau que www : il est vide (enfin, je pense qu’il s’agit de l’ancien, je n’en suis pas sure à 100%)
    – un nouveau, dans www : vide également
    Dans ma BDD, je ne sais pas s’il y a des différences, je ne m’y connais pas…

    Je viens de tenter ceci :
    export de la BDD ou de la table (??) des articles « wp_2_posts » sur mon PC au format sql
    import de la table (???) dans « wp_3_posts » (option spécifique de format : mode de compatibilité = sql)
    Cependant, impossible de réaliser cette opération, j’obtiens systématiquement ce message d’erreur :

    Échec de la connexion sécurisée

    La connexion avec le serveur a été réinitialisée pendant le chargement de la page.
    La page que vous essayez de consulter ne peut pas être affichée car l’authenticité des données reçues ne peut être vérifiée.
    Veuillez contacter les propriétaires du site web pour les informer de ce problème.

    Du coup, faut-il que je demande à OVH de faire la manip ? C’est dommage, car l’idée me paraissait simple et pratique. Certes, c’était une manière de contourner le problème, mais cela aurait fonctionné…

15 sujets de 1 à 15 (sur un total de 75)