Marie (Créer un compte)

Toutes mes réponses sur les forums

15 sujets de 1 à 15 (sur un total de 101)
  • Auteur
    Messages
  • CoinCoin
    Participant
    Chevalier WordPress
    113 contributions

    Bon je ne suis pas sûre que ça ait changé qqch aux autres boutons, mais j’ai mis ce code là pour restreindre au cas où.

    Merci pour tout !

    CoinCoin
    Participant
    Chevalier WordPress
    113 contributions

    J’ai pris la version 1, car j’avoue ne pas comprendre l’intérêt de la 2e…

    Par contre petite question, je l’ai mis dans mes css personnalisés au niveau du thème, pas de la page (ça ne fonctionnait pas avec Divi), du coup je me demande, est-ce que ça va agir sur tous les boutons du site ?

    Merci beaucoup !

    CoinCoin
    Participant
    Chevalier WordPress
    113 contributions

    Un bouton masqué qui renvoie sur un google form ?

    Oui, c’est voulu, je l’active par périodes, ça m’évite de recréer le nouveau bouton 1 fois par mois quand il est utile car ce n’est pas un sujet permanent… 😉

    CoinCoin
    Participant
    Chevalier WordPress
    113 contributions

    Oui j’ai fait ça et il n’y avait rien que ce beau message :

    System Status
    Congratulations, all system checks have passed. Your hosting configuration is compatible with Divi.

    C’est après quand j’ai testé les extensions que j’ai trouvé le bug. Et c’est un peu ce que je me dis, si c’est pas fondamental et que ça fait “juste” buguer Yoast sur cette page, c’est pas très grave, c’est pas la plus fondamentale en matière de SEO…

     

    Pas de souci, j’ai laissé le bouton, désactivé Yoast et activé la visibilité du bouton sur tous supports (tel/tablette/ordi)

     

    Merciiiii

    CoinCoin
    Participant
    Chevalier WordPress
    113 contributions

    Bonjour,

    Le code n’a pas fonctionné 🙁

    En revanche je me demandais, est-ce que ce pb à l’enregistrement est vraiment gênant ? Car en fait le bouton a l’air de bien s’afficher même s’il bloque l’enregistrement…

    Par contre, je n’arrive pas à le centrer. J’ai tenté un CSS additionnel text-align:center sur le bloc code, j’ai essayé de centrer l’élément directement avec les affichages Divi : globalement sur la prévisualisation ça fonctionne mais pas en réel… (J’ai désactivé Yoast le temps de faire ces réglages aussi pour ne pas être embêtée.)

    Merci de votre aide !

    CoinCoin
    Participant
    Chevalier WordPress
    113 contributions

    Merci bcp pour votre aide c’est génial !

    J’ai regardé la page que vous m’aviez indiqué et testé la désactivation/réactivation des plugins avec le shortcode. C’est très surprenant mais l’enregistrement fonctionne dès lors que YOAST SEO est désactivé… Tous les autres plugins sont OK, c’est uniquement Yoast qui bug avec ça…

    J’ai aussi testé le nouveau code mais rien ne se passe sur la page a priori…

    CoinCoin
    Participant
    Chevalier WordPress
    113 contributions

    Euh d’accord mais du coup je l’ajoute le bouton comment sur la page concernée après ?

    CoinCoin
    Participant
    Chevalier WordPress
    113 contributions

    Ca serait surprenant effectivement, à moins que j’aie mal recopié qqch ? Voilà les codes que j’ai ajoutés au functions.php :

    // fonction dernier article
    function dernier_article(){
    	$args = array(
            'posts_per_page' => 1 );		
    	$LastPosts = new WP_Query($args); 
    	while ($LastPosts->have_posts()) : $LastPosts->the_post();
    		$permalink = get_permalink();
    	echo'<div class="et_pb_button_module_wrapper et_pb_button_5_wrapper et_pb_button_alignement_center et_pb_module">
    		<a class="et_pb_button et_pb_button_5 et_pb_bg_layout_light" href="'.$permalink.'">Lire mon dernier article</a></div>';
    	endwhile;
    }
    add_shortcode('shortcode_article','dernier_article');
    // fin fonction dernier article

    Et pour le test :

    // test shortcode
    
    function test(){
    	$args = array(
            'posts_per_page' => 1 );		
    	$LastPosts = new WP_Query($args); 
    	while ($LastPosts->have_posts()) : $LastPosts->the_post();
    		$permalink = get_permalink();
    	echo ‘toto’ ;
    	endwhile;
    }
    add_shortcode('test','test');

     

    Le add_action est à rajouter après le add_shortcode, c’était ça l’idée ? J’ai tenté ça n’a rien changé…

    Décidément, il nous donne du fil à retordre ! 🙁

    CoinCoin
    Participant
    Chevalier WordPress
    113 contributions

    Alors : pour le style avec les classes existantes effectivement, ça a recopié le bouton au niveau dimensions et cie dans l’éditeur, ça fonctionne bien, il ne manque que le centrage mais ça c’est facile à faire. 🙏🏻

    En revanche (évidemment) j’ai toujours l’erreur.

    Essayez avec une fonction toute simple (style echo ‘toto’). Autrement vous pouvez aussi essayer un hook divi.

    Je ne suis pas sûre d’avoir compris ce que vous vouliez dire. J’ai remplacé

    echo'<div class="et_pb_button_module_wrapper et_pb_button_6_wrapper et_pb_button_alignment_center et_pb_module ">
    		<a class="et_pb_button et_pb_button_6 et_pb_bg_layout_light" href="'.$permalink.'">Mon dernier article</a></div>'

    par echo ‘toto’

    C’était bien ça ? Si oui, j’ai testé, ça affiche ‘toto’ sur ma visualisation mais ça renvoie exactement la même erreur à l’enregistrement…

    • Cette réponse a été modifiée le il y a 1 mois et 1 semaine par CoinCoin.
    CoinCoin
    Participant
    Chevalier WordPress
    113 contributions

    Bonjour,

    Merci pour tout ça. Oui oui, le bouton est déjà stylisé, il n’y a qu’une icône intégrée ainsi que la dimension et la position qui ne sont pas identiques aux autres boutons de la page.

    Malheureusement, le changement de code n’a rien changé, j’ai toujours l’erreur à l’enregistrement…
    Je n’utilise pas Gutemberg non plus, je suis dans Divi. Et dans Divi, les shortcodes sont utilisés directement dans des modules “code”. J’ai déjà utilisé des shortcodes créés via plugins à d’autres endroits sans encombre, je ne sais pas ce qui peut bloquer, c’est vraiment bizarre… 🙁

    CoinCoin
    Participant
    Chevalier WordPress
    113 contributions

    RAS sur functions.php

    Bug à l’enregistrement = bug à l’enregistrement de la page quand j’ajoute le shortcode dans un bloc code.

    Comme dit le bouton apparait, non centré et pas calibré au niveau de la taille. Le lien fonctionne bien. Mais comme ça me met ce bug j’ai peur que ça ne marche pas réellement partout et que je ne puisse pas faire de modif sur la mise en page…

     

     

    CoinCoin
    Participant
    Chevalier WordPress
    113 contributions

    Bonjour,

    Merci pour ces précisions !

    Je viens (enfin) de prendre le temps de faire le test ça a l’air de fonctionner, cependant j’ai un bug à l’enregistrement :

    Une erreur est survenue lors de l’enregistrement de votre page. Divers problèmes peuvent provoquer un échec de la sauvegarde, comme un manque de ressources du serveur, des blocages de pare-feu, des conflits de plugins ou une mauvaise configuration du serveur. Vous pouvez essayer de sauvegarder à nouveau en cliquant sur Essayer de nouveau, ou vous pouvez télécharger une sauvegarde de votre page non enregistrée en cliquant sur Télécharger la sauvegarde. Les sauvegardes pourront être restaurées à l’aide du système de portabilité lors de la prochaine édition de votre page.

    Contacter votre hôte et lui demander d’augmenter les variables PHP suivantes peut aider : memory_limit, max_execution_time, upload_max_filesize, post_max_size, max_input_time, max_input_vars. En outre, l’audit du journal d’erreur de votre pare-feu (tel que ModSecurity) peut révéler des faux positifs qui empêchent les sauvegardes de se terminer.

    Enfin, il est recommandé de désactiver temporairement tous les plugins de WordPress et les extensions du navigateur, puis d’essayer de sauvegarder à nouveau pour déterminer si quelque chose cause un conflit.

     

    Ca apparait dès que j’active la visibilité du bouton. Je n’avais encore essayé aucune modification de CSS pour le positionnement et le dimensionnement du bouton donc ça ne vient pas de là… Cela étant, même quand l’erreur apparait, le bouton est visible sur la page, donc c’est un peu bizarre…

    Avez-vous une idée ?

     

    Merci !

     

    en réponse à : [Résolu] Créer un lien unique vers le dernier article du blog #2376409
    CoinCoin
    Participant
    Chevalier WordPress
    113 contributions

    Merci de cette réponse, du coup je précise !

    La page en question est là : https://www.connectaloe.com/liens/

    C’est donc une page plein de boutons qui renvoie vers mes liens utiles. L’idée est de rajouter un bouton spécifique “Dernier article publié” qui pointerait donc vers… le dernier article publié.

    Et je ne pense pas pouvoir mettre de code tel quel dans un bouton, a priori simplement une URL. C’est là où je bloque du coup…

     

    Merci !

    en réponse à : [Résolu] Créer un lien unique vers le dernier article du blog #2376394
    CoinCoin
    Participant
    Chevalier WordPress
    113 contributions

    Merci bcp pour ça, mais euh j’ai pas tout compris…

    J’insère ça où au juste ?

    Et après c’est quoi le lien vers lequel je dois pointer pour aller sur le dernier article ou plus concrètement, je mets quoi en lien sur le bouton que je crée ?

     

    Merci de ton aide !

     

     

    en réponse à : Suppression footer sur une page unique avec TwentySeventeen #2359380
    CoinCoin
    Participant
    Chevalier WordPress
    113 contributions

    Nickel ça marche, merci !

     

    Tant que je te tiens, une idée de comment virer ma hello bar juste sur ces pages là ? Car elle est appliquée sur tout le site, mais j’aimerais éviter sur les landing page, je viens de m’apercevoir du truc…

    Merciiii

15 sujets de 1 à 15 (sur un total de 101)