bobby (Créer un compte)

Toutes mes réponses sur les forums

15 sujets de 1 à 15 (sur un total de 43)
  • Auteur
    Messages
  • en réponse à : Traduction du CODEX en FR #765821
    bobby
    Participant
    Padawan WordPress
    51 contributions

    Je suis plutôt motivé mais je ne sais pas trop par où commencer.

    Je pense en effet qu’il faudrait mettre en place un groupe de personnes motivées et s’atteller à la traduction du CODEX.

    en réponse à : Gros problème avec le formulaire de commentaire #745438
    bobby
    Participant
    Padawan WordPress
    51 contributions

    Bonjour,

    N’ayant pas abouti à quoique ce soit de probant avec ta méthode, j’ai désinstallé puis réinstallé wordpress et depuis ça remarche.

    Vu que je suis en plein développement, je teste plusieurs plugins, que je ne retiens pas toujours. C’est sans doute ça qui a du “corrompre” les redirections.

    Merci pour ta réponse en tout cas.

    en réponse à : Traduction du codex #565980
    bobby
    Participant
    Padawan WordPress
    51 contributions

    Ok, merci AmO.

    Je vais commencer à bosser sur l’espace de l’utilisateur, en attendant d’avoir plus de précision.

    en réponse à : Traduction du codex #565978
    bobby
    Participant
    Padawan WordPress
    51 contributions

    Bonsoir,

    Je souhaite contribuer à la traduction du codex. J’ai plusieurs questions :
    – qui valide les pages? C’est à dire qui décide qu’une page peut quitter l’espace privé d’un utilisateur pour devenir publique?
    – comment peut-on éditer les URL des pages pour les rendre conforme à la norme mise en place (fr:cupoftea et non fr:tassedethe) ou faire des redirections vers les bonnes pages?
    – je souhaite commencer par finir de traduire ou mettre à jour les pages de la rubrique “En cours de traduction“. Est-ce qu’il est préférable que je travaille sur l’espace de l’utilisateur qui a commencé la trad ou que je rapatrie tout sur mon espace?

    en réponse à : Traduction du plugin “Geo Mashup” #734493
    bobby
    Participant
    Padawan WordPress
    51 contributions

    La traduction est finie et a été soumise à l’auteur.

    En attendant une événtuelle intégration au plugin, vous pouvez la télécharger sur la page google code du projet (ici).

    Il vous suffit de télécharger le fichier GeoMashup-fr_FR.mo et de le placer dans le dossier racine du plugin (wp-contentpluginsgeo-mashup)

    N’hésitez pas à me contacter si vous avez des remarques sur la traduction.

    en réponse à : [Plugin Amazon Showcase] Problème lors de l’activation #734321
    bobby
    Participant
    Padawan WordPress
    51 contributions

    Finalement, j’ai réussi à le faire marcher.

    Il m’a suffit de télécharger le widget (et non le plugin) ici : http://wordpress.org/extend/plugins/amazon-showcase-wordpress-widget/download/

    Je ne sais pas trop quelle est la différence entre les deux, mais je n’ai plus ce message d’erreur.

    en réponse à : [Plugin Amazon Showcase] Problème lors de l’activation #734320
    bobby
    Participant
    Padawan WordPress
    51 contributions

    J’ai vérifié les fichiers wp-config.php des deux instances.

    A part les clefs uniques d’authentification qui ont été remplies par WordPress lors de l’installation en ligne, je n’ai pas trouvé de différence avec la version en local.

    Je devrais chercher quoi exactement?

    en réponse à : [Plugin Amazon Showcase] Problème lors de l’activation #734318
    bobby
    Participant
    Padawan WordPress
    51 contributions

    Je viens de supprimer mon installation et de la réinstaller.

    En plus du message cité ci-dessus, je viens de m’apercevoir que j’avais aussi celui-là :

    L’extension a généré 61 caractères d’affichage inattendu  lors de l’activation. Si vous voyez un message « Les en-têtes ont déjà été envoyés », des problèmes avec les flux de syndication ou d’autres erreurs, essayez de désactiver ou enlever cette extension.

    Ca ne dit toujours rien à personne?

    edit:
    Je précise qu’au moment de mon test, je n’avais aucune autre extension activée.

    en réponse à : [Résolu] Afficher un mot-clef dans un attribut “id” d’une div #733137
    bobby
    Participant
    Padawan WordPress
    51 contributions

    Bonjour à tous,

    Après bien des misères, j’ai enfin réussi à obtenir ce que je voulais (ou du moins quelque chose d’exploitable).

    N’arrivant pas à customiser la fonction body_class() selon mes besoins, j’ai utilisé cette fonction :

    get_queried_object();
                $id = ‘archive-author-‘ . sanitize_html_class( $author->user_nicename , $author->ID );
            } elseif ( is_category() ) {
                $cat = $wp_query->get_queried_object();
                $id = ‘archive-category-‘ . sanitize_html_class( $cat->slug, $cat->cat_ID );
            } elseif ( is_date() ) {
                    if ( is_day() ) {
                        $date = get_the_time(‘F jS Y’);
                        $id = ‘archive-day-‘ . str_replace(‘ ‘, ‘-‘, strtolower($date) );
                    } elseif ( is_month() ) {
                        $date = get_the_time(‘F Y’);
                        $id = ‘date-‘ . str_replace(‘ ‘, ‘-‘, strtolower($date) );   
                    } elseif ( is_year() ) {
                        $date = get_the_time(‘Y’);
                        $id = ‘date-‘ . strtolower($date);
                    } else {
                        $id = ‘archive-date’;
                    }
            } elseif ( is_tag() ) {
                $tags = $wp_query->get_queried_object();
                $id = ‘archive-tag-‘ . sanitize_html_class( $tags->slug, $tags->term_id );
            } else {
                $id = ‘archive’;
            }
        }
        
        // If it’s a Single Post
        if ( is_single() ) {
            if ( is_attachment() ) {
                $id = ‘attachment-‘.$wp_query->queried_object->post_name;
            } else {
                $id = ‘single-‘.$wp_query->queried_object->post_name;
            }
        }
    
        // If it’s a Page
        if ( is_page() ) {
            $id = ‘page-‘.$wp_query->queried_object->post_name;
            if (” == $id ) {
                $id = ‘page’;
            }
        }
        
        // If $id still doesn’t have a value, attempt to assign it the Page’s name
        if (” == $id ) {
            $id = $wp_query->queried_object->post_name;
        }
        
        $id = preg_replace(“#s+#”, ” “, $id);
        $id = str_replace(‘ ‘, ‘-‘, strtolower($id) );
        
        // Let other plugins modify the function
        return apply_filters( ‘body_id’, $id );    
    
    };
    
    // Print id on body elements
    function body_id( $id = ” ) {
        if ( ” == $id ) {
            $id = get_body_id();
        }
        
        $id = preg_replace(“#s+#”, ” “, $id);
        $id = str_replace(‘ ‘, ‘-‘, strtolower($id) );
    
        echo ( ” != $id ) ? ‘id=”‘.$id. ‘”‘: ” ;
    };
    ?>

    <body >

    Source : http://darrinb.com/notes/2010/adding-a-custom-id-to-the-body-element-in-wordpress/

    Pour ceux que ça intéresse, voici quelques ressources supplémentaires, mais que je n’ai pas testé car elles ne répondaient pas à mes besoins. A noter qu’elles sont toutes les deux en anglais.

    9 Ways to Set Dynamic Body IDs via PHP and WordPress (sur Perishablepress)

    – Plugin “Body Class Enhanced for WordPress” qui permet de personnaliser la body_class

    Merci à Lumière de Lune et à Ducatiwarrior pour m’avoir mis sur la bonne voie 😉

    Tchô

    en réponse à : [Résolu] Afficher un mot-clef dans un attribut “id” d’une div #733135
    bobby
    Participant
    Padawan WordPress
    51 contributions

    La fonction body_class() était en effet activée, mais je n’avais pas du tout pensé à m’en servir!

    Merci du tuyau.

    Par contre, y a-t-il moyen d’afficher l’intitulé du tag? J’ai essayé en passant le paramètre ‘tag’ mais ca me retourne au lieu de .

    en réponse à : Comment nettoyer les balises meta générées par les plugins? #656629
    bobby
    Participant
    Padawan WordPress
    51 contributions

    Bonsoir,

    Personne n’a de réponse ou ce sujet s’est noyé dans la masse?

    en réponse à : Problème avec le flux RSS #653193
    bobby
    Participant
    Padawan WordPress
    51 contributions

    Après quelques recherches approfondies, je suis tombé sur ce commentaire sur le forum de Worpress.org.

    J’ai essayé les solutions proposées par Feedvalidator. La désactivation des plug-in n’a pas marché chez moi.

    En revanche, la suppression du fichier .htaccess puis la modifcation des permalinks ont réglé le problème énoncé plus haut.

    Cela dit, maintenant, Netvibes (mon lecteur de flux par défaut dans Firefox) m’indique le message suivant “Aucun flux valide n’a été trouvé”. En revanche, quand j’affiche mon flux dans Firefox, le flux affiche correctement les billets de mon site.

    Est-ce que cela pourrait provenir du fait que je travaille en local et que Netvibes ne peut pas lire les flux locaux? (cette solution semblerait logique, mais j’aimerai avoir confirmation 😉 )

    en réponse à : Problème avec le flux RSS #653192
    bobby
    Participant
    Padawan WordPress
    51 contributions

    Bonsoir à tous,

    Je me permets de remonter le sujet. J’ai exactement le même problème qu’arthur, mais cela ne peut pas venir de l’hébergement, vu que je travaille encore en local.

    J’ai wordpress 2.7, version française.

    J’espère qu’entre deux verres de champagne quelqu’un trouvera le temps de me répondre 😉

    D’avance merci.

    en réponse à : Màj 2.7: connexion admin devenue impossible #653602
    bobby
    Participant
    Padawan WordPress
    51 contributions

    Par contre, le fichier fr_FR.php se recrée quand on met à jour WordPress.

    Comment faire en sorte qu’il ne se recrée pas?

    en réponse à : Vous n’avez pas les droits suffisants wordpress 2.7 #653988
    bobby
    Participant
    Padawan WordPress
    51 contributions
    Handimobility wrote:
    Effectivement, j’ai eu le même problème, la suppression du dossier plugins et ensuite la remontée de ceux-ci un par un fonctionne ( ouf )

    De mon coté c’était le plugin Back-up database qui était en cause

    Il semblerait en effet que ce soit ce plug-in qui pose problème. Une solution a été proposé dans cette discussion.

15 sujets de 1 à 15 (sur un total de 43)