angeliquesoleil (Créer un compte)

Toutes mes réponses sur les forums

15 sujets de 1 à 15 (sur un total de 17)
  • Auteur
    Messages
  • en réponse à : [Résolu] Bug des apostrophes suite à la mise à jour ! #838029
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    J’ai réinstallé la version et enlever les lignes de codes et réactivé texturize. Problème réglé, hourra! Merci beaucoup!
    (Je me demande toutefois en quoi désactiver texturize permettait de régler le bogue temporairement.)

    en réponse à : [Résolu] Bug des apostrophes suite à la mise à jour ! #838025
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    Il y a aussi une fonction qui insère des espaces dans les nombres depuis 3.4
    Techniquement 1000000000 deviendrait 1 000 000 000.

    en réponse à : [Résolu] Bug des apostrophes suite à la mise à jour ! #838024
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    Bon, les seuls hangements apport6és dans formatting.php dans 3.4 sont sur les urls. Aucune idée donc, de la source du bogue.

    /**
     * Sanitize space or carriage return separated URLs that are used to send trackbacks.
     *
     * @since 3.4.0
     *
     * @param string $to_ping Space or carriage return separated URLs
     * @return string URLs starting with the http or https protocol, separated by a carriage return.
     */
    function sanitize_trackback_urls( $to_ping ) {
    	$urls_to_ping = preg_split( ‘/rnt /’, trim( $to_ping ), -1, PREG_SPLIT_NO_EMPTY );
    	foreach ( $urls_to_ping as $k => $url ) {
    		if ( !preg_match( ‘#^https?://.#i’, $url ) )
    			unset( $urls_to_ping[$k] );
    	}
    	$urls_to_ping = array_map( ‘esc_url_raw’, $urls_to_ping );
    	$urls_to_ping = implode( “n”, $urls_to_ping );
    	return apply_filters( ‘sanitize_trackback_urls’, $urls_to_ping, $to_ping );
    }

    en réponse à : [Résolu] Bug des apostrophes suite à la mise à jour ! #838023
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    J’utilise Windows 7 et un clavier multilingue canadien français. Si ça peut être une donnée. Pour le reste, les dernières versions de tous les navigateurs.

    ***

    Historiquement, la fonction texturize cause beaucoup de problèmes. Elle a pour fonction de remplacer certains types de caractères par d’autres, dans l’affichage.
    (par exemple : http://core.trac.wordpress.org/ticket/1418, http://lists.automattic.com/pipermail/wp-trac/2008-September/031861.html )

    J’ai testé avec du texte préformaté (dans les options de la police) et le bogue ne se produit pas. Or la fonction ne s’applique jamais sur le texte préformaté.

    Cela dit, contrairement à Loutre, pour ma part, tous mes apostrophes ont été changés pour des doubles apostrophes (”) dans ma base de données. J’ai comparé avec un ami et les siens étaient normaux et simples (‘).

    Considérant aussi que 3.4 semble ajouter de nouvelles fonctions pour le texturize (si je me fie à ça : http://make.wordpress.org/polyglots/important-changes-for-wordpress-3-4/ ), ça serait probablement dans le formatting.php que le problème se situe?
    Ce sont les changements appliqués à wordpress 3.4 : http://core.trac.wordpress.org/changeset/19795 .

    Je peux peut-être te copier les même lignes chez moi. Personnellement, je ne suis jamais très bonne avec le code alors…

    en réponse à : [Résolu] Bug des apostrophes suite à la mise à jour ! #838017
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    Bon, j’ai trouvé une solution, dites-moi si ça marche pour vous.
    La fonction texturize (qui sert à rendre les signes de ponctuation plus mignons chez les anglophones) semble créer un conflit… lequel, je n’en ai aucune idée, puisque mes apostrophes droits n’ont jamais été transformés pour des courbés…

    Mais en la désactivant, les espaces disparaissent, yé!

    Il faut ajouter ça dans functions.php, avant la balise finale :

    remove_filter (‘single_post_title’, ‘wptexturize’);
    remove_filter (‘bloginfo’, ‘wptexturize’);
    remove_filter (‘wp_title’, ‘wptexturize’);
    remove_filter (‘category_description’, ‘wptexturize’);
    remove_filter (‘list_cats’, ‘wptexturize’);
    remove_filter (‘comment_author’, ‘wptexturize’);
    remove_filter (‘comment_text’, ‘wptexturize’);
    remove_filter (‘the_title’, ‘wptexturize’);
    remove_filter (‘the_content’, ‘wptexturize’);
    remove_filter (‘the_excerpt’, ‘wptexturize’);

    J’espère que ça fonctionnera pour vous!

    en réponse à : [Résolu] Bug des apostrophes suite à la mise à jour ! #838016
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    Hum, mais la version sql de mon ami présente des apostrophes doublés. Par exemple :
    « J”adore le mot “authentique” dans ce contexte, c”est vraiment la clef. »

    en réponse à : [Résolu] Bug des apostrophes suite à la mise à jour ! #838015
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    Bon, la base de données est normale. Pas d’espace dans mon texte.

    en réponse à : [Résolu] Bug des apostrophes suite à la mise à jour ! #838013
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    Ok, j’ai un élément de réponse… mais ça ne me dit où est le problème réel dans le code.

    En anglais, deux types d’apostrophe sont utilisés : les « straight » (droits ‘) et les « curly » (courbés ’). En remplaçant un apostrophe droit par un courbé, le bogue est réglé, du moins, visuellement. Mais comme mon clavier fait par défaut des apostrophes droits, je vois mal comment remplacer TOUS les apostrophes de TOUTES les entrées et de TOUS les commentaires, un à un, en copiant-collant, pour des courbés.

    en réponse à : [Résolu] Bug des apostrophes suite à la mise à jour ! #838011
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    Pour ma part, cher/ère Loutre, le problème subsiste avec IE, Chrome ET Firefox, sans discrimination aucune!

    Je suis hébergée chez un ami. Je lui ai envoyé un courriel, mais je ne peux pas accéder tout de suite à ma base de données, car je n’en ai pas les code d’accès.

    en réponse à : [Résolu] Bug des apostrophes suite à la mise à jour ! #838008
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    Je cherche ça.

    en réponse à : [Résolu] Bug des apostrophes suite à la mise à jour ! #838006
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    Bon, les messages sont en désordre : j’ai eu le même problème avec TwentyEleven.

    en réponse à : [Résolu] Bug des apostrophes suite à la mise à jour ! #838004
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    Même problème avec TwentyEleven.

    en réponse à : [Résolu] Bug des apostrophes suite à la mise à jour ! #838003
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    Je n’ai jamais regardé dans une base de données…
    Je vais voir comment le faire et après je te réponds. 🙂

    en réponse à : [Résolu] Bug des apostrophes suite à la mise à jour ! #838001
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    J’ai essayé avec le « WordPress Default par Michael Heilemann ».

    en réponse à : [Résolu] Bug des apostrophes suite à la mise à jour ! #837998
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    C’est confirmé : remettre le thème par défaut et désactiver les extensions ne règle pas le problème chez moi.

15 sujets de 1 à 15 (sur un total de 17)