YouTube

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 41)
  • Auteur
    Messages
  • #447166
    mateo
    Membre
    Initié WordPress
    16 contributions

    Hello, encore un problème d’affichage de vidéo.

    Aucun problème avec Dailymotion pour l’affichage sur K2 en désactivant les options dans écriture, mais impossible de faire reconnaître les codes YouTube :

    Que puis-je faire ?

    PS : j’ai l’impression que K2 est plus complexe dans l’écriture que les autres. Je rêve ou pas ?

    merci d’avance,

    -m

    #571214
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Prend garde que le code soit bien écrit sans espace ou retour à la ligne superflues. C’est souvent de là que viennent des problèmes de ce type.

    #571215
    mateo
    Membre
    Initié WordPress
    16 contributions

    Merci pour ta réponse.

    Le code est :

    et à vrai dire quand j’essaye d’enlever les espaces comme ça :

    C’est pire. Sinon il va à la ligne naturellement je pense…

    #571216
    Aline
    Participant
    Padawan WordPress
    82 contributions

    Est-ce que une fois le code entré et validé WP le modifie ???

    #571217
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    mateo > Attention, je parlais de supprimer les espaces superflues… et non pas tous les espaces !!

    Mais a priori, le code que tu as parait bien… en tout cas il fonctionne très bien sur mon blog muni du thème K2.
    J’ai pourtant recopier le code que tu as mis dans ton premier post. Donc le problème ne vient pas du code. 😉

    #571220
    mateo
    Membre
    Initié WordPress
    16 contributions

    Oui Aline, quand je clique sur sauvegarde continue, ensuite le code est :

    Avec K2, j’ai pourtant désactivé l’option dans écriture…faut-il faire autre chose ?…

    #571221
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    As-tu bien désactivé l’éditeur visuel (tu es bien sous WP 2.0 ?) dans ton profil utilisateur ?

    #571222
    Aline
    Participant
    Padawan WordPress
    82 contributions

    D’après moi, il y a une erreur dans le php (quoique je ne soit pas sur),
    Tu peux soit essayer de forcer WP a laisser le code en le mettant entre des balises

    Ou alors essai d’avoir un plugin qui empeche WP de retoucher une partie du texte voulu !!!

    Bonne chance !!!

    #571223
    damino
    Participant
    Maître WordPress
    1243 contributions

    Il faudrait éditer en mode HTML et désactiver l’éditeur WYSIWYG non ?
    Un petit lien vers ton site …?

    #571218
    mateo
    Membre
    Initié WordPress
    16 contributions

    quand je passe par l’éditeur htlm, même résultat, il modifie les lignes, et j’obtiens :

    Le lien : http://www.mociologic.com

    #571219
    mateo
    Membre
    Initié WordPress
    16 contributions

    ça ne marche pas non plus avec les balises

    , je me demande pourquoi ça marche sur le blog K2 de Kenobi et pas sur le mien…alors que j’ai désactivé ce qui devait l’être.
    #571224
    resktor
    Membre
    Initié WordPress
    2 contributions

    Personnellement je rencontre exactement la meme erreur alors que je n’utilise pas le meme theme.

    J’utilise le theme WPAndreas03 Traduit par AmO et dès que je veux inserer une vidéo YouTube il supprime automatiquement la balise « embed »

    Je ne sais pas pourquoi mais visiblement cette section ne lui plait pas

    Si quelqu’un a une idee je suis preneur

    #571225
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Idée : ne pas utiliser l’éditeur visuel pour copier/coller du code.
    Idée++ : avoir un utilisateur pour les articles Texte, avec éditeur visuel, et un autre sans éditeur, pour les manips de code.

    #571226
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Idée +++ : Désactiver l’éditeur visuel… :D

    #571227
    resktor
    Membre
    Initié WordPress
    2 contributions

    Merci Xavier et merci BenKenobi
    J’ai effectivement créé un utilisateur qui se passe de l’éditeur visuel et ca fonctionne sans problème

    Merci beaucoup et bonne continuation

15 sujets de 1 à 15 (sur un total de 41)
  • Vous devez être connecté pour répondre à ce sujet.