WP-Table : Incompatible avec WP 2.5 (Créer un compte)

  • Statut : non résolu
8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #459109
    imported_BenKenobi
    Membre
    Padawan WordPress
    93 contributions

    Bonjour,

    J’utilise sur un site avec WP 2.3.3 un plugin d’Alex Rabe, WP-Table. Il permet la création de tableau dans les articles et pages de WordPress sans difficulté… on peut également importer des fichiers CSV… bref ce plugin est simple d’utilisation et peut rendre de bons services…

    Seulement au moment où j’envisage la mise à jour de ce site vers WP 2.5, je constate que l’auteur ne souhaite pas rendre ce plugin compatible pour le moment. J’ai fait un essai sur une installation de WP 2.5 et en effer, l’activation du plugin est empêché à cause d’une “erreur fatale”.

    Bref… est-ce qu’une âme généreuse pourrait tenter de regarder dans les entrailles de ce plugin pour savoir pourquoi il n’est pas compatible et si possible pouvoir le rendre compatible avec la version 2.5 de WP.

    Cela me rendrait de grands services. Merci d’avance.

    #628571
    yazerty
    Membre
    Chevalier WordPress
    158 contributions

    Je tenais à “alerter” ceux que les tableaux dans WP intéressent, que l’idée de l’intégration du support des tableaux dans WP est proposée ici : http://wordpress.org/extend/ideas/topic.php?id=413#post-1764 Votons 🙂 !

    Une telle fonctionnalité serait très intéressante pour pas mal de petites choses et devrait faire l’objet d’un développement propre à WP lui-même plutôt que d’un plugin selon moi (j’avais déjà exposé mon point de vue chez logiste.be).

    #628572
    Sagittarius
    Membre
    Initié WordPress
    25 contributions

    Comme BenKenobi, j’ai aussi le même soucis avant que de passer à WP 2.5.1
    Connaissez-vous une solution qui permette de se passer de ce plugin ?

    #628573
    Lumiere de Lune
    Participant
    Maître WordPress
    19378 contributions

    Notepad++, ctrl A, ctrl C, ctrl V ?

    Ok, je suis déjà dehors 😗

    #628574
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4079 contributions

    J’aimerai beaucoup avoir une solution car il faut que je fasse la mise à jour vers WP 2.5.1 et j’ai besoin de ce plugin… ou d’une vraie solution de rechange…

    Merci d’avance.

    #628575
    Invite 21
    Membre
    Padawan WordPress
    92 contributions

    Une chose à savoir à propos du plugin Wp-Table, que je trouve excellent dans l’insertion de tableaux, et surtout l’opportunité d’y importer un fichier Excel. Que l’auteur ne le mette pas à jour vers la nouvelle version de WP 2.5, c’est une chose mais ne veut pas dire qu’il ne fonctionnera pas… Il est (p-t) pas optimisé pour cette version, mais qu’importe, j’arrive à l’utiliser avec WP 2.5.

    J’ai eu la même erreur que toi, BenKenobi, impossible de l’activer, il me déclenchait une erreur fatale depuis la mise à jour. La solution pour l’activer, j’ai trouvé des incomptabilités avec d’autres plugins qui l’empêcheraient de fonctionner, tels :
    C-Forms II (formulaires) et Viper’s Video Quicktags/Embedded Video Link (vidéos)

    (pour infos, à propos des incompatibiltés de C-Forms II sur WordPress.org)

    Solution : J’ai désactivé l’ensemble de mes plugins jusqu’à trouver celui qui gênait. Pour mon cas, c’était le plugin Viper’s Video Quicktags.
    Pour les formulaires, tu peux utiliser Dagon Design Form Mailer, tout aussi bien. A la place de Viper’s Video ou Embedded Video Link, tu peux prendre WordPress Video Plugin.

    Il se peut que C-Forms II te gêne (si tu n’as pas Viper’s Video…), alors je te conseille de faire la même manipulation, désactives ces 2 plugins (j’ai vu que tu avais C-Forms II sur ton blog), actives wp-Table, et normalement tu n’auras plus de soucis.

    Cdt,

    😉

    #628576
    dean
    Participant
    Chevalier WordPress
    487 contributions

    En effet, il doit s’agir d’une incompatibilité de plugins, j’ai testé celui là seul et il fonctionne on dirait.

    #628577
    Invite 21
    Membre
    Padawan WordPress
    92 contributions

    Il fonctionne mais l’on peut se passer de ce plugin en insérant des templates que l’on modifie avec Notepad++ ou encore Dreamweaver. Ces templates sont insérés dans le répertoire du thème utilisé.

    Lorsque l’on insère une page dans l’admin de WP, on lui associe ce template. Et hop, le tour est joué.

    😉

8 sujets de 1 à 8 (sur un total de 8)
  • Vous devez être connecté pour répondre à ce sujet.