Wp-diapo sous IE 6 (Créer un compte)

  • Statut : non résolu
14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #450593
    David69
    Participant
    Initié WordPress
    7 contributions

    Salut,

    Ma configuration WP actuelle
    – Version de WordPress : 2.0.6
    – Thème utilisé : perso
    – Plugins en place : wp-diapo, static front page,…
    – Nom de l’hebergeur : ovh

    Problème(s) rencontré(s) :
    Impossible de faire fonctionner wp-diapo sous internet explorer 6.
    J’ai fais pal mal d’investigations afin de résourdre le probleme mais là, je commence à devenir chèvre.

    Quelqu’un aurait-il déjà trouver une astuce ? ou bien ce plugin est-il tout simplement incompatible (non précisé sur le site de l’auteur) ?

    Merci d’avance

    #592276
    Oo
    Membre
    Maître WordPress
    2484 contributions

    Bonsoir David69,

    Je rencontre le meme probleme avec IE7. Le blog de l’auteur de l’extension ne fonctionne pas. J’ai pourtant Flash d’installé mais bon !

    Mais sous FF2, tout roule a merveille !

    Oo

    #592277
    David69
    Participant
    Initié WordPress
    7 contributions

    Ouais je viens de me rendre compte qu’il ne fonctionnait pas sous ie 7.

    #592278
    Oo
    Membre
    Maître WordPress
    2484 contributions

    Sais tu si le code de ton module flash est correcte aux standards w3c ?

    Oo

    #592279
    David69
    Participant
    Initié WordPress
    7 contributions

    hum, bonne question…
    Apparement, il y a d’autres productions de l’auteur qui ne fonctionne pas sous IE.
    Je l’ai conctacté mais je n’ai pas encore de réponse.

    Lorsque IE charge la page, il rencontre une erreur de syntaxe à la ligne x.
    Concretement :

    <div id="flashdiapo_0" style="color: #FFFFFF">
     Une animation flash aurait du apparaitr à cet emplacement. Pour se faire, veuillez mettre à jour votre version de Flash Player en visitant  <a href="http://www.adobe.com/go/getflashplayer" target="_blank"> le site de Adobe</a> et ensuite, rechargez cette page.
    </div>
    
    <p>
    
    <br />
    <!– SWF inclusion (WP-Diapo)<br />
    var sowpdiapo0 = new SWFObject(“http://www.barbouille-et-paillette.com/wp-content/plugins/wp-diapo/wp-diapo.swf”, “diapo0”, “500”, “500”, “8”, “#90756A”);<br />
    sowpdiapo0.addParam(“wmode”, “window”);<br />
    sowpdiapo0.addVariable(“scanner”, “http://www.barbouille-et-paillette.com/wp-content/plugins/wp-diapo/scanner.php”);<br />
    sowpdiapo0.addVariable(“path”, “../../../wp-content/photos/poissons”);<br />
    sowpdiapo0.addVariable(“thumbsize”, “40”);<br />
    sowpdiapo0.addVariable(“thumbpadding”, “10”);<br />
    sowpdiapo0.addVariable(“comfile”, “comments.txt”);<br />
    sowpdiapo0.addVariable(“comcolor”, “#ffffff”);<br />
    sowpdiapo0.addVariable(“combgcolor”, “#000000”);<br />
    sowpdiapo0.addVariable(“combgalpha”, “50”);<br />
    sowpdiapo0.write(“flashdiapo_0”);<br />
    –><br />
    </div>

    Je me demande bien ce que fais ce

    non fermé en plein milieu

    #592280
    Oo
    Membre
    Maître WordPress
    2484 contributions

    Re,

    Attends de voir s’il te répond ! Et fais-nous part de ses infos ! Car là, je ne suis pas capable de te dire !

    Oo

    #592281
    David69
    Participant
    Initié WordPress
    7 contributions

    J’ai eu un retour !!

    L’auteur a corrigé la source mais cela ne fonctionne toujours pas chez moi (ma faute).
    Est-ce que quelqu’un pourrait la tester pour moi (et lui).

    Je vous rappel l’adresse : WP-Diapo

    Merci d’avance !!

    #592282
    David69
    Participant
    Initié WordPress
    7 contributions

    up !

    #592283
    Oo
    Membre
    Maître WordPress
    2484 contributions

    Il marche très bien chez moi ! Enfin, il s’affiche correctement ! Je n’ai pas installé ladite extension !

    Je te conseille de tout effacer et de reprendre depuis le début avec l’extension mise à jour !

    Oo

    #592284
    David69
    Participant
    Initié WordPress
    7 contributions

    Je ne comprend pas.
    Comme tu dit, j’ai tout effacé et tout recommencé, deux fois.

    J’ai essayé de l’installé sur un autre site WP : même effets.

    Lorsque j’affiche le code produit, je m’aperçois que les ” dans la source du concepteur sont remplacés chez moi par des &8221… une piste ?

    #592285
    Oo
    Membre
    Maître WordPress
    2484 contributions

    Regarde dans ton admin > option > ecriture. Est-ce que la case “WordPress doit automatiquement corriger les balises XHTML non valides” est cochée ?

    Si c’est le cas, décoche pour voir !

    Oo

    #592286
    David69
    Participant
    Initié WordPress
    7 contributions

    Aucun résultat

    #592287
    LH
    Membre
    Chevalier WordPress
    372 contributions

    Ca y’est j’ai réussi à le faire marcher chez moi! 😆
    Il y a un pb quand l’install WP n’est pas à la racine du site, le fichier scanner.php prend un argument ‘path’ relatif et se plante! Il sait combien il y a d’images mais il n’arrive pas à les charger. On a des boites noires :fouet:
    Hack:
    En forçant le résultat de cette fonction à produire
    <gallery path="http://url-de-votre-install-wp/chemin-des-albums/"&#8230;
    ça a marché chez moi…

    function dumpXML()
    {
                            $nb = sizeof($this->photos);
                            $xml = “path.”” size=””.$nb.””>”;
    …
    }

    Bon allez, je vais me coucher…

    PS: Si vous pouvez contacter l’auteur avant moi, je pense qu’il faudrait un argument flashVar supplémentaire pour passer l’url de l’install WP…

    #592288
    dreamer
    Participant
    Chevalier WordPress
    484 contributions

    Bonsoir

    LH ta solution m’intéresse , mais je n’arrive pas a mettre l’url sous une bonne forme , ça plante , et comme le php et moi ça fait deux , une petite aide pour me montrer la forme du code .

    A +

14 sujets de 1 à 14 (sur un total de 14)
  • Vous devez être connecté pour répondre à ce sujet.