WordPress Apache Php (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 28)
  • Auteur
    Messages
  • #504974
    bmzoom
    Participant
    Maître WordPress
    941 contributions

    bonjour ,

    Je teste des inconvénients de wp en local / distant , avec ceci :

    distant >> free , php4 , mysql en utf8

    local >> ubuntu , apache2 , php5 , mysql en utf8

    J’ai fait quelques modif dans conf.d pour le local pour passer php.ini en utf8 qui était en iso

    Apache2 local est fourni en utf8



    Mais les caractères accentués ne passent toujours pas en local …

    💡

    version.php

    $wp_version = ‘2.0.11’;
    $wp_db_version = 3441;



    Php5 local prend les caractères accentués sur une page statique

    C’est les dépendances du blog qui ne sortent pas les bons caractères …

    J’ai aussi vérifié que la bdd locale contient les accents correctes sur les caractères

    #813390
    Lumiere de Lune
    Participant
    Maître WordPress
    19378 contributions

    Donc en gros, tu demandes de l’aide pour savoir comment configurer ton installation locale ?
    Installes un wamp de base, ça marche sans problème

    (en revanche, php4 et wordpress, c’est mort d’avance)

    #813388
    Chouby
    Participant
    Chevalier WordPress
    417 contributions

    PHP4 et WP 2.0.11, ça devrait le faire… PHP4 est supporté jusqu’à la version 3.1.4 (PHP 4.3). Au delà, c’est PHP 5.2.4
    WAMP, c’est pour Windows, pas Ubuntu (qui est fourni avec son serveur Apache).

    Ceci dit 2.0.11, c’est peut-être un peu vieux, je ne suis pas sûr que tu trouveras quelqu’un pour t’aider sur cette version… Pas moyen d’utiliser plus récent ?

    #813389
    luciole135
    Participant
    Maître WordPress
    13743 contributions
    Chouby wrote:
    PHP4 est supporté jusqu’à la version 3.1.4 (PHP 4.3).

    Eh non, PHP 5 depuis WordPress 2.8
    voir le sujet épinglé ici :
    http://www.wordpress-fr.net/support/sujet-31932-php5-depuis-wordpress

    #813391
    Chouby
    Participant
    Chevalier WordPress
    417 contributions

    😳 ça m’apprendra à croire tout ce que le codex raconte… Je me référais aux notes de la version 3.2 qu j’avais relu il n’y a pas longtemps.

    #813392
    bmzoom
    Participant
    Maître WordPress
    941 contributions

    Le th�me par d�faut de WordPress, bas� sur le fameux th�me Kubrick.



    J’ai ci-dessus les caractères accentués dans l’interface et le blog qui ne sont pas

    codés .

    Sur page hors blog , il n’y a pas ce problème avec php5 .

    Est ce tynimce , l’éditeur de wp , qui bloque avec php5 ?

    C’est la première archive de tyni compatible php5 qui pourrait

    convenir à mon install locale , mais où la trouver pour essayer ?



    Je suis le dernier des mohicans qui installe wordpress avec free – Et c’est largement suffisant pour mes besoins – Une copie en local de la bdd est facile avec apache2 /php5 et mysql , installés en natif avec ubuntu .

    http://forum.ubuntu-fr.org/viewtopic.php?pid=7614061#p7614061

    Pour ceux qui débutent et veulent une install chez free , c’est sans souci .

    #813393
    Chouby
    Participant
    Chevalier WordPress
    417 contributions

    Pour le fun, j’ai essayé. Linux Mint 10 + Xampp 1.7.7 (PHP 5.3.8 + mysql 5.5.16 si j’en crois mon phpinfo et phpmyadmin) + WP 2.0.11. Edition d’un article avec lettres accentuées. Pas de problème rencontré ni à la lecture sur le site, ni à la réédition. Par contre, j’ai tout plein de warnings “deprecated”, etc… J’imagine qu’il y a une option pour les virer…

    ça fait tout drôle, c’est avec une 2.0 quelque chose que j’ai commencé…

    #813394
    bmzoom
    Participant
    Maître WordPress
    941 contributions

    ça fait tout drôle, c’est avec une 2.0 quelque chose que j’ai commencé…

    Avec une 2.0 l’interface est ultra simple et les thèmes de 2008 sont vite trouvés

    J’ai oublié comment upgrader une 2.0 vers une 3.1.4 ( dernier version php4 ) , c’est une upgrade que je peux tester en local …

    #813396
    Lumiere de Lune
    Participant
    Maître WordPress
    19378 contributions
    bmzoom wrote:
    J’ai oublié comment upgrader une 2.0 vers une 3.1.4 ( dernier version php4 ) , c’est une upgrade que je peux tester en local …

    Si c’est ça ton problème, j’ai testé pour toi… ma recommandation, c’est de reprendre une à une les versions dans l’espace téléchargement, et de faire tes upgrades tranquillement, une version après l’autre. :D

    #813398
    bmzoom
    Participant
    Maître WordPress
    941 contributions

    @Lumière de Lune

    Avec de l’expérience , tu n’as pas la moindre idée du blocage des caractères accentués

    //// Le th�me par d�faut de WordPress ////

    distant >> free , php4 , mysql en utf8

    local >> ubuntu , apache2 , php5 , mysql en utf8

    Comment être sûr et certain , que cela vient de la version de php ? C’est quand je fais un transfert de table wp_post du distant vers vers le local que les � s’incrustent dans le wordpress local …

    Avant ce transfert , et en modifiant le premier article du blog avec caractères accentués , tout est normal .

    Quelle est la meilleure méthode pour une réplique distant vers local ?

    #813399
    Guy
    Participant
    Maître WordPress
    14828 contributions

    Pour tes caractères accentués est ce ce qui est en provenance de la base de donnée ou ce qui est codé dans les fichiers PHP qui présente ces caractères bizarres, as tu vérifié les define(‘DB_CHARSET’, …. et/ou define(‘DB_COLLATE’, ”); dans ton wp_config, les traductions fonctionnent elles? as tu vérifié l’encodage des fichiers PHP? etc…

    #813403
    bmzoom
    Participant
    Maître WordPress
    941 contributions

    Quelle est la meilleure méthode pour une réplique distant vers local ?

    #813404
    Guy
    Participant
    Maître WordPress
    14828 contributions

    je n’avais pas vu, c’est juste ta base après transfert, c’est probablement tes options d’import/export qu’il faut vérifier.

    #813401
    bmzoom
    Participant
    Maître WordPress
    941 contributions

    Avec un fichier sql , je l’ouvre et change le nom de domaine avec un éditeur de texte – Mais comme il y a moins de caractères avant/après , est ce modifiable sans erreur ?

    #813402
    Guy
    Participant
    Maître WordPress
    14828 contributions

    les options me semblent correctes. Pour un test, une importation sans modifier les chemins te fait la même erreur?

    Vérifies quand même que l’encodage n’est pas modifié quand tu sauves le fichier avec les nouveaux chemins.

15 sujets de 1 à 15 (sur un total de 28)
  • Vous devez être connecté pour répondre à ce sujet.