WordPress 3.8 compatible FREE.fr et PHP 5.1.3 (Créer un compte)

  • Statut : non résolu
9 sujets de 16 à 24 (sur un total de 24)
  • Auteur
    Messages
  • #930339
    Flobogo
    Modérateur
    Maître WordPress
    20088 contributions

    Mercu Luciole !

    L’astuce donnée par le 1er site (M.M) me semble simple (trop ?) à mettre en oeuvre.

    Par contre, l’autre site dit « vous mettez ce code n’importe où« , c’est vraiment « light » comme info : on ne peut pas mettre du PHP n’importe où ! Par exemple, pas dans un widget. Ou bien si c’est possible, il faudrait indiquer comment … :(

    Mais bon, je réfléchis à tout ça dans les prochains jours (hélas, la semaine de congés va se terminer 😕 )

    #930340
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Le premier code est simple car c’est l’exemple donné dans le CODEX pour l’usage de la fonction is_user_logged_in http://codex.wordpress.org/Function_Reference/is_user_logged_in#Examples
    L’inconvénient, c’est qu’ici, il n’est pas indiqué comment créer un formulaire d’inscription, travail qui reste à faire.

    Ce formulaire ou du moins une vresion de ce formulaire est donné dans le second lien. Il faut bien sûr mettre le code contenant la fonction is_user_logged_in dans le header.php.

    #930341
    kati
    Participant
    Maître WordPress
    866 contributions

    Bonsoir,

    Je ne savait pas que je pouvais ,installer la version 3.8 sous free 😋 Bon par contre je pense que ça doit être compliqué de passer de ma version 3.1.4 à 3.8 non ??

    Mais bon comme je file sous Hostinger…je vasi prendre un sous domaine vu le bazar avec le prestataire internet de notre site 😡

    #930342
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    le plus simple est de faire une copie locale sur votre ordinateur personnel de votre propre site web comme indiqué dans le tuto que j’ai écrit ici : http://additifstabac.free.fr/index.php/faire-une-copie-locale-exacte-de-son-site-wordpress/

    Mais en installant localement la même version de WordPress que celle que vous avez en ligne et que vous pouvez télécharger ici : http://fr.wordpress.org/releases/

    Ensuite, il est préférable de faire la migration localement version par version, c’est à dire
    3.1.4 -> 3.2.1 -> 3.3.2 -> 3.4.2 -> 3.5.2 -> 3.6.1 -> 3.7.1 -> 3.8.1
    certaines étapes ne sont pas obligatoires (vous pouvez passer directement de 3.6.1 à 3.8.1, mais comme je ne me souviens plus de celles qui sont obligatoires, les faire toutes est plus sûr).

    En vérifiant à chaque étape la compatibilité de votre thème et de vos extension.

    Lorsque cela est terminé, il suffira de faire une copie de son site local vers le site en ligne, mais avec la version de WordPress adaptée pour FREE.

    #930343
    ptitesoso
    Membre
    Initié WordPress
    2 contributions

    Bonjour
    J’ai téléchargé la version « wordpress 3.5.2 « elvin » chez free.fr » sur le blog de rodolphe marsolier, avant de tomber sur ta version 3.8.
    Je n’arrive pas à mettre en place le plugin AWPCP pour mettre des petites annonces sur mon site, avec le message d’erreur « Warning: Invalid argument supplied for foreach() in /mnt/169/sda/4/a/troccub/wp-admin/includes/class-wp-upgrader.php on line 558 »
    Penses-tu que la migration pourrais régler mon problème? ou est un plugin incompatible avec FREE?
    Merci de ton aide

    #930344
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Comme il est dit dans la FAQ du dit plugin :
    Question: Does your plugin have any particular requirements for PHP or MySQL versions? Answer: Yes, you need PHP 5.2+ and MySQL 5+. Earlier versions may work, but are not officially supported.

    https://wordpress.org/plugins/another-wordpress-classifieds-plugin/faq/

    En clair le plugin nécessite PHP 5.2 et FREE ne dispose que de PHP 5.1. Donc, cela ne fonctionnera pas non avec WordPress 3.8.1 à la sauce FREE.

    #930345
    ptitesoso
    Membre
    Initié WordPress
    2 contributions

    Merci pour ta réponse rapide.
    Une autre question de novice : comment peut-on savoir dans la (très) longue liste des versions antérieures du plugin AWPCP, lesquels seraient compatible avec le PHP 5.1?

    #930346
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Le plus simple est de poser la question directement sur le forum support du plugin, ici :
    https://wordpress.org/support/plugin/another-wordpress-classifieds-plugin

    Sinon, d’après la liste des modifications apportées au plugin, on voit que la version 2.0.1 était conçu pour fonctionner avec WP 3.1 qui lui acceptait encore PHP 5.1.

    « Version 2.0.1

    Warnings about AWPCP::init suppressed
    Problem with table update for options fixed
    WP 3.0 lacked import file present in 3.1, fixed

    « 
    Ainsi, vous pouvez commencer par installer la version 2.0.1 et si elle fonctionne faire des mises à jour jusqu’à trouver celle qui ne fonctionne plus et revenir à celle qui est compatible avec PHP 5.1

    #930347
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Aujourd’hui, mercredi 22 juillet à 15 40 min, Lionel Bernardi vient d’annoncer que la version PHP 5.6.8 beta est déployée sur tous les serveurs des pages perso de FREE.

    Les versions originales de WordPress fonctionnent, il est inutile d’installer une version adaptée à PHP 5.1.3.

    Je mets à disposition sur bitbucket.org un fichier « .htaccess » sécurisé et optimisé pour php 5.6.8 selon les conseils de « Al » du site les.pages.perso.chez.free .

    Il est disponible à partir de cette page : Déploiement de la version PHP 5.6.8 beta sur tous les serveurs des pages perso de FREE.

9 sujets de 16 à 24 (sur un total de 24)
  • Le sujet ‘WordPress 3.8 compatible FREE.fr et PHP 5.1.3’ est fermé à de nouvelles réponses.