WordPress 2.9 sur Free : wp_usermeta doesn’t exist (Créer un compte)

  • Statut : non résolu
15 sujets de 16 à 30 (sur un total de 55)
  • Auteur
    Messages
  • #705545
    KAMSY
    Membre
    Initié WordPress
    21 contributions

    wp_usermeta: Table ‘domaine.wp_usermeta’ doesn’t exist

    #705546
    Lalao
    Membre
    Initié WordPress
    9 contributions

    MMH… Attends un peu?
    Au fait? Tu as la même config. que moi?

    #705547
    KAMSY
    Membre
    Initié WordPress
    21 contributions

    je sais pas du tout, mais la table wp_usermeta il faut la creer

    #705548
    KAMSY
    Membre
    Initié WordPress
    21 contributions

    quand je reviens a mon adresse j ai cette erreur
    Warning: Cannot modify header information – headers already sent by (output started at /mnt/142/sda/6/f/domaine/wordpress/wp-config.php:1) in /mnt/142/sda/6/f/domaine/wordpress/wp-includes/functions.php on line 2861

    #705549
    balaime
    Participant
    Initié WordPress
    22 contributions

    Bonjour,
    J’obtiens la même chose (avec WP 2.9 sur Free) :
    D’abord une proposition de réparation des tables
    Puis le message d’erreur sur celle incriminée :
    wp_usermeta: Table ‘*******.wp_usermeta’ doesn’t exist

    A quoi cela est-il dû? Peut-on créer cette table ? Si oui, comment ?
    La version 2.9 pose t-elle problème ?

    Cela fait plusieurs fois que j’obtiens des erreurs dans mes installations, j’arrive parfois à des résultats (j’avais commencé un blog mais chaque modification me renvoyait une erreur que j’ignorais sans arrêt…) mais c’est généralement avec des versions antérieures (2.6.1 ou 3 notamment)

    Merci d’avance

    #705550
    chamomor
    Participant
    Maître WordPress
    1912 contributions

    Avec Free comme avec tout hébergeur, il faut impérativement être en php 5. La version MySQL de Free est 5.0.83 donc pas de souci, théoriquement, pour wp 2.9. Mais je me demande si la fonction pour la réparation de la base dans le wp-config.php va passer. Je ne crois pas, je testerai ça.
    Sinon, je ne vois pas pourquoi il faudrait créer manuellement wp users etc.

    à toute fin utile, article détaillé WordPress et Free

    #705551
    balaime
    Participant
    Initié WordPress
    22 contributions

    Bonsoir bonsoir,
    je viens vous faire part de mon évolution concernant mes problèmes d’installation.
    J’ai résolu le problème, je ne pourrais pas vous dire exactement comment mais au moins vous dire mes manips :

    D’abord, une fois l’intégralité du dossier wordpress envoyé par FTP, j’ai créé à tout hasard le fichier .htaccess, seulement ce que je ne savais pas c’est qu’il fallait le renommer comme tel depuis le FTP et non depuis windows après sa création : http://geraldetsonblog.free.fr/index.php/post/2007/07/27/86-htaccess-Free-pour-les-nuls-1
    Je m’excuse si cela avait été dit dans ces forums mais j’avais épuisé mes requêtes google avec tous mes problèmes! Une fois les fichiers wordpress envoyés il faut donc :
    -Créer un doc texte depuis windows avec pour seul contenu « php 1« 
    -Envoyer en FTP
    -Click droit depuis le logiciel FTP (filezilla chez moi), renommer en .htaccess
    -Installer wordpress!

    Bref une fois de plus à tout hasard j’ai également décocher la case pour le référencement, et là, miracle, tout fonctionne à merveille! (pour l’instant). Je ne pense pas que le souci rencontré a été résolu par ma dernière manip mais je préfère prévenir, j’ai par ailleurs réactivé cette option depuis sans problème.

    Resultat : un wordpress 2.9 FR pour le moment fonctionnel…chez Free!

    Résolu

    #705552
    Miracle
    Participant
    Padawan WordPress
    77 contributions

    Bonjour,

    J’avais le même problème sur la même config et aucune des solutions proposées n’a fonctionné. L’envoi du fhichier .htaccess avec « php1 » a même explosé mon espace Free : les autres répertoires n’étaient même plus accessibles ! Je précise que j’installe ce WordPress dans un sous-répertoire, sur un compte principal Free (autre WordPress installé sur un sous-répertoire d’un compte secondaire attaché, fonctionne sans problème).

    Ma solution « système D », à toutes fins utiles :

    – Déjà, j’ai annulé le htaccess en en renvoyant un vide. OK.
    – Et puis aussi on efface tout ce qu’il y avait suite aux install ratées, on efface toutes les tables de la BDD.
    – Le nom de mon sous-répertoire comportait un tiret : je l’ai enlevé.
    – Ayant installé tout récemment un WP 2.8.6 sans problème (mis à jour ensuite vers 2.9), j’ai repris ces fichiers et installé le 2.8.6. Décocher la case pour le référencement, à tout hasard.
    – J’ai obtenu le message d’erreur classique (sorry, il me m’impressionne tellement plus que je ne l’ai même pas noté celui-là !). J’ai juste actualisé la page : OK, WordPress installé !
    – Mise à jour vers 2.9 (du coup il n’y a qu’à écraser tous les fichiers sur le FTP). A la connexion suivante, le système WP demande une mise à jour de la base de données (pour rire) : dire OK, il se débrouille tout seul (WordPress mon amour…).
    – Et voilà, ça marche !

    Joyeux Noël les gens !

    (il subsiste juste un pb d’erreur de syntaxe XML sur le fil RSS des billets, alors que le RSS des commentaires est OK. Pb rencontré plusieurs fois et qui s’est parfois résolu spontanément suite à des mises à jour. A moins que ce ne soit lié au thème, mais en l’occurrence celui-ci tourne pour le moment avec le thème par défaut et sans aucun plugin, étant nouveau né…)
    (c’est hors-sujet mais je vous ignale quand même que ce dernier pb s’est résolu en activant un autre thème que celui par défaut de WP, voir là : http://www.wordpress-fr.net/support/viewtopic.php?pid=174680#p174680)

    #705553
    Ladi-Boy
    Membre
    Initié WordPress
    7 contributions

    Hi!
    Tout d’abord… Je vous souhaite à tous une très bonne année à tous et a toutes. Et vos blog connaissent la gloire =)

    Je suis un tout nouveau sur wordpress.
    J’aimerai ouvrir un blog dans le style assez pro destiné à l’univers des Infographiste 3D et compositing, après plusieurs demande d’amis ( c’était pour la petite présentation).

    Voilà free vient d’ouvrir mon ftp, 2010 commence bien.
    Je prend wordpress 2.9

    – J’ouvre le « wp_config » sur lequel je remplis les informations suivantes: « DB_NAME », « DB_USER », « DB_PASSWORD »

    – Je crée un fichier « .htaccess » contenant « php 1 »

    J’upload tout sur le ftp.

    Je vais « LOGIN ».free.fr/wp-admin, je remplis le nom, mot de passe, Référencer « oui », SUIVANT…

    Et là problème comme beaucoup de monde.

    « One or more database tables are unavailable. The database may need to be repaired. »

    Je répare mais impossible avec la wp_usermeta

    J’ai voulu recommencer à zéro, donc tout supprimer sur ftp, et réuploader, mais j’arrive direct à l’étape 2 qui ne marche pas.

    Je supprime à nouveau tout, je mets la vers 2.8.6.
    A la page du tableau de bord, j’ai déjà des problème

    Fatal error: cannot yet handle MBCS in html_entity_decode()! in /mnt/129/sda/4/2/pixmotion/wp-includes/default-widgets.php on line 803

    Fatal error: cannot yet handle MBCS in html_entity_decode()! in /mnt/129/sda/4/2/pixmotion/wp-admin/includes/dashboard.php on line 820

    Je veux mettre la mise à jour « automatique vers 2.9 » et j’obtiens ce message

    Téléchargement de la mise à jour depuis http://fr.wordpress.org/wordpress-2.9-fr_FR.zip.

    Le téléchargement a échoué.: Operation timed out after 2000 milliseconds with 553136 out of 2783443 bytes received

    Échec de l’installation

    Je remets la 2.9 et j’ai ceci quant je vais sur login.free.fr/wp-admin

    Warning: Cannot modify header information – headers already sent by (output started at /mnt/129/sda/4/2/pixmotion/wp-config.php:1) in /mnt/129/sda/4/2/pixmotion/wp-includes/pluggable.php on line 868

    Que dois je faire ?

    #705554
    Lumiere de Lune
    Participant
    Maître WordPress
    20531 contributions

    Changer d’hébergeur 😉 ….

    Je cite chamonor, spécialiste de free « pour des sites ça marche bien et pour d’autres il y a plein de difficultés sans qu’on sache pourquoi »

    #705555
    Ladi-Boy
    Membre
    Initié WordPress
    7 contributions

    Je vais m’enteter un peu sur free.
    Sinon vous me conseiller quoi qui peux faire un minimum pro!
    Si sa marche bien, je choperai un nom de domaine plutard

    #705556
    balaime
    Participant
    Initié WordPress
    22 contributions

    Bon alors je ne vais pas être aussi radical mais je dois avouer qu’étant chez Free et ce n’est pas Lumière de Lune qui me contredira, j’ai eu pas mal de soucis effectivement, par contre pour le moment après avoir tout recommencé c’est nickel…

    Pour répondre à ta question j’ai plusieurs choses à ajouter :

    Comme dit précédemment, le fichier .htaccess ne doit s’appeler comme tel qu’une fois envoyé en FTP (c’est à dire le renommer depuis le logiciel FTP, et depuis la racine du dossier wordpress de destination !). Là il devrait se transformer en icône blanche car extension non interprétée. Note que c’est à faire avant l’installation. Donc mon conseil, supprimes d’abord tout par FTP puis connecte-toi à ta base SQL de free et supprime tout également, ensuite recommence comme dit précédemment. Il faut également bien changer wp-config sample avec les ID et renommer en wp-config, bref ça on commence à le savoir.

    Je ne saurais te conseiller d’éviter la mise à jour automatique, surtout si tu as déjà des erreurs…

    Free pose aussi pas mal de problèmes du côté de la fameuse « erreur 500 », que le fichier .htaccess ne résout pas car il s’agit purement et simplement d’un problème de serveur Free (j’ai attendu le lendemain après envoi des fichiers et le problème était résolu). C’est entre autres là où Free est ch…., en hébergeur bon je te conseille OVH (payant mais pas trop, une solution gratuite existe mais assez limitée)

    Pour le dernier message d’erreur je me suis énormément pris la tête dessus j’ai eu exactement le même, il faut l’interpréter comme ça :
    Il y a une erreur (généralement d’espace en trop dira t-on) à la ligne 1 du fichier wp-config.php qui AFFECTE le fichier pluggable.php dans son execution ligne 868. C’est donc le 1er qui pose problème.
    – essaye la méthode traditionnelle, ouvre avec notepad voir notepad++ le fichier wp-config.php et regarde la première ligne s’il n’y a pas d’espace en trop. Place ton curseur avant <?php et maintient la touche backspace un petit peu, tant qu'à faire même chose tout en bas du document en maintenant la touche suppr. (Delete). Pour moi ça n'a pas marché il n'y avait pas d'erreur de ce genre…
    – Sinon réinstalle mais en procédant dans l’ordre défini auparavant, c’est ce que j’ai fait après avoir sauvegargé ma BDD sur Free.

    Voilà en espérant avoir été précis…

    #705557
    Ladi-Boy
    Membre
    Initié WordPress
    7 contributions

    Hi !
    Merci de ta réponse très bien développer .

    Durant que tu devais écrire la réponse, je réfléchissais sur le problème en testant ce qui venait pas ma tête qui a tout perdu en connaissance web etc. Mais j’ai réussi à faire la mise à jour, avec plus qu’un seul problème

    Donc après avoir supprimer tout le contenu du FTP.
    Je suis allé dans la base sql de chez free. Et là supris, il y a encore les tables de données.
    J’efface les bases comme tu l’as aussi dit!

    Je remet la version 2.8.6. Sa marche mais il y a des messages d’erreur comme précédemment cités.

    La mise a jour automatique ne marche pas, je le fais manuellement. Et sa marche! Avec les messages d’erreur

    Je remets le fichier .htaccess… disparitions de pas mal de messages d’erreur pour « extension » « blog développement » et « autre actualité de wordpress ».

    Il m’en reste un…
    Il est tout en haut! Au dessus de « Nom du site » « Aller sur le site » « nouvel article » « salutation Admin »

    Warning: Cannot modify header information – headers already sent by (output started at /mnt/129/sda/4/2/pixmotion/wp-config.php:1) in /mnt/129/sda/4/2/pixmotion/wp-includes/functions.php on line 790

    Warning: Cannot modify header information – headers already sent by (output started at /mnt/129/sda/4/2/pixmotion/wp-config.php:1) in /mnt/129/sda/4/2/pixmotion/wp-includes/functions.php on line 791

    D’ou sa peut provenir… est ce réellement important ?

    #705558
    Rocka
    Membre
    Initié WordPress
    1 contributions

    Bonjour à tous, pour ma part après de nombreux essais j’ai exactement le même problème.
    Au départ il me dit qu’il manque la base wp_usermeta, et si j’arrive à la créer, wp tourne en boucle en me disant de la réparer, j’ai essayé toutes les manips décrites dans ce topic sans succès.
    En espérant trouver une solution.

    #705559
    Miracle
    Participant
    Padawan WordPress
    77 contributions

    Bonjour, à tout hasard : il me semble avoir constaté que rien que le fait de NE PAS cocher la case pour le référencement, lors de l’install (quand on va sur l’adresse du site après avoir uploadé les fichiers de WP via le FTP) résout ou plutôt évite pas mal de problèmes. Bon ça aussi ça a déjà été dit plus tôt, mais bon…
    Bonne année (au fait) !

15 sujets de 16 à 30 (sur un total de 55)
  • Vous devez être connecté pour répondre à ce sujet.