Wordpres 6.3.1, mise à jour de PHP 7 vers 8 (Créer un compte)

  • WordPress :6.2
  • Statut : non résolu
2 sujets de 1 à 2 (sur un total de 2)
  • Auteur
    Messages
  • #2460878
    Vincent Valentine
    Participant
    Initié WordPress
    14 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP : 7.4.33
    • MySQL : 5.7.41
    • Thème utilisé : Sahifa
    • Extensions en place :

    Akismet Anti-spam: Spam Protection Version 5.3 par Automattic – Anti-spam Team
    Backup For WP Version 6.5.1 par Backup for WP
    Contact Form 7 Version 5.8 par Takayuki Miyoshi
    Duplicate Page Version 4.5.3 par mndpsingh287
    EditorsKit Version 1.40.0 par Munir Kamal
    Envato Market Version 2.0.10 par Envato
    Events Manager Version 6.4.5.1 par Pixelite
    Google Doc Embedder Version 2.6.4 par Kevin Davis
    Jetpack Version 12.6 par Automattic
    Jetpack Boost Version 2.1.1 par Automattic – Jetpack Site Speed team
    PDF Embedder Version 4.6.4 par WP PDF Embedder Team
    Real Media Library (Free) Version 4.21.9 par devowl.io (dernière version : 4.21.11)
    reCaptcha by BestWebSoft Version 1.73 par BestWebSoft
    Redirection Version 5.3.10 par John Godley
    Scope semaine pour Events Manager Aucune information de version ou d’auteur/autrice n’est disponible.
    Simple Lightbox Version 2.9.3 par Archetyped
    Smush Version 3.14.2 par WPMU DEV
    User Role Editor Version 4.64 par Vladimir Garagulya
    WP Downgrade | Specific Core Version Version 1.2.6 par Reisetiger
    WP Super Cache Version 1.10.0 par Automattic
    Yoast SEO Version 21.2 par Team Yoast

    Problème(s) rencontré(s) : Questionnement sur la mise à jour de PHP

    Bonjour, je récupère la gestion (bénévole) d’un site web fait sous WordPress. J’ai déjà manipulé/construit des site avec WordPress. En prenant connaissance de l’ensemble, je vois que le serveur est encore en PHP7. C’est un support dégradé payant … Je peux migrer PHP jusqu’à la version 8.2 (8.1 recommandé par IONOS).

    En cherchant un peu sur le net, j’ai compris que Wordpres supportait PHP8 depuis un moment. Mais, quels sont les risques de la migration de PHP de 7 vers 8 ? Est-ce que j’ai des extensions qui peuvent ne plus fonctionner ?
    En dehors de la migration sur le serveur, dois-je intervenir sur WordPress ?

    Évidemment, avant toute intervention, je ferai une sauvegarde de l’ensemble.

    Merci pour vos conseils.

    #2460886
    pasglop
    Participant
    Maître WordPress
    699 contributions

    Bonjour,

     

    Le risque est qu’effectivement, le thème (payant je pense) et/ou une/des extensions n’aient pas été maintenus depuis x temps, et ne supportent PHP 8, auquel cas le site peut planter.

    Donc, vérifier si tout est compatible avant la sauvegarde, et l’upgrade de PHP

     

2 sujets de 1 à 2 (sur un total de 2)
  • Vous devez être connecté pour répondre à ce sujet.