Widgets version Zone de blocs (Créer un compte)

  • WordPress :5.4
  • Statut : non résolu
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #2353566
    vfavrat
    Participant
    Initié WordPress
    16 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de WP : 5.5.1
    • Version de PHP/MySQL : (multisite) PHP Version 7.3.15 / MariaDB 5.5.65 – (monosites) PHP Version 7.3.19 / MariaDB 10.2.32
    • Thème utilisé : multisite + plus d’une centaine de monosites donc variés
    • Extensions en place : nombreuses et variables selon sites
    • Nom de l’hébergeur : Rectorat de Lyon
    • Adresse du site : Par exemple https://blog.ac-lyon.fr

    Problème(s) rencontré(s) :

    Depuis la dernière MAJ de WP la page de gestion des widgets habituelle a été remplacée par une zone de blocs.

    Souci : impossible d’ajouter des widgets liés à des extensions si l’extension n’a pas de bloc associé. J’ai essayé avec le bloc “Code court”, mais il n’est pas interprété.

    Par exemple pour ce blog : https://ecole-simandres.blog.ac-lyon.fr/ la page “Se connecter” avec le bloc “Code court” [lwa] s’affiche correctement alors que dans la zone des widgets le même bloc n’est pas interprété (extension “Login with Ajax”).

    Par contre si le widget était activé avant la MAJ de WP, il apparaît bien dans la zone de blocs.

    Il en sera de même probablement pour tous les anciens widgets qui n’ont pas de bloc correspondant puisqu’ils n’apparaissent pas dans la liste.

    Si quelqu’un sait résoudre ce problème ou à qui s’adresser pour qu’il soit résolu, merci d’avance.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2353590
    PhiLyon
    Modérateur
    Maître WordPress
    26329 contributions

    Bonjour.

    Perso je gère les widgets dans Apparence/Widgets, mais certains thèmes ont peut-être d’autres exigences.

    🙂

    #2353594
    vfavrat
    Participant
    Initié WordPress
    16 contributions

    Les copies d’écran ont été obtenues dans “Apparence” -> “Widgets”.

    Cette page de configuration ne se présente plus du tout pareil depuis le passage à 5.5, quel que soit le thème.

    #2353596
    PhiLyon
    Modérateur
    Maître WordPress
    26329 contributions

    Il faut que le PHP soit à 7.4, que tous les thèmes et extensions soient à jour, c’est le cas ?

    Sinon essaie d’installer/activer cette extension https://fr.wordpress.org/plugins/enable-jquery-migrate-helper/

    Ceci est valable pour ton autre sujet.

    🙂

    #2353606
    vfavrat
    Participant
    Initié WordPress
    16 contributions

    Merci, malheureusement l’extension sus-citée ne change rien pour les widgets.

    Côté extensions et thèmes tout est mis à jour quotidiennement.

    Par contre côté version de PHP, ce n’est pas moi qui gère.

    Je fais donc remonter au service compétent en espérant que ce ne sera pas trop long.

    #2353609
    PhiLyon
    Modérateur
    Maître WordPress
    26329 contributions

    Ah oui le Rectorat, j’ai été confronté à cette situation, il y a longtemps…

    🙂

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.