Warning: Cannot modify header information – headers already sent by… (Créer un compte)

  • Statut : non résolu
  • Ce sujet contient 15 réponses, 9 participants et a été mis à jour pour la dernière fois par C_Lucien, le il y a 3 années.
15 sujets de 1 à 15 (sur un total de 16)
  • Auteur
    Messages
  • #462972
    alexxan
    Participant
    Initié WordPress
    6 contributions

    Bonjour,
    Depuis la dernière mise à jour voici le joli message d’erreur qui s’affiche pr quasimment ts les fichiers… :
    Warning: Cannot modify header information – headers already sent by (output started at /mnt/103/sda/5/0/the.world.of.all/wp-config.php:1) in … on line …
    Que faire svp… ? j’ai tout désinstallé, réinstallé en vidant les tables…
    rien n’y fait !

    #645388
    0606060606
    Participant
    Maître WordPress
    523 contributions

    aaaaaaaaaaaaaaaaaaaaahhhhhhhhhhhh

    non franchement, faut arrêter là

    t’a recherché sur le forum ?

    #645389
    alexxan
    Participant
    Initié WordPress
    6 contributions

    Mais oui… que des discussions sur le même sujet. Et alors !? : c’est à cause de cette fichu* mise-à jour 2.6.2
    Mais dans tous les topics y’a pas vraiment de réponse claire, moi comme ts les autre, je n’ai touché à rien dans les fichiers. C’est un pb qui vient de WordPress, mnt j’en suis sûr, c’est pourquoi j’me demande si y’a personne de calé qui pourrait expliquer cqui faut faire pr corriger ça, si ça trouve c simple…
    En attendant….

    #645390
    Maitre Mo
    Participant
    Maître WordPress
    1653 contributions

    Alainfilms est venu, a vu cette erreur, il y a longtemps, et il a a trouvé, et il a dit : editer ton fichier wp-config.php, l’enregistrer en code UTF-8 sans Bom. C’est simple effectivement, et effectivement le forum bloque un peu avec ce problème, parce que vous êtes nombreux à chercher cette réponse sans la trouver alors qu’elle a été donnée une bonne cinquantaine de fois je pense…

    #645391
    0606060606
    Participant
    Maître WordPress
    523 contributions

    peut-être faudrait-il mettre la solution en tant que sujet épinglé…

    #645385
    alexxan
    Participant
    Initié WordPress
    6 contributions

    bonne idée le sujet épinglé…)
    merci pr vos réponses, mais j’ai enregistré en UTF-8 ça ne change strictement rien : normal, le fichier était déjà en UTF-8 d’origine…
    Alors que faire^^ ?

    #645387
    Maitre Mo
    Participant
    Maître WordPress
    1653 contributions

    Désolé si j’étais à côté… UTF-8 sans Bom ? Sinon on recommence ce topic à zéro, tout honteux, mais demain…

    #645386
    alexxan
    Participant
    Initié WordPress
    6 contributions

    MERCI !!!!!!!!
    Enfin la solution miracle grâce à vous, finalement poster un nouveau topic a valu le coup^^
    J’ai téléchargé notepad++ et encodé donc en UTF-8 sans Bom et ô miracle !

    #645392
    martincout
    Membre
    Initié WordPress
    1 contributions

    Merci, merci merci!
    Télécharger notepad++ et encodé en UTF8 sans bom
    génial

    #645393
    kati
    Participant
    Maître WordPress
    845 contributions

    😳 c’est bon il fallait encoder wp-config.php en UTF-8 sans Bom : un souci de moins !!

    #645394
    Flobogo
    Modérateur
    Maître WordPress
    18415 contributions

    bah Kati !!! Tu n’avais jamais lu ce sujet épinglé ?
    J’ai vu ta demande sur l’autre sujet, et je me suis dit que ce n’était pas la peine de te dire de vérifier ton encodage, que c’était sûrement plus compliqué que ça … 😋

    #645395
    celtinvest
    Participant
    Initié WordPress
    20 contributions
    Maître Mô wrote:
    Alainfilms est venu, a vu cette erreur, il y a longtemps, et il a a trouvé, et il a dit : editer ton fichier wp-config.php, l’enregistrer en code UTF-8 sans Bom. C’est simple effectivement, et effectivement le forum bloque un peu avec ce problème, parce que vous êtes nombreux à chercher cette réponse sans la trouver alors qu’elle a été donnée une bonne cinquantaine de fois je pense…

    Bonjour,
    Je comprends (enfin presque) ce que je dois faire mais je ne sais pas comment le faire.

    Vous parlez de cette ligne là dans config.php:
    /** Jeu de caractères à utiliser par la base de données lors de la création des tables. */
    define(‘DB_CHARSET’, ‘utf8’);

    Comment doit-on procéder exactement ?

    Merci.

    #645396
    Flobogo
    Modérateur
    Maître WordPress
    18415 contributions

    Bonjour Celtinvest,

    Comme le dit Maître Mô :

    éditer ton fichier wp-config.php, l’enregistrer en code UTF-8 sans Bom.

    Petite précision : utilisez le logiciel NotePad++ sous Windows (sinon son équivalent pour Mac), ouvrez votre fichier wp-config.php avec ce logiciel, et modifiez l’encodage en UTF8-sans-BOM avant de ré-enregistrer.
    Ne vous inquiétez pas de ce nom barbare, le logiciel Notepad++ le propose dans ses options d’encodage.

    #645397
    celtinvest
    Participant
    Initié WordPress
    20 contributions
    Flobogo wrote:
    Bonjour Celtinvest,

    Comme le dit Maître Mô :

    éditer ton fichier wp-config.php, l’enregistrer en code UTF-8 sans Bom.

    Petite précision : utilisez le logiciel NotePad++ sous Windows (sinon son équivalent pour Mac), ouvrez votre fichier wp-config.php avec ce logiciel, et modifiez l’encodage en UTF8-sans-BOM avant de ré-enregistrer.
    Ne vous inquiétez pas de ce nom barbare, le logiciel Notepad++ le propose dans ses options d’encodage.

    Merci. Le problème est déjà résolu.

    #2263463
    CopieChloe
    Participant
    Initié WordPress
    1 contributions

    Bonjour à tous! J’avais déjà utilisé cette méthode (encoder config.php en utf-8 sans BOM sous Notepad) et ç’avait fonctionné comme un charme.

    Seulement voilà, aujourd’hui je constate que le fichier est déjà en utf-8 sans BOM. Qu’en pensez-vous?

    Voici l’erreur : <b>Warning</b>: Cannot modify header information – headers already sent by (output started at /homepages/18/d777401215/htdocs/clickandbuilds/Champagneoudart/wp-content/themes/salient/functions.php:1) in <b>/homepages/18/d777401215/htdocs/clickandbuilds/Champagneoudart/wp-includes/pluggable.php</b> on line <b>1251</b>

    Et oui, j’ai vérifié functions.php, il n’y a pas d’espaces indésirables avant ni après les balises d’ouverture et de fermeture php.

15 sujets de 1 à 15 (sur un total de 16)
  • Le sujet ‘Warning: Cannot modify header information – headers already sent by…’ est fermé à de nouvelles réponses.