Warning: array_keys() [function.array-keys]… (Créer un compte)

  • Statut : non résolu
7 sujets de 16 à 22 (sur un total de 22)
  • Auteur
    Messages
  • #655153
    Hybrid Son Of Oxayotl
    Participant
    Initié WordPress
    6 contributions

    Toujours rien ?

    #655154
    Hybrid Son Of Oxayotl
    Participant
    Initié WordPress
    6 contributions

    Personne n’a trouvé de solution ?

    #655155
    Hybrid Son Of Oxayotl
    Participant
    Initié WordPress
    6 contributions

    Up.

    #655156
    Lumiere de Lune
    Participant
    Maître WordPress
    20535 contributions

    Bonjour HybridCa ne sert à rien de faire Up comme ça

    « la » solution n’existe pas, elle dépend de chaque blog, de chaque hébergeur, etc…

    Je t’invite donc à ouvrir ton propre sujet, en précisant ce que tu as déjà fait pour essayer de résoudre le problème (y compris bien sur désactiver tous les widgets).

    #655157
    Hybrid Son Of Oxayotl
    Participant
    Initié WordPress
    6 contributions

    Bonjour,
    Je n’ai aucune idée de comment désactiver quoi que ce soit vu que je n’ai plus accès à l’interface de configuration, ni à quoi que ce soit d’ailleurs.
    À la place de la page d’accueil, j’ai un simple

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /var/www/jeanalexandre.angles_dauriac/wordpress/wp-includes/widgets.php on line 1843

    http://perso.ens-lyon.fr/jeanalexandre.angles_dauriac/wordpress/

    et à la place de celle d’administration :

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /var/www/jeanalexandre.angles_dauriac/wordpress/wp-includes/widgets.php on line 1843

    Warning: Cannot modify header information – headers already sent by (output started at /var/www/jeanalexandre.angles_dauriac/wordpress/wp-includes/widgets.php:1843) in /var/www/jeanalexandre.angles_dauriac/wordpress/wp-includes/pluggable.php on line 850

    http://perso.ens-lyon.fr/jeanalexandre.angles_dauriac/wordpress/wp-admin/

    Dans le fichier /wp-includes/widget.php, en partant de la ligne 1842, j’ai :

    1842 $id = false;
    1843 foreach ( (array) array_keys($options) as $o ) {
    1844 // Old widgets can have null values for some reason
    1845 if ( !isset($options[$o]) || !isset($options[$o]) || !isset($options[$o]) )
    1846 continue;
    1847 $id = « rss-$o »; // Never never never translate an id

    L’hébergement, c’est un service proposé par mon école, l’ENS Lyon, donc il n’y a virtuellement aucune chance que quelqu’un d’autre l’utilise et ait eu le même problème.

    #655158
    Lumiere de Lune
    Participant
    Maître WordPress
    20535 contributions

    1. « ouvrir son propre sujet » c’est pas répondre à la suite.
    2. pour désactiver les plugins, il suffit d’aller sur l’espace ftp et de renommer autrement le dossier wp-content/plugin

    Si ça ne suffit, je te recommande d’ouvrir ton propre sujet.

    #655159
    arnaudt
    Participant
    Initié WordPress
    42 contributions

    J’ai le même problème, décrit dans une autre enfilade.
    Je serais curieux de savoir si vous avez réussi à résoudre le vôtre.

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /homepages/40/d148401741/htdocs/wordpress/wp-includes/widgets.php on line 1045

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/40/d148401741/htdocs/wordpress/wp-includes/widgets.php:1045) in /homepages/40/d148401741/htdocs/wordpress/wp-includes/pluggable.php on line 850

    RÉSOLU !
    Tout simplement en remettant le fichier wp-config.php de mon ancienne version, que j’avais pris soin de mettre de côté avant la bascule en 2.7.1

    Alors je ne sais pas ce que je perds à ne pas avoir le dernier wp-config, mais en tout cas 1° j’ai de nouveau accès à mon Dashboard et mon blog est de nouveau en ligne.

    Ouf !
    Et merci à tous pour les différentes réponses sur les différentes enfilades de notre cher et beau forum.

    Merci.

7 sujets de 16 à 22 (sur un total de 22)
  • Vous devez être connecté pour répondre à ce sujet.