“Vos scripts consomment trop de CPU et surchargent nos serveurs” site

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 38)
  • Auteur
    Messages
  • #485029
    clecle
    Participant
    Chevalier WordPress
    305 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.0

    – Thème utilisé : RustyMetalPlateofAzures

    Problème(s) rencontré(s) :

    Bonjour,

    En me levant ce matin je vois qu’on mon site est fermé avec une erreur 403 “You don’t have permission to access / on this server.”
    Je consulte mes mails et là je vois qu’OVH a fermé mon site pour cette raison : “Nous vous informons que l’état opérationel de votre hébergement
    est passé en état “HACKE”. Ceci veut dire qu’il n’est plus
    opérationel du tout.

    La raison de ce changement d’état est le suivant:
    Vos scripts consomment trop de CPU et surchargent nos serveurs”

    Je suis allez sur mon manager OVH afin de relever les problèmes sur mes scirpts et voilà ma page : http://www.casimages.com/img.php?i=100812121026701401.jpg
    On constate que c’est aujourd’hui que le site a pété avec 194 alertes CPU. Je ne comprends pas d’où cela peut venir étant donné que je n’ai fait aucun changement entre hier et aujourd’hui.
    Que faire ?

    #735761
    Red-rabbit
    Membre
    Maître WordPress
    688 contributions

    Ca veut dire qu il faut que tu trouve ce qui fait que la page index.php eclate les alertes cpu.
    Si la veille y a rien, les 94 alerte du 05 sont deja louche.
    Tu oeux avoir un plugin qui deconne ou un widget

    #735762
    clecle
    Participant
    Chevalier WordPress
    305 contributions

    Oui toute à fait. Mais seulement comment trouver ce plugin qui fait foirer ? D’autant plus que le site est mort maintenant… Quelle galère !!

    #735764
    clecle
    Participant
    Chevalier WordPress
    305 contributions

    Je viens de recevoir un mail : “Linaccessibilité de votre site est du aux scripts des pages:
    index.php 313
    wp-cron.php 66

    Pour rétablir l’accés a votre site, veuillez corriger ces scripts.”
    Ils sont bien mignon mais je vois pas ce que je dois faire, je ne suis pas un spécialiste.
    VOici mon fichier index.php :

    <?php
    /**
    * Front to the WordPress application. This file doesn’t do anything, but loads
    * wp-blog-header.php which does and tells WordPress to load the theme.
    *
    * @package WordPress
    */

    /**
    * Tells WordPress to load the WordPress theme and output it.
    *
    * @var bool
    */
    define(‘WP_USE_THEMES’, true);

    /** Loads the WordPress Environment and Template */
    require(‘./wp-blog-header.php’);
    ?>

    #735765
    Antoine_935
    Participant
    Initié WordPress
    5 contributions

    Salut

    Tu dois avoir accès à ta base de données via le manager OVH.
    Ouvre le manager (v3), et choisis ton hébergement. Va dans l’onglet « hébergement ».
    Du côté des bases de données, tu devrais trouver “phpMyAdmin”.

    !! Avant cette manip, je te recommande de faire une sauvegarde de ta base de données !!
    Pour cela, va sur “gérer SQL” (ou un truc du style), et demande une copie de sauvegarde. Un mail te sera envoyé par OVH.

    !! J’ai fait ça sur un WordPress 3. !!
    Ça ne devrait pas être différent sur d’autres versions, mais si tu n’as pas la 3, c’est d’autant plus conseillé de faire une copie de sauvegarde 😉

    Tu vas devoir te connecter à ta base de données comme indiqué.
    Une fois connecté, dans le menu à droite, tu as une liste, avec un lien au sommet de celle-ci.
    Ce lien doit être le nom de ta base de données. Clique dessus, et ensuite sur l’onglet SQL.

    — Cette partie est optionnelle, et te permet de conserver la liste des plugins actifs. Va plus bas si ça ne t’intéresse pas —
    Entre la requête suivante:

    select option_value from wp_options where option_name = ‘active_plugins’;

    et exécute la.
    phpMyAdmin devrait t’afficher un tableau en retour, avec une seule colonne appelée “option_value”.
    En dessous du tableau, il y a un lien “Version imprimable (avec textes complets)”. Clique dessus. Tu n’es pas obligée d’imprimer, mais conserve bien le texte un peu cryptique dans l’encadré : c’est la liste des plugins activés.
    Reclique sur l’onglet SQL.

    — Continue ici —
    Exécute la requête suivante:

    update wp_options set option_value = ‘a:0:{}’ where option_name = ‘active_plugins’;

    Si tout s’est bien déroulé, phpMyAdmin devrait t’indiquer qu’une ligne a été modifiée.

    Félicitation, tous tes plugins sont désactivés.

    #735766
    clecle
    Participant
    Chevalier WordPress
    305 contributions

    Fait ! Mais toujours rien, le site est hors ligne…

    #735767
    Franck (fge)
    Modérateur
    Maître WordPress
    9583 contributions

    le site est hors ligne…

    C’est normal, les seuls qui peuvent le remettre en route c’est l’hébergeur.

    #735768
    Franck (fge)
    Modérateur
    Maître WordPress
    9583 contributions

    Il serait intéressant de connaître les plugins installés (d’où l’intérêt du questionnaire) pour savoir le(s)quel(s) pourraient être en cause, car cela a toutes les chances de recommencer. Essaye de supprimer ceux qui pourraient être à l’origine du problème (la dernière fois sur ce forum, si mes souvenirs sont bons, c’était liés à l’affichage d’images).
    Dans tous les cas, le code de ces 2 scripts ne sont pas en cause, le problème est l’usage trop intensif qui en est fait.

    #735759
    clecle
    Participant
    Chevalier WordPress
    305 contributions

    Oui d’accord Hum non je pensais que j’avais réussi à désactiver tous les plugins mais non. Donc est-ce que il existerait une autre solution que de passer par phphmyadmin car impossible de m’y connecter ? Renommer le fichier plugin par exemple ?

    #735769
    Antoine_935
    Participant
    Initié WordPress
    5 contributions

    Ah, c’est pas bête ça… En fait, si tu vides ton répertoire “wp-content/plugins”, tout sera d’office désactivé. Bon, garde les quand même de côté, sait-on jamais.

    Comme quoi, à force de chercher trop loin…

    #735770
    clecle
    Participant
    Chevalier WordPress
    305 contributions

    Ok, donc que fais-je ?Je renomme le fichier par exemple “pluginss” et lorsque le site est open je le renomme en “plugins” ? Mes ce que j’ai peur c’est que si je fais cela, toutes mes configurations de plugin seront supprimés non ?

    #735763
    clecle
    Participant
    Chevalier WordPress
    305 contributions

    Antoine_935 je t’ai envoyé un mail 😉

    #735760
    Antoine_935
    Participant
    Initié WordPress
    5 contributions

    Bien reçu le mail, j’y répond dès que je peux.

    Concernant la configuration des plugins, elle est stockée en base de donnée (sauf quelques rares cas). Tu ne risques donc pas de les perdre, sauf à toucher à la base de données.

    À ta place, je laisserais le répertoire plugins là où il est. Par contre, tu peux le copier via ftp. De cette manière, tu es sur de garder les configurations. Après, vide le dossier plugins.

    #735773
    extra
    Participant
    Initié WordPress
    39 contributions

    Oui, tu sauvegarde les plugins sur ton ordi et tu les supprime du serveur, mais c’est clair qu’il y a quelque chose qui va pas sur ton site. Fais une recherhe sur chacun de tes plugins pour voir s’il n’y a pas déjà eu des problèmes avec l’un d’eux.

    Tu dois avoir accès à ton fichier de logs, regarde s’il y a pas eu quelque chose d’anormal.

    #735774
    clecle
    Participant
    Chevalier WordPress
    305 contributions

    Attendez, OVH vient d’ouvrir mon site mais maintenant j’ai le droit à un message d’erreur : Warning: main(/homez.333/thevip/www/wp-includes/load.php) [function.main]: failed to open stream: No such file or directory in /homez.333/thevip/www/wp-settings.php on line 19

    Fatal error: main() [function.require]: Failed opening required ‘/homez.333/thevip/www/wp-includes/load.php’ (include_path=’.:/usr/local/lib/php’) in /homez.333/thevip/www/wp-settings.php on line 19

    Que faire ?

15 sujets de 1 à 15 (sur un total de 38)
  • Vous devez être connecté pour répondre à ce sujet.