[Résolu] Visual Composer non fonctionnel

  • WordPress :5.2
  • Statut : résolu
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Messages
  • #2278087
    Kciel
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    Voici ma configuration WP actuelle…

    • Version de PHP/MySQL : PHPH 5.6
    • Thème utilisé : Jupiter 5.9.3
    • Extensions en place : WPBakery Visual Composer (Modified Version) / Artbees Themes Captcha / AVH Extended Categories Widgets …
    • Version active de WPBakery Visual Composer (Modified Version) : 5.1.1
    • Nom de l’hébergeur : O2switch
    • Adresse du site : http://olivierbleys.com/

    <span style=”text-decoration: underline;”>Problème(s) rencontré(s) : </span>

    Je suis écrivain. J’ai créé seul mon site Internet professionnel, dont vous trouverez l’adresse ci-dessus, en m’aidant de Word Press et d’une version de Visual Composer modifiée pour le thème Jupiter (ArtBees Modified version).

    Tout marchait bien jusqu’à l’été dernier. Puis, la mise à jour d’une extension ou du thème lui-même (j’ignore d’où vient le problème) a semé la pagaille.

    Mes pages continuent de s’afficher correctement sur le site. En revanche, en back-office, la présentation de type de Visual Composer à laquelle j’étais habitué, et qui me permettait de composer facilement mes pages en déplaçant des blocs, n’est plus disponible. Seul apparaît désormais le code html, que je ne sais pas exploiter.

    J’ai tenté de mettre à jour l’extension “WPBakery Visual Composer (Modified Version)”. Un message d’erreur s’affiche : “La mise à jour a échoué : Le téléchargement a échoué. L’URL fournie n’est pas valide.” J’ai tenté d’installer une version standard (non modifiée) de Visual Composer, achetée en ligne — et, depuis, remboursée. Cela a semé le chaos dans mes pages, et il m’a fallu la désactiver.

    Ci-joint, deux copies d’écran de mon back-office, sur une page quelconque. On voit comment Visual Composer, pourtant actif, refuse d’interpréter le code html et considère la page comme “vide”. Je joins également ma liste d’extensions, à toutes fins utiles.

    Bref, je me trouve depuis deux mois dans l’impossibilité de mettre à jour mon site.

    Quelqu’un pour m’aider ? J’ai cherché dans les sujets du forum, mais n’ai pas trouvé de réponse à mes questions.

    La procédure décrite sur cette page d’aide du thème pourrait-elle s’appliquer à mon cas ? :

    https://themes.artbees.net/docs/update-wpbakery-page-builder/

    Tout conseil sera le bienvenu !

    Bonne journée,

    Olivier B.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2278093
    PhiLyon
    Modérateur
    Maître WordPress
    23780 contributions

    Bonjour.

    Essaies de passer ton PHP en 7.3 chez ton hébergeur.

    🙂

    #2278096
    Kciel
    Participant
    Initié WordPress
    4 contributions

    Merci… Je vais tenter.

    Je pensais que les upgrades de PHP se faisaient automatiquement.

    Pour être sincère, je ne m’étais jamais posé la question.

    #2278409
    Flobogo
    Modérateur
    Maître WordPress
    15850 contributions

    Bonjour,

    Faites la mise à jour de version PHP (au moins en PHP 7.2, parfois la 7.3 n’est pas compatible avec toutes les extensions)

    Et ensuite, faites en effet la mise à jour de votre extension VC, en suivant le tuto que vous avez vous-même indiqué. Il y a apparemment une procédure spécifique pour votre thème.

    Et si vous n’y arrivez pas, adressez-vous au support là où vous avez acheté votre thème, ils sont les seuls à pouvoir vous dépanner puisque votre thème est payant, et c’est lui qui nécessite cette extension.

    #2279066
    Kciel
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    Merci de ces nouveaux conseils.

    Je procéderai à la mise à jour ce week-end, et vous tiendrai informés.

    #2279232
    Kciel
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    J’ai procédé à la mise à jour de la version PHP, puis à la mise à jour de l’extension “WPBakery Page Builder” qui remplace l’ancien “Visual Composer”, selon la procédure dont j’avais trouvé la description en ligne (procédure de mise à jour de WPBakery PB).

    Et, enfin… ça marche !

    Merci beaucoup pour votre aide.

    #2279284
    Flobogo
    Modérateur
    Maître WordPress
    15850 contributions

    Merci d’avoir marqué “résolu”. 😉

    Et en effet, pour bien fonctionner, tout doit être à jour : WordPress, le(s) thème(s) et les extensions, mais aussi le “moteur” PHP/MySQL pour la base de données.

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.