Vieilles charrues (Créer un compte)

  • WordPress :5.7
  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #2378647
    belcikowski
    Participant
    Padawan WordPress
    81 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé :
    • Extensions en place :
    • Nom de l’hébergeur :
    • Adresse du site :

    Problème(s) rencontré(s) :

    Puis-je mettre à jour sans risque en WP 5.xx mes sites qui sont en WP 4.9.18 ?

    #2378659
    momofr@free.fr
    Modérateur
    Maître WordPress
    4272 contributions

    Salut, c’est toujours délicat, comme tu as oublié de nous donner les informations sur ton hébergement, le thème et les extensions utilisées je te conseillerais de :

    • Sauvegarder tes sites
    • Les cloner ou les migrer en local
    • Si ils ont la même base technique thème/extension tu fais tes essais sur un seul site
    • On conseille de passer par des étapes 5.0 -> 5.2 -> 5.4 par exemple

    Sans informations supplémentaires je ne peux pas évaluer l’impact que ça peut avoir.

    #2378665
    belcikowski
    Participant
    Padawan WordPress
    81 contributions

    Merci beaucoup.

    Je vais suivre ton conseil et tester en local.

    #2378668
    Flobogo
    Modérateur
    Maître WordPress
    17626 contributions

    Il est clairement risqué pour la stabilité du site de faire le grand saut de 4.9.18 à 5.7.2 (sur ce forum, un membre est récemment venu chercher de l’aide après avoir planté son site, exactement sur cette manip’)

    Je vous conseille de passer en 5.0.13 car le passage 4.9 à 5.0 est particulier.
    Ensuite, vous pouvez tenter d’avancer de 2 en 2 (5.2 / 5.4 / 5.6) comme le suggère Momofr.
    Les anciennes versions sont à récupérer . Prenez toujours la dernière (la + aboutie) de chaque série.

    Et surtout, désactivez systématiquement les extensions, et sauvegardez la BDD à chaque étape. Activez même un thème par défaut (Twenty-XX), ce ne serait pas plus mal (et mettez-le à jour au fur et à mesure), car on ne connaît pas votre/vos thème(s), on ne sait donc pas si il est / sont compatible(s) avec WP 5.7

    Testez le fonctionnement du site “a minima” entre chaque étape.

    #2379317
    belcikowski
    Participant
    Padawan WordPress
    81 contributions

    Bonjour,
    J’ai testé la mise à jour en 5.0.13 sur l’un de mes sites, La dormeuse blogue 2 :
    http://belcikowski.org/ladormeuseblogue2/`Thème : Twenty Seventeen
    Ça passe, sauf que les images ne s’affichent plus.

    Que dois-je faire pour retrouver mes images ?

    Christine

    • Cette réponse a été modifiée le il y a 3 mois et 2 semaines par Flobogo. Raison: retrait des balises de code inutiles
    #2379319
    Flobogo
    Modérateur
    Maître WordPress
    17626 contributions

    Bonjour,

    Aviez-vous désactivé toutes les extensions comme recommandé ?

    La version du thème twenty Seventeen correspond-t-elle à la version WP 4.9.18 ? ou 5.0.13 ? ou autre ?

    #2379320
    belcikowski
    Participant
    Padawan WordPress
    81 contributions

    Non, j’ai changé le thème avant de tenter la mise à jour. J’ai choisi la mise à jour Seventeen qui m’étaitt proposée en l’état sur mon site.

     

    #2379321
    belcikowski
    Participant
    Padawan WordPress
    81 contributions

    Oui, j’ai désactivé toutes les extensions comme recommandé;

    #2379323
    Flobogo
    Modérateur
    Maître WordPress
    17626 contributions

    J’ai choisi la mise à jour Seventeen qui m’était proposée en l’état sur mon site.

    Et donc, c’est quelle version de twenty Seventeen ? Si elle n’est pas adaptée à votre version WP, c’est logique qu’il y ait des soucis.

    #2379414
    belcikowski
    Participant
    Padawan WordPress
    81 contributions

    Bonsoir,

    J’ai fait la mise à jour de l’un de mes sites en 5.0.13.

    J’ai rétabli les images, mais la mise en page est un peu cassée.

    Pour le moment, je laisse en l’état, car le site est lisible.

    Mais les bras m’en tombent à la pensée qu’il faut mettre à jour chacun de mes sites, et retravailler la mise en page, puisque le problème va se retrouver partout.

    Et comme j’ai désactivé tous les plugins, plus de sécurité sur aucun de mes sites…

    Grosse fatigue…

     

    #2379416
    Flobogo
    Modérateur
    Maître WordPress
    17626 contributions

    comme j’ai désactivé tous les plugins, plus de sécurité sur aucun de mes sites…

    Réactivez au moins l’extension de sécurité de chaque site, sinon, vous courrez à la cata ( = risques de piratage ++) avec des sites en ligne mais pas à jour !

    Mais vous n’avez pas répondu à ma question : quelle version de Twenty-Seventeen avez-vous mise en ligne ? Vous pouvez trouver le numéro de version dans votre admin’, à la rubrique Apparence > Thèmes, ou alors dans le tableau de bord

    #2379424
    belcikowski
    Participant
    Padawan WordPress
    81 contributions

    Bonjour,

    J’ai le thème Twente-Seventeen 2.0.

    Je viens d’installer Anti-Malware from GOTMLS.NET, qui est compatible avec ma version de WP.

    Maintenant, il me faut revoir la mise en page du site. Mais ce travail va attendre un peu, car je dois faire évoluer de la même façon tous mes autres sites WP. Et, dans le même temps, je continue à publier de nouveaux articles sur mes sites PluXml…

    Après WP 5.0.13., vers quel autre version de WP dois-je aller ?

     

    #2379470
    Flobogo
    Modérateur
    Maître WordPress
    17626 contributions

    J’ai le thème Twenty-Seventeen 2.0.

    Bon, c’est bien la version correspondant à WP 5.0.x

    Après WP 5.0.13., vers quel autre version de WP dois-je aller ?

    Si tout fonctionne, vous pouvez essayer de “sauter” une version, et d’aller directement à la dernière de WP 5.2, qui est la 5.2.11 à retrouver ici.

    Par contre, si vous n’avez plus (ou pas bien) vos images, c’est sans doute un problème de version de PHP. Pour vos sites WordPress, il faut être au moins en PHP 7.2 ou 7.3 à partir de WP 5.x

    Et il faudra même passer en PHP 7.4 à partir de WP 5.2 ou 5.4 maxi. A voir si cela vous convient pour vos autres sites, ou si votre hébergeur vous permet d’avoir différentes versions de PHP selon vos différents sites.

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.