Utilisation de nav menu et de sidebar

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 16)
  • Auteur
    Messages
  • #495360
    matbook
    Membre
    Padawan WordPress
    79 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : derneire
    – Version de PHP/MySQL :
    – Thème utilisé : perso
    – Extensions en place :
    – Nom de l’hebergeur : locale
    – Adresse du site :

    Problème(s) rencontré(s) :
    header.php:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <!--Titre et description du blog-->
    <title>Usine SPPE – Un site utilisant WordPress</title>
    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>” type=”text/css” media=”screen” />
    <!--[if IE]>
    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
    <![endif]-->
    
    
    
    
    </head>
    <body>
    <div id="global">
    	
    		<div id="header">
    		<div id="top1" >
    			<a href="#" alt="" >
    				<img src="<?php bloginfo('template_directory');?>/images/top12.png” alt=””/></a>
                    <a href="pages/#"><div id="contact"><img src="<?php bloginfo('template_directory');?>/images/menu4.png” alt=””/></div></a>
    		</div>
    		<div id="top2"></div>
    		<ul id="menu">
    <?php wp_nav_menu( array('name' => ‘menu4’ )); ?>  
    <?php wp_nav_menu( array('menu' => ‘syndicat’ )); ?>
    
            <li>
                    <?php dynamic_sidebar('menu1'); ?>
            </li>
            
            <li>
                    <?php dynamic_sidebar('menu2'); ?>
            </li>
            
            <li>
                    <?php dynamic_sidebar('menu3'); ?>
            </li>
    		
    		<li>
                    <?php dynamic_sidebar('menu4'); ?>
            </li>
            
           
            
            
    </ul>
    
    </div>

    Functions.php:

    <?php 
    add_theme_support( 'nav_menus' );
    register_nav_menu('menu1','accueil');
    register_nav_menu('menu2','syndicat');
    register_nav_menu('menu3','production');
    register_nav_menu('menu4','qualite');
    
    register_sidebars(4, array('name'=>‘menu%d’));
    ?>

    Je n’arrive pas à afficher mon nav menu spécifique.
    Mes dynamic sidebar ne s’affichent pas et mon essai avec les nav menu ne m’affiche que la page d’accueil et je ne comprends pas pourquoi….

    #771767
    Guy
    Participant
    Maître WordPress
    14833 contributions

    Les nouveaux menus apparaissent dans les menus utilisables par le thème (apparence/menu)?
    Est ce qu’il y a des menus sélectionnés dans les combobox accueil, syndicat, etc….

    #771768
    matbook
    Membre
    Padawan WordPress
    79 contributions
    #771769
    Guy
    Participant
    Maître WordPress
    14833 contributions

    oups je n’avais pas fait attention à l’appel de nav_menu, peut être renseigner theme_location dans l’appel au menu à la place de name ou menu.

    #771770
    matbook
    Membre
    Padawan WordPress
    79 contributions

    bizarre…j’ai remplacé par thème location il y toutes les pages que j’ai créé qui s’affiche sans pour autant respecter le nav menu… je comprend pas tout

    #771771
    Guy
    Participant
    Maître WordPress
    14833 contributions

    Si toutes les pages s’affichent, c’est au moins que cela marche, il va appeler la fonction wp_page_list quand il n’a pas pu mettre le menu sélectionné.
    Tu es sur que le menu est sélectionné dans Apparence/Menu? Le créer n’est pas suffisant, il faut aussi le sélectionner pour utilisation dans le thème.

    #771772
    matbook
    Membre
    Padawan WordPress
    79 contributions

    comme tu a pu le voir je veux mettre 4 dynamics sidebar pour pouvoir toucher le css pour chaque rubrique plus facilement.
    C’est pourquoi j’ai créer 4 menu nav et que je voulais les mettre dans des sidebar grave à la fonctionnalité des menu personnalisé wordpress mais je n’arrive pas à faire fonctionner tout ça.
    L’utilisation de wp_list_page me limiterai à des pages ors dans deux rubriques il y des catégories que je veux afficher donc..

    #771773
    Guy
    Participant
    Maître WordPress
    14833 contributions

    Je n’avais pas pu voir 🙂 le lien ne fonctionnait pas, c’est pour ça que je reposais la question. Tout est OK en effet.

    Quand tu met le widget menu personnalisé dans une sidebar, cela marche?

    sinon j’ai toujours utilisé register_nav_menu comme ça mais je crois pas que cela change grand chose.
    register_nav_menus(
    array(
    ‘menu1’ => ‘Description menu1’,
    ‘menu2’ => ‘Description menu2’
    )
    );

    #771774
    matbook
    Membre
    Padawan WordPress
    79 contributions

    rien qui change mais c’est bizarre j’appelle:

     ‘accueil’ )); ?>

    et qu’il y ai marquai accueil ou un autre mot ça m’affiche toutes les pages.Il fait quoi exactement ce theme location?

    #771775
    Guy
    Participant
    Maître WordPress
    14833 contributions

    euh, je crois qu’il faut marquer menu1, accueil, c’est juste le titre qu’il y aura écrit au dessus de la combobox si c’est défini comme ça : register_nav_menu(‘menu1′,’accueil’);

    #771776
    matbook
    Membre
    Padawan WordPress
    79 contributions

    quand je met ça:

    register_nav_menu(‘menu1′,’accueil’);
    register_nav_menu(‘menu2′,’syndicat’);

    Il m’affiche deux fois l’accueil…

    #771777
    Guy
    Participant
    Maître WordPress
    14833 contributions

    Le register est bon, c’est dans l’appel à wp_nav_menus( array(‘theme_location’ => ‘menu1’ ));

    #771778
    matbook
    Membre
    Padawan WordPress
    79 contributions

    C’est bon sa marche!!! par contre je vais devoir bidouiller pour rendre tout ça en menu déroulant ou il y une astuce?

    #771779
    matbook
    Membre
    Padawan WordPress
    79 contributions

    c’est bon, j’avais oublier que par admin de wordpress tu peux faire un menu déroulant par contre quand je place met wp_nav entre des li sa ne s’affiche plus par contre il sont bien présent quand je regarde avec la web developper bar… je comprend pas tout ^^

    #771780
    Guy
    Participant
    Maître WordPress
    14833 contributions

    surement un css pas adapté

15 sujets de 1 à 15 (sur un total de 16)
  • Le forum ‘Utilisation spécifique de WordPress’ est fermé à de nouveaux sujets et réponses.