Une ou plusieurs tables de votre base de données sont indisponibles. (Créer un compte)

  • Statut : non résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #487831
    Liznogood
    Membre
    Initié WordPress
    15 contributions

    Ma configuration WP actuelle
    – Version de WordPress 3.0 :
    – PHP Version 5.2.14 :
    – hebergement: OVH Perso :

    Bonjour à tous,

    Je tourne en rond depuis une journée sur un probleme d’installation, et même en écumant les forums je ne trouve pas de réponse à ma question. Pardon d’avance si ce sujet a déjà été traité, je n’ai rien trouvé de concluant en utilisant le moteur de recherche…

    Voilà le truc:
    J’ai développé un site dans un sous répertoire ( site.fr/blog )
    j’ai voulu le basculer sur l’url principale.
    Sans réfléchir, j’ai copié mes fichiers dans site.fr, et bien sur ca n’a pas marché.
    Du coup j’ai décidé de refaire l’install.
    J’ai vidé la base de données (sans la sauvegarder..oui je les ai accumulées)

    Donc au final, j’ai viré ce qu’il y avait sur le ftp pour refaire l’install de wordpress…Et là ca coince, on me dit :

    « Une ou plusieurs tables de votre base de données sont indisponibles. La base de données a peut-être besoin d’être réparée. »

    ensuite, je dois copier une ligne sur mon fichier config => il accede à ma bdd, dit que tout est ok, me demande de supprimer la ligne, de remettre sur le fichier sur le serveur. Je fais tout ca, et il me redit que une ou plusieurs tables sont indisponibles. Je peux recommencer la manip indéfiniment…copier la ligne, réparer la base, enlever la ligne etc.

    Je ne sais plus quoi faire.
    En suivant les conseils glanés sur ce forum, j’ai envoyé un htacces ( avec le code spécifique à OVH) pour forcer php5, mais ca ne change rien à l’affaire.

    Vous l’aurez compris, je suis une bleue.

    Si vous avez des idées pour débloquer la machine, je vous en serai très reconnaissante.
    Merci
    Liz

    #745142
    Liznogood
    Membre
    Initié WordPress
    15 contributions

    Je précise aussi que j’ai bien enregistré mon fichier wp-config.php en UTF-8 ( sans signature), sous Notepad2.

    Le pbl doit donc venir de ma BDD: mais comment savoir ce qui cloche ? Dois-je carrément supprimer les tables ? En fait je ne sais même pas s’il y a des tables par défaut, ou si c’est WP qui les crée.
    Du coup en attendant vos réponse, je ne touche rien… j’ai fait trop de dégâts aujourd’hui pour une seule femme ^^

    #745143
    Liznogood
    Membre
    Initié WordPress
    15 contributions

    Personne n’a d’idées ?🙂

    #745144
    kati
    Participant
    Maître WordPress
    867 contributions

    Bonsoir,

    J’en suis au même point que toi. Même message et cela fait déjà quelques jours que je tente d’installer wordpress!!

    Aurais tu trouvé la solution??

    #745145
    Liznogood
    Membre
    Initié WordPress
    15 contributions

    Hello Kati !

    Oui j’ai trouvé la solution !!!!
    En fait, pendant l’instal j’ai changé le prefixe des tables (le fameux wp_), et ca a marché.
    Mais après on m’a expliqué comment déplacer tranquillement un site WP sur une autre url (Merci PM !!!)

    « Pour déplacer un site WordPress, il faut faire, dans l’ordre et sans interruption :

    1. dans le backoffice WordPress Réglages > Général (wp-admin/options-general.php, donner la nouvelle adresse où faire pointer. Concrètement, il suffit de remplacer site.fr/blog par site.fr
    (il se sert de cette adresse pour savoir où trouver les fichiers « vitaux » de wordpress).

    2. Dans le ftp de wordpress, tu prends tout le contenu de ton répertoire « blog » et tu le copies à la racine du site (typiquement, en le téléchargeant d’abord sur le disque dur puis en envoyant en ligne ce que tu as téléchargé).

    Voilà ! J’espère que cela remarchera aussi pour toi, parce que tourner en rond comme ca…ragghhhh !!!
    Bon courage !
    liz

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.