Un problème de redirection… (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 16)
  • Auteur
    Messages
  • #465145
    Anthony29
    Participant
    Padawan WordPress
    53 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.6.5
    – Thème utilisé : FRESHY
    – Plugins en place : WPPOLLS, MY WEATHER
    – Nom de l’hebergeur : free/neodomaine
    – Adresse du site : http://www.saintevarzec2008.com

    Problème(s) rencontré(s) :

    Bonjour à tous !

    Voici mon problème.
    j’ai un blog wordpress hébergé chez free.
    Pour en changer et pour ne plus avoir de problème de connexion, je choisis de l’héberger chez neodomaine.

    Je mets un version neuve de wordpress dans le FTP neodomaine. un fichier wp-config avec les codes SQL neodomaine. et je fais une importation de SQL de chez free vers neodomaine.

    Jusqu’ici tout va bien, mais lorsque je vais sur mon site WWW, le site redirige automatiquement chez free !
    j’ai beau tout essayé..ça revient chez mon ennuyeux free !

    je précises que j’ai mis une version neuve de wordpress..
    peut-être y a t-il un souci avec l’importation de base de données?

    d’avance merci à tous !

    #653032
    dlo
    Participant
    Maître WordPress
    1850 contributions

    Il faut modifier les valeurs des options « siteurl » et « home » dans la table wp_options via SQL après l’importation des données. Elles contiennent toujours les adresses du blog chez Free. Il faut donc les remplacer par la nouvelle adresse du blog.

    Cordialement

    #653033
    Anthony29
    Participant
    Padawan WordPress
    53 contributions
    dlo wrote:
    Il faut modifier les valeurs des options « siteurl » et « home » dans la table wp_options via SQL après l’importation des données. Elles contiennent toujours les adresses du blog chez Free. Il faut donc les remplacer par la nouvelle adresse du blog.

    Cordialement

    Ok merci, c’est ce que m’a dit Neodomaine également.
    Je l’ai fait…je pense que ça doit être ça..
    mais j’ai cet avertissement qui en découle :

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 19456 bytes) in /home/saintevarzec2008.com/wp-admin/includes/update.php on line 97

    Merci 😉

    #653034
    dlo
    Participant
    Maître WordPress
    1850 contributions

    Dépassement de la mémoire allouée à PHP par l’hébergeur. 8 Mo, c’est trop peu pour WordPress. Il faut au moins 32 Mo, voir 64 Mo.

    A voir auprès du fournisseur du service.

    Cordialement

    #653035
    Anthony29
    Participant
    Padawan WordPress
    53 contributions
    dlo wrote:
    Dépassement de la mémoire allouée à PHP par l’hébergeur. 8 Mo, c’est trop peu pour WordPress. Il faut au moins 32 Mo, voir 64 Mo.

    A voir auprès du fournisseur du service.

    Cordialement

    Bizarre que neodomaine n’alloue que 8mo…
    bon bah je suis donc bon pour rester chez free

    #653036
    Anthony29
    Participant
    Padawan WordPress
    53 contributions

    J’ai une base de 50m0

    et j’ai toujorus ce message…

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 19456 bytes) in /home/saintevarzec2008.com/wp-admin/includes/update.php on line 97

    help !

    #653037
    dlo
    Participant
    Maître WordPress
    1850 contributions
    Anthony29 wrote:
    bon bah je suis donc bon pour rester chez free

    Pas forcemment. Que dit l’hébergeur d’une augmentation de la mémoire allouée à PHP ? Il s’agit juste d’une modification de paramétrage dans le fichier php.ini

    Rester chez Free n’est pas toujours une bonne idée avec les nouvelles restrictions d’utilisation qu’ils viennent de mettre en place.

    Cordialement

    #653038
    dlo
    Participant
    Maître WordPress
    1850 contributions
    Anthony29 wrote:
    J’ai une base de 50m0

    et j’ai toujorus ce message…

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 19456 bytes) in /home/saintevarzec2008.com/wp-admin/includes/update.php on line 97

    help !

    Les 50 Mo sont de l’espace sur disque pour stocker les fichiers. Les 8 Mo sont de la mémoire vive utilisée pour exécuter les programmes. Ce sont deux choses différentes.

    #653039
    Anthony29
    Participant
    Padawan WordPress
    53 contributions
    dlo wrote:
    Anthony29 wrote:
    J’ai une base de 50m0

    et j’ai toujorus ce message…

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 19456 bytes) in /home/saintevarzec2008.com/wp-admin/includes/update.php on line 97

    help !

    Les 50 Mo sont de l’espace sur disque pour stocker les fichiers. Les 8 Mo sont de la mémoire vive utilisée pour exécuter les programmes. Ce sont deux choses différentes.

    boudiou..c’est compliqué !!
    des rames vite ! lol

    #653040
    Anthony29
    Participant
    Padawan WordPress
    53 contributions

    J’ai pourtant testé ce que m’a dit mon hébergeur :
    j’ai placé la ligne ini dans update.php

    <?php
    ini_set(« memory_limit » , « 32M »);
    // The admin side of our 1.1 update system

    Mais rien ne bouge…

    #653041
    dlo
    Participant
    Maître WordPress
    1850 contributions

    Je mettrais plutôt cette ligne dans le fichier wp-config.php, juste après le <?php du début. Ainsi cette instruction sera toujours la première exécutée.

    #653042
    Anthony29
    Participant
    Padawan WordPress
    53 contributions

    neodomaine m’a otroyé un supplément jusqu’a 16m0

    ça semble marcher..mais ça me redirige tjs vers free..alors que j’ai changé dans Wp_options…l’url..
    je veille…

    #653043
    dlo
    Participant
    Maître WordPress
    1850 contributions

    Si les deux options siteurl et home ont été modifiées dans la table wp_options, cela ne devrait plus arriver.

    Bien évidemment, tous les liens qui ont été insérés dans les articles (comme les images, par exemple) pointent toujours vers l’ancienne adresse. Ne serait-ce pas cela ?

    #653044
    Anthony29
    Participant
    Padawan WordPress
    53 contributions

    Encore merci Dlo pour ton support,
    ça a marché !!!
    😉

    #653045
    dlo
    Participant
    Maître WordPress
    1850 contributions

    Et bien bon blogging (Aïe, quel barbarisme !) avec :wp:

15 sujets de 1 à 15 (sur un total de 16)
  • Vous devez être connecté pour répondre à ce sujet.