Un blog collaboratif privé avec P2 et Absolut Privacy

  • Statut : non résolu
Affichage de 1 message (sur 1 au total)
  • Auteur
    Messages
  • #481725
    johnfrancisco
    Membre
    Initié WordPress
    24 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.9.2
    – Version de PHP/MySQL : PHP5
    – Thème utilisé : P2
    – Extensions en place : Absolut Privacy, Add Lightbox & Title, BM Custom Login, Lightbox 2, Peter’s Login Redirect
    – Nom de l’hebergeur : 1and1 et miroir en local
    – Adresse du site : privé

    Problème(s) rencontré(s) :

    Bonjour

    J’ai configuré un wordpress avec P2 et Absolut Privacy pour en faire un blog collaboratif privé (pour parler entre membres de l’édition d’un fanzine). Ce thème et ce plugin vraiment cool.
    Après une configuration assez simple, j’ai installé quelques plugins annexes pour parfaire le truc (genre lightbox et custom login).
    J’ai également modifié simplement le plugin Absolut Privacy pour le régler sur “author” (les droits par défaut en “suscriber” ne permettent pas de poster ou d’ajouter des images…).
    Tout se passait bien, jusqu’au moment de l’éprouver en ligne avec de réels utilisateurs. En effet, le réglage de Absolut Privacy “Block Admin Access” interdisant aux membres de voir les pages d’admin et redirigeant vers la homepage (très pratique pour éviter à des utilisateurs non-averti de se taper le back-end de wordpress et compatible sur le papier avec le fonctionnement front-end de P2) interdisait aux auteurs d’insérer des images dans leurs publications (l’insertion d’image se faisant en front-end par une lightbox de la page d’ajout d’images qui est une page d’admin donc bloquée).

    J’ai contourné ce premier problème en désactivant le “Block Admin Access” (un peu trop strict) de Absolut Privacy et en remplaçant cette fonction par le plugin Peter’s Login Redirect qui lui n’interdit pas l’accès à l’admin mais redirige simplement au moment de la connexion vers une page que l’on choisit.

    Ce réglage ainsi fait les “auteurs” sont épargnés du back-end de WordPress et peuvent tout de même ajouter des images comme prévu avec P2 en front-end.

    Le problème qui se pose maintenant, c’est lorsque l’on rédige un billet rapide de type “status“, avec seulement une image (sans titre de billet, ni de content de post à part l’image), il apparaît dans le corps du post un message de warning de ce genre :

    Warning: strpos() [function.strpos]: Empty delimiter in /xxxxxxx/xxx/xxxxxxxx/xxxxxxxx/xxxxxxx/xxxxx/wp-content/themes/p2/functions.php on line 171

    (J’ai barré par de x le chemin d’accès…)
    Alors ce bug n’apparaît que sur la version en ligne et pas du tout sur la version en local alors qu’elles sont pourtant identiques en terme de plugins installés et de réglages…

    Le message fait apparemment référence à une ligne de code du theme P2 où quelque chose serait vide… (titre et contenu de post)

    Je ne comprend pas bien, si quelqu’un a une idée, par avance, merci.

    HYYdBhRujTH29uBIotlUTuKrOmSVosY4_o.png

    JF

Affichage de 1 message (sur 1 au total)
  • Le forum ‘Utilisation spécifique de WordPress’ est fermé à de nouveaux sujets et réponses.