[Résolu] UGS Woocommerce (Créer un compte)

  • WordPress :6.4
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 23)
  • Auteur
    Messages
  • #2474714
    RodPlay
    Participant
    Initié WordPress
    28 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 8
    • Thème utilisé : ASTRA PRO
    • Extensions en place : Woocommerce
    • Nom de l’hébergeur : AMEN
    • Adresse du site : (en construction)

    Problème(s) rencontré(s) :  Bonjour, une référence UGS semble corrompue sous Woocommerce :
    je créé un nouveau produit en partant d’une image importée ayant une référence utilisée précédemment et mis à la corbeille.

    Woocommerce m’annonce attention UGS déjà utilisé.
    En changeant cet UGS dans la fenêtre produit, rien y fait, l’ancien reste définitivement…

    Y a t-il une possibilité de supprimer la référence UGS en défaut ?
    Comme un nettoyage de BdD spécifique à Woocommerce et comment y accéder ?

    Merci de votre aide.

    • Ce sujet a été modifié le il y a 1 mois par RodPlay.
    #2474716
    RodPlay
    Participant
    Initié WordPress
    28 contributions

    Note : j’ai cherché dans la base de donnée PhP My Admin et n’ai rien trouvé (UGS ou Woocommerce)…
    Si vous avez une orientation ou solution.
    Merci

    #2474717
    Joss47
    Modérateur
    Maître WordPress
    5192 contributions

    Salut,

    peut etre que dans une variation produit tu as ce UGS ?

    Sinon installe cela et fait un coup de clean des variations orphelines : https://wordpress.org/plugins/advanced-database-cleaner/

    (Fais un export de ta BDD avant au cas ou, sait on jamais)

    #2474718
    RodPlay
    Participant
    Initié WordPress
    28 contributions

    Oui ce sont dans les variations, parce qu’il s’agit de peinture avec 3 encadrements possibles
    Manuellement je rentre des UGS pour identifier chaque solution.
    Malgré l’ajout de 2 lettres supplémentaire dans l’UGS du single product, Woo reprend l’UGS source qui est la référence de la peinture initialement enregistrée dans le titre.

    Penses-tu que je puisse effacer uniquement la référence incriminée avec ce plugin ?

    Merci

    #2474719
    Joss47
    Modérateur
    Maître WordPress
    5192 contributions

    Aucune idée mais ça ne fera pas de mal de faire un coup de clean dans tous les cas.

    Sinon tu peux exporter ta liste des produits avec les UGS et tu vas voir si vraiment ce code n’existe réellement plus 😉

    #2474720
    RodPlay
    Participant
    Initié WordPress
    28 contributions

    Sais-tu comment trouver ou identifier cette liste ?
    Je n’ai pas réussi dans la BdD via PhP My Admin (en recherchant : UGS ou Woocommerce)

    #2474721
    Joss47
    Modérateur
    Maître WordPress
    5192 contributions

    Non, tu vas dans ta liste des produits et en haut tu as deux boutons exporter ou importer, pas plus compliqué 🙂

    #2474723
    RodPlay
    Participant
    Initié WordPress
    28 contributions

    Effectivement, j’ai bien 2 doublons et ce sont ces deux références qui bug à l’affichage du pop-up.

    Quelle méthode pour supprimer la référence en défaut ?
    Elle apparait dans la liste, mais je ne la voit pas en double dans la boutique…

    Merci beaucoup de tes conseils.

    #2474724
    Joss47
    Modérateur
    Maître WordPress
    5192 contributions

    Si tu vois le produit dans la liste, il doit être présent en back office obligatoirement.

    A l’aveugle c’est compliqué pour moi de t’en dire plus

    #2474725
    RodPlay
    Participant
    Initié WordPress
    28 contributions

    C’est bien le problème, dans les images du back office, je n’ai que mes 3 références avec cet UGS l’original et 2 modèles de cadres…
    Si j’accédait à la bdD je ne pourrait pas supprimer la ligne qui me dérange ?

    Il semble que la trace de l’ancienne référence, effacée préalablement reste en « fantôme » mais est invisible.
    Puis-je te proposer un accès ?

     

    #2474727
    Joss47
    Modérateur
    Maître WordPress
    5192 contributions

    Sinon, vas dans ton functions.php du theme enfant et tu ajoute cela à la fin :

    add_filter( 'wc_product_has_unique_sku', '__return_false' ); 

    #2474728
    RodPlay
    Participant
    Initié WordPress
    28 contributions

    En fait, le phénomène se passe dès que je met l’image produit. Il me semble que c’est une vignette générée par WordPress, l’image source est de 1733 px.
    Elle sort en 800 x 548 px.

    Ci joint une capture d’écran

    • Cette réponse a été modifiée le il y a 1 mois par RodPlay.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2474731
    Joss47
    Modérateur
    Maître WordPress
    5192 contributions

    Il n’y a aucun rapport entre une image et un UGS produit… je pige pas du tout la…

    Ajoute ce que je viens de te donner et ça règlerai d’office tout tes soucis de UGS dupliqué and co

    #2474732
    RodPlay
    Participant
    Initié WordPress
    28 contributions

    Cela ne change rien…
    J’ai toujours mon problème d’affichage au final.

    Capture avec le défaut sur cette référence (que j’ai imaginé lié à l’UGS) et une autre qui fonctionne.

    Si tu as une piste.

    • Cette réponse a été modifiée le il y a 1 mois par RodPlay.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2474736
    Joss47
    Modérateur
    Maître WordPress
    5192 contributions

    Oula mais ça n’a aucun rapport avec ce que tu dis dans ta demande.

    J’ai cru que tu avais un soucis a cause du UGS mais ça n’a rien à voir la…

    Il faudrait que tu rendes le site accessible ET que tu me donnes l’URL de la fiche produit conernée stp

15 sujets de 1 à 15 (sur un total de 23)
  • Vous devez être connecté pour répondre à ce sujet.