[Résolu] Twenty seventeen affichage mobile

  • WordPress :5.2
  • Statut : résolu
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #2285006
    GoupMasta
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : Twenty Seventeen
    • Extensions en place :
    • Nom de l’hébergeur : Infomaniak
    • Adresse du site : https://vovinam-libourne.fr/

    Problème(s) rencontré(s) :

    Bonjour,

    J’ai un soucis avec le thème Twenty Seventeen. J’ai vu que ce problème à l’air récurant. L’image d’en-tête est coupé en version mobile. J’ai utilisé les lignes de code CSS qui ont été données dans le sujet ci dessous :

    https://wpfr.net/support/sujet/twenty-seventeen-image-den-tete-qui-ne-sadapte-pas-en-mobile/?fbclid=IwAR2f9q1x_z6cSD84m7GW1ouQppNC-iQovhNsdtATY5o-4cenuWgLnKdURF8

    @media screen and (max-width: 768px) {
    .has-header-image.twentyseventeen-front-page .site-branding, 
    .has-header-video.twentyseventeen-front-page .site-branding, 
    .has-header-image.home.blog .site-branding, 
    .has-header-video.home.blog .site-branding,
    .has-header-image.twentyseventeen-front-page .custom-header, 
    .has-header-video.twentyseventeen-front-page .custom-header, 
    .has-header-image.home.blog .custom-header, 
    .has-header-video.home.blog .custom-header {    
      display:block
      max-height: 100%;
    	height: auto;
        left: 0;
        max-width: 100%;
        min-height: 0;
        -o-object-fit:  unset;
        object-fit: unset;
        position: relative;
        -ms-transform: none;
        -moz-transform: none;
        -webkit-transform: none;
        transform: none;
    }
    
    .has-header-image.twentyseventeen-front-page .site-branding, 
    .has-header-video.twentyseventeen-front-page .site-branding, 
    .has-header-image.home.blog .site-branding, 
    .has-header-video.home.blog .site-branding,
    .custom-header-media,
    .has-header-image .custom-header-media img, 
    .has-header-video .custom-header-media video, 
    .has-header-video .custom-header-media iframe {
        position: static;
    }
    
    .custom-header-media:before {
        background: none;
    }
    
    body.has-header-image .site-description, 
    body.has-header-video .site-description {
        color: #222;
        opacity: 1;
    }
    
    .site-branding .wrap {
        padding: 0 1em;
    }  
    }

    Seulement je me retrouve avec l’image d’en-tête comme il faut mais le nom du site, logo, etc, se retrouve sur la droite.

    Est-ce que vous pouvez m’aider s’il vous plait ?

    Cordialement,

    Alexis

     

     

     

     

    #2285033
    PhiLyon
    Modérateur
    Maître WordPress
    24147 contributions

    Bonjour.

    Il manque un ; dans le code, remets-le

    .has-header-video.home.blog .custom-header {    
      display:block /* là */
      max-height: 100%;

    Et sur le simulateur de Firefox, je ne vois pas de titre du tout.

    🙂

    #2285924
    GoupMasta
    Participant
    Initié WordPress
    2 contributions

    Merci pour votre réponse, ça marche.

    Désolé de pas avoir répondu plus tôt.

     

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.