Tuto Mimbo2 (Créer un compte)

  • Statut : non résolu
  • Ce sujet contient 211 réponses, 37 participants et a été mis à jour pour la dernière fois par Anonyme 2, le il y a 11 années.
15 sujets de 16 à 30 (sur un total de 212)
  • Auteur
    Messages
  • #616770
    niss
    Membre
    Initié WordPress
    47 contributions

    Martin,

    Pour l’edito, à mon avis c’est parce que tu as mis l’ID de ta catégorie uniquement dans cette ligne

    query_posts(‘showposts=3&cat=xx’);

    il faut aussi que tu indiques ce meme ID dans cette ligne là :

    wp_list_categories(‘include=xx&title_li=&style=none’);

    Par contre pour ton histoire de blurbs, là j’avoue ne pas comprendre. Je viens de tester en local en ne mettant qu’une seule catégorie et ça passe parfaitement bien… Quel navigateur utilises tu?

    #616771
    Martin
    Membre
    Chevalier WordPress
    484 contributions

    Merci…j’avais complètement zappé la ligne wp list categories !

    Pour mon navigateur Firefox…mais c’est la même chose avec IE. J’ai changé ma page d’accueil pour que tu voies par toi-même. Tu verras donc :

    <div id="rightcol">
        
        <div class="clearfloat">
          is_category = false;
    		$wp_query->is_archive = false;
    		$wp_query->is_home = true;
    		 ?>
          <h3><a href="”></a></h3>
          
          
          <a href="” rel=”bookmark” title=”Lien Permanent vers “><img src="/images/” alt=”” /></a>
          
          <a href="” rel=”bookmark” class=”title”>»</a>
          
          
        </div>
        
      </div><!--END RIGHTCOL-->

    #616772
    Petrucci
    Membre
    Padawan WordPress
    76 contributions

    Bon déjà je tiens encore à remercier Niss pour son aide, je viens de suivre son tuto pour les onglets, c’est clair et ça marche 🍺

    Il me reste quelques petites choses à améliorer et il ne devrait plus y avoir de problèmes:

    voici le site ICI

    1-Est il possible de supprimer le “Pas de catégorie” qui ne sert à rien au dessus de la barre de recherche ? J’ai regardé dans les fichiers, comme colonne latérale, mais j’ai rien vu.

    J’ai installé l’onglet mais:

    2-Comment améliorer la présentation ? onglets “inactifs” en vert clair, titres en vert clair également, {Suite»} … enfin comme le site de Niss quoi :D je n’ai rien de tout ça après l’installation.

    3-Enfin, mes onglets, sauf le premier (mais avec une présentation pas terrible donc), ne marchent pas… il doit y avoir quelque chose que je n’ai pas fait correctement, ou quelque chose à modifier dans un fichier…

    Martin– Dans ta colonne centrale, je ne sais pas si tu le vois, mais il y a une catégorie mal placée (vive le train francilien)

    #616773
    Martin
    Membre
    Chevalier WordPress
    484 contributions

    Petrucci – Oui, justement, ce n’est pas une catégorie, mais un article. Il y a un problème de présentation, mais lequel ? 😉

    Et c’est vrai, je remercie vivement niss, sans toi, je n’aurai jamais essayé, et utilisé, Mimbo ! :D

    Martin
    !D

    #616774
    Petrucci
    Membre
    Padawan WordPress
    76 contributions

    Ah c’est pas simple 😕

    le plugin lightbox 2 marche plus, ça doit être l’installation des onglets :( j’ai rien fait d’autre !

    Et je met mes images chez ipernity mais apparement l’adresse de certaines images n’est pas fixe… donc forcément ça coince et depuis ce matin j’ai deux images qui ne s’affichent plus, avec à la place une vieille image pixellisée ipernity, si il faut à chaque fois vérifier toutes les pages et remplacer les adresses qui ne sont plus valables je vais pas m’en sortir 😉

    #616775
    moimoi123456
    Participant
    Padawan WordPress
    95 contributions

    bonjour a tous je viens a peine d ‘essayer se thème et déjà je vois que vous êtes bien avancer au niveau config etc

    J’ai une question qui risque d’être bête pour vous mais qui reste un petit mystère pour ma part…
    à l’origine c’est comme ca :

    sanstitrewh1.jpg

    Comment doit on faire pour en arriver la :

    sanstitre1ta2.jpg

    Je vous demande ca, car j’ai mis un article dans une categorie et rien n’apparait …

    …Pas d’image dans l’article.
    (Pas d’images non plus dans le carré de sélection rouge de la première image)

    Par contre, en effet l’image est belle et bien la lorsqu’on rentre dans le billet (et l’effet lightbox fonctionne),
    mais j’aimerais voir les images dans le “preview” tout comme ton site (image no2)

    merci a vous

    #616776
    Petrucci
    Membre
    Padawan WordPress
    76 contributions

    Je suis pas certains d’avoir tout compris… mais:

    tu parles des blurbs. et voici ce qu’il faut faire (tuto de Niss)

    “Dans index.php, tu reperes ca : // this is where you enter the IDs of which categories you want to display
    Puis tu remplace le 7,34,35 par les Numeros de categories que tu veux voir apparaitre ici, dans la ligne ci dessous :
    $display_categories = array(7,34,35);

    Par defaut sera pris un article de chacune de ces 3 categorie, si tu veux en afficher par exemple 2 pour chaque categorie, il te suffit de reperer juste un peu en dessous la ligne suivante : <?php query_posts("showposts=1&cat=$category");
    Tu remplace alors le 1 par 2…”

    L’image en page d’accueil est à mettre ds le repertoire image du thème.
    Tu dois remplir, dans Champs personnalisés: la clé (“Image”) et le nom de ton image.jpg

    #616777
    moimoi123456
    Participant
    Padawan WordPress
    95 contributions
    Petrucci wrote:
    Je suis pas certains d’avoir tout compris… mais:

    tu parles des blurbs. et voici ce qu’il faut faire (tuto de Niss)

    “Dans index.php, tu reperes ca : // this is where you enter the IDs of which categories you want to display
    Puis tu remplace le 7,34,35 par les Numeros de categories que tu veux voir apparaitre ici, dans la ligne ci dessous :
    $display_categories = array(7,34,35);

    Par defaut sera pris un article de chacune de ces 3 categorie, si tu veux en afficher par exemple 2 pour chaque categorie, il te suffit de reperer juste un peu en dessous la ligne suivante : <?php query_posts("showposts=1&cat=$category");
    Tu remplace alors le 1 par 2…”

    L’image en page d’accueil est à mettre ds le repertoire image du thème.
    Tu dois remplir, dans Champs personnalisés: la clé (“Image”) et le nom de ton image.jpg

    ok merci a toi c’est ca

    par contre derniere presision stp
    pour mes images dans mes articles je fais ca

    Mon Image

    mais comment dois-je faire pour voir l image dans le billet a l acceuil (avec cette balise (‘image’) )

    #616778
    niss
    Membre
    Initié WordPress
    47 contributions

    Petrucci,

    je viens d’aller jeter un oeil sur ton site, les onglets sont inactifs (on ne peut pas cliquer dessus) et je pense savoir pourquoi : tu as oublié de déclarer ces 2 lignes (ou une des 2) dans le de header.php

    <script type="text/javascript" src="”>
    <script type="text/javascript" src="”>

    sinon, pour les couleurs des onglets et autre points de mise en forme de ces onglets, il suffit juste d’aller un peu retoucher le fichier style.css dans les classes concernant les tab que tu as rajouté (partie 3 du tuto ci-dessus). Si tu ne trouves pas ou modifier, fais le moi savoir et je t’indiquerai dès que possible l’endroit exact 😉

    Bien content que ce thème ait autant de succés, je trouve personnellement que c’est une tuerie absolue!!

    #616779
    Martin
    Membre
    Chevalier WordPress
    484 contributions

    @moimoi123456, la clé Image ne sert que pour la page d’accueil. Donc tu laisses le code de tes images normal. Il faut juste que tu spécifies, ou non, une image avec la bonne taille pour identifier l’article sur la page d’accueil. Cette iage ne servira plus après, sauf si tu la demandes dans l’article. Lis bien le récapitulatif de niss plus haut : TOUT est expliqué ! Merci niss :D


    @niss
    : as-tu pu jeter un petit coup d’oeil sur mon site ? 😇😇

    Merci !

    Martin
    !D

    #616780
    niss
    Membre
    Initié WordPress
    47 contributions

    Hello Martin,

    Ecoute, apparemment pour toi tout est ok d’après ce que je vois… Juste, pour le 2e blurb qui apparait en decalé sous le 1er, c’est rien de bien méchant : c’est parce que l’extrait de ton article que tu as mis pour le 1er blurb est trop court… Rallonge le juste un petit peu et tu verras que celui du dessous n’appparaitra plus en décalé 😉

    #616781
    Martin
    Membre
    Chevalier WordPress
    484 contributions

    Salut !

    Ok, j’ai essayé, mais j’arrive pas à rallonger l’extrait….
    Tant pis, j’ai mis en brouillon pour 1 sec, et effectivement tout rentrait dans l’ordre. A ceci près, que l’on n’a pas la barre avec les pointillés. Je sais, c’est un peu du détail, mais comme je n’ai qu’une catégorie, ça a son importance… Si tu pouvais m’aider (encore une fois :D) sur ce coup…. Merci

    D’autre part, que faut-il faire pour changer le “Martin est ” en bas des articles ?

    Merci.

    Martin
    !D

    #616782
    moimoi123456
    Participant
    Padawan WordPress
    95 contributions

    en effet mercia vous deux je viens de comprendre pour la balise image

    #616783
    Petrucci
    Membre
    Padawan WordPress
    76 contributions

    Merci Niss 🍺

    
    <html xmlns="http://www.w3.org/1999/xhtml" >
    
    
    <meta http-equiv="Content-Type" content="; charset=” />
    
    
    <title>  
    » cat_name . ‘ ‘; 
    } ?>  
    
    </title>
    
    <meta name="generator" content="WordPress ” /> <!-- leave this for stats -->
    
    <link rel="stylesheet" href="” type=”text/css” media=”screen” />
    <link rel="stylesheet" href="/nav.css” type=”text/css” media=”screen” />
    <link rel="stylesheet" href="/print.css” type=”text/css” media=”print” />
    
    <script type="text/javascript" src="/js/dropdowns.js”>
    
    <link rel="alternate" type="application/rss+xml" title=" RSS Feed” href=”” />
    <link rel="pingback" href="” />
    
    
    
    
    
    <title>Cyclotourisme en Montagne</title>
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    <script type="text/javascript" src="”>
    <script type="text/javascript" src="”>
     
    <body id=”home”>
    <div id="page" class="clearfloat">
    
    
    <div class="clearfloat">
    <div id="branding" class="left">  
    <h1><a href="/”></a></h1>
    <div class="description">

    Voilà mon fichier header, et comme tu peux le constater, j’ai bien inséré le code que tu m’as donné 😐

    Ahh c’est vraiment pas de chance, je suis à deux doigts de tout régler mais là, je sèche.
    Je ne parviens pas à rendre les onglets actifs… et même si ça marche, j’ai un problème avec lightbox qui ne fonctionne plus du tout depuis que j’ai installé les onglets :(

    #616784
    Petrucci
    Membre
    Padawan WordPress
    76 contributions
    Martin wrote:
    Salut !

    que faut-il faire pour changer le “Martin est ” en bas des articles ?

    Merci.

    Martin
    !D

    Il faut aller dans ton profil et remplir ce que tu souhaites dans “à propos de vous”.

15 sujets de 16 à 30 (sur un total de 212)
  • Vous devez être connecté pour répondre à ce sujet.