transfert de localhost vers 1&1 avec Filezilla

  • Statut : non résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #510406
    noixdecoco
    Participant
    Chevalier WordPress
    278 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.2
    – Version de PHP/MySQL : 5.3
    – Thème utilisé : twenty eleven
    – Extensions en place : none
    – Nom de l’hebergeur : 1&1
    – Adresse du site : http://www.lesdelicesdemimi.com

    Problème(s) rencontré(s) :

    J’ai travaillé en localhost et quand j’ai tout basculé sur mon serveur en ligne avec mon ftp je ne retrouve pas mon site mais seulement le css que j’avais modifié. Mes pages et mes article n’apparaissent pas !
    Une explication ?
    Merci

    #836206
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    Avant de faire l’importation, des tables de données WordPress, vous devez les ouvrir avec un traitement de texte et remplacer l’adresse localhost/wordpress (si vous avez placé WordPress dans un dossier wordpress en local) par la nouvelle adresse http://www.lesdelicesdemimi.com (sans le http://).

    De plus, via Filezilla, vous devez transférer sur votre nouveau site avec Filezilla, le dossier wp-content/uploads de votre site local, si bien sûr vous avez des images sur votre site.

    #836207
    noixdecoco
    Participant
    Chevalier WordPress
    278 contributions

    Merci,

    J’ai exporté mes tables et j’ai obtenu un fichier.sql sur le bureau. Je l’ai ouvert avec notepad++ et j’ai trouvé à la ligne 142 cela :

    INSERT INTO `wp_options` (`option_id`, `blog_id`, `option_name`, `option_value`, `autoload`) VALUES
    (3, 0, ‘siteurl’, ‘http://localhost/wordpressmimi’, ‘yes’)

    Que je remplace donc par

    INSERT INTO `wp_options` (`option_id`, `blog_id`, `option_name`, `option_value`, `autoload`) VALUES
    (3, 0, ‘siteurl’, ‘lesdelicesdemimi.com’, ‘yes’)

    Par contre je ne trouve pas l’onglet “importer” dans l’administration des base de données de 1&1 ? Pourtant il existe sur wampserver dans phpmyadmin !

    Quelqu’un peut m’aider ?

    #836208
    luciole135
    Participant
    Maître WordPress
    13753 contributions
    noixdecoco wrote:
    Merci,

    J’ai exporté mes tables et j’ai obtenu un fichier.sql sur le bureau. Je l’ai ouvert avec notepad++ et j’ai trouvé à la ligne 142 cela :

    INSERT INTO `wp_options` (`option_id`, `blog_id`, `option_name`, `option_value`, `autoload`) VALUES
    (3, 0, ‘siteurl’, ‘http://localhost/wordpressmimi’, ‘yes’)

    Que je remplace donc par

    INSERT INTO `wp_options` (`option_id`, `blog_id`, `option_name`, `option_value`, `autoload`) VALUES
    (3, 0, ‘siteurl’, ‘lesdelicesdemimi.com’, ‘yes’)

    Par contre je ne trouve pas l’onglet “importer” dans l’administration des base de données de 1&1 ? Pourtant il existe sur wampserver dans phpmyadmin !

    Quelqu’un peut m’aider ?

    Non, c’est “ocalhost/wordpressmimi” qu’il faut remplacer par “www.lesdelicesdemimi.com”.

    #836209
    noixdecoco
    Participant
    Chevalier WordPress
    278 contributions

    Merci,

    Tu parlais des www devant (sans le http://) ?, comme cela :

    INSERT INTO `wp_options` (`option_id`, `blog_id`, `option_name`, `option_value`, `autoload`) VALUES
    (3, 0, ‘siteurl’, ‘www.lesdelicesdemimi.com’, ‘yes’)

    😕

    #836210
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    Perso, je ne me prends pas la tête, avec notepad++, il y a un bouton “Rechercher”, je clique dessus et je chosis “remplacer”. il s’ouvre une fene^tre et dans TOUTES les tables de données (pas uniquement wp-options), remplacer “localhost/wordpressmimi” par “www.lesdelicesdemimi.com”.

    Pour ce faire, il suffit de sélectionner TOUTES les tables de données (elles sont surlignées en rouge) de faire un clic droit et d’ouvrir avec notepad++.
    Puis, dans la fenêtre de remplacement précédente, il y a l’option “remplacer dans tous les documents ouverts”.
    Ainsi, le changement est fait dans TOUTES les tables !

    #836211
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    Bien sûr ne pas oublier d’enregistrer tous les documents avec l’option idoine en cliquant sur l’onglet “fichier”, puis “enregistrer tout” de notepad++.

    #836212
    noixdecoco
    Participant
    Chevalier WordPress
    278 contributions

    Merci,
    J’ai bien fait tout cela avec notepad++ (très pratique) maintenant je ne sais pas comment importer mes tables vers mon serveur 1and1 ?:(

    #836213
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    La FAQ de 1&1 donne une solution avec PhpMyAdmin :
    http://faq.1and1.com/web_space__access/mysql/17.html

    #836214
    noixdecoco
    Participant
    Chevalier WordPress
    278 contributions

    Ok, ça fonctionne!
    Un truc bon à savoir c’est que si des tables existent déjà ils faut alors les effacer sinon ça fonctionnera pas. Il ne faut pas effacer la base de donnée dans mon cas.
    Merci encore
    🍺

    #836215
    emry
    Participant
    Chevalier WordPress
    141 contributions

    S’il vous plait, venez-moi en aide. ça fait deja plus d’une semaine que je cherche des reponses en vain. J’ai ouvert un compte chez hostgator, mais là n’est pas le probleme je pense. Je suis nouveau et je ne maitrise pas ces bricolage de code et autre. Quand j’installe wordpress depuis le cpanel, il est en anglais. J’ai donc transferer tout le contenu de wordpress fr via ftp vers le dossiers www de mon repertoir principal. On m’ expliqué qu’apres cela, il faut aller sur http://www.mosite.com/wp_admin/install.php pour configurer wordpress. Or, l’orsque je le fait je suis rediriger vers une page d’erreur 404 avec le logo de mon hébergeur.
    Questions: Apres le transfere, quels sont les ficheirs et les modifications que l’on doit apporter pour resoudre mon probleme? merci

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.