Traductions plus reconnues – Thème Graphene

  • WordPress :4.9
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 16)
  • Auteur
    Messages
  • #2043451
    gutenmorgwen
    Participant
    Initié WordPress
    5 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 5.6.33
    • Thème utilisé : Graphene
    • Extensions en place : AJAX Thumbnail Rebuild, Akismet Anti-Spam, All in one Favicon, CodeStyling Localization, Easy Facebook Likebox, Gmedia Gallery, Google Analytics Dashboard for WP (GADWP), Google Language Translator, Jetpack par WordPress.com, Link Manager, Loco Translate, MailPoet 2, PO/MO Editor, Re-add text underline and justify, Shareaholic, Social Media Widget, Special Recent Posts FREE Edition, TablePress, Theme Test Drive, WordPress Importer, WordPress phpinfo(), WordPress Popular Posts, WP Lightbox 2, WP-Polls, WPtouch Mobile Plugin, Yoast SEO
    • Adresse du site : gutenmorgwen.com

    Problème(s) rencontré(s) :

    Bonjour,

    Je vous écris car depuis les dernières mises à jour de mon thème Graphene, toutes mes traductions ont disparues, elles sont pourtant présentes dans mon fichier fr_FR.po (sous « /wp-content/themes/graphene/languages »)
    Le ficher fr-FR.po n’apparait plus dans mon extension PO/MO Editor alors que celui-ci est bien présent sous « /wp-content/themes/graphene/languages ».

    Le thème semble ne plus reconnaitre mon fichier, il le cherche peut être dans un autre dossier… merci par avance pour votre aide.

    Par exemple, on peut lire sur la page d’accueil de mon site « Continue reading » alors que ma traduction « Lire la suite » est présente dans mes traductions.

     

    #2043624
    PhiLyon
    Modérateur
    Maître WordPress
    20529 contributions

    Bonjour.

    Les fichiers dans wp-content/languages/themes doivent se nommer ainsi graphene-fr_FR, c’est le cas ?

    🙂

    #2043629
    PhiLyon
    Modérateur
    Maître WordPress
    20529 contributions

    Et tes extensions, dont ton PO/MO Editor sont-elles à jour ?

    🙂

    #2044331
    gutenmorgwen
    Participant
    Initié WordPress
    5 contributions

    Merci pour cette réponse rapide 🙂

    Oui, mes fichiers sous wp-content/languages/themes, se nomment graphene-fr_FR.po und graphene-fr_FR.mo

    Mais j’ai également les fichiers fr_FR.po et fr_FR.mo sous /wp-content/themes/graphene/languages

    Je ne sais pas bien pourquoi les traductions sont ici en double.

    Mes extensions, dont PO/MO Editor sont bien à jour.

    #2044484
    PhiLyon
    Modérateur
    Maître WordPress
    20529 contributions

    Supprimes ceux dans le thème.

    🙂

    #2044486
    Flobogo
    Modérateur
    Maître WordPress
    14910 contributions

    Bonjour,

    mes fichiers sous wp-content/languages/themes, se nomment graphene-fr_FR.po et graphene-fr_FR.mo

    Mais j’ai également les fichiers fr_FR.po et fr_FR.mo sous /wp-content/themes/graphene/languages

    –> sauvegardez ces 4 fichiers sur votre ordi par précaution (en passant par le FTP)

    Ensuite, je vous conseille de tester en supprimant les fichiers fr_FR qui sont dans le dossier du thème Graphene, pour ne garder que ceux qui sont dans wp-content/languages/themes et qui se nomment graphene-fr_FR.po et graphene-fr_FR.mo

    #2044827
    gutenmorgwen
    Participant
    Initié WordPress
    5 contributions

    J’ai  supprimé les fichiers fr_FR qui étaient dans le dossier du thème Graphene et je n’ai plus que ceux qui sont dans wp-content/languages/themes, ils se nomment graphene-fr_FR.po et graphene-fr_FR.mo

    J’ai actualisé le tout, je n’ai malheureusement toujours aucune traduction. « Continue reading » est toujours affiché en ligne au lieu de «Lire la suite ».

    Pour info, sous PO/MO Editor, l’arborescence « /wp-content/themes/graphene/languages » est prise en compte (cf screenshot ci-joint).

    Peut être qu’une fonction de mon thème appelle un mauvais fichier / mauvais répertoire concernant les traductions du thème et par conséquent mes fichiers .po et .mo ne sont pas reconnus. Je ne sais pas trop… ou est-ce peut être un problème de compatibilité entre mes extensions ? (CodeStyling Localization, PO/MO Editor?)

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2044924
    PhiLyon
    Modérateur
    Maître WordPress
    20529 contributions

    Bonjour.

    Supprimes/désactives LocoTranslate et PO/MO Editor.

    Il vient d’y avoir une mise à jour de Graphene en 2.2, fais-la, supprimes les fichiers po et mo dans wp-content/languages/themes et relances tout (vides tes caches).

    Je viens de tester, le Continue Reading est traduit.

    Si tu veux modifier la traduction d’autres termes, utilises Poedit, c’est plus simple.

    🙂

    #2045034
    gutenmorgwen
    Participant
    Initié WordPress
    5 contributions

    J’avais déjà la version 2.2 de Graphene.

    J’ai désactivé LocoTranslate et PO/MO Editor.
    J’ai supprimé les fichiers po et mo dans wp-content/languages/themes puis vidé mon cache, Continue Reading n’est toujours pas traduit chez moi.

    Vous avez pu voir mon site avec Continue Reading traduit ? http://gutenmorgwen.com/

    J’ai du mal à comprendre.

    #2045137
    PhiLyon
    Modérateur
    Maître WordPress
    20529 contributions

    Réinstalles le thème.

    🙂

    #2045357
    PhiLyon
    Modérateur
    Maître WordPress
    20529 contributions

    Et si ça ne suffit pas, désactives tes extensions une par une pour tester.

    🙂

    #2047693
    gutenmorgwen
    Participant
    Initié WordPress
    5 contributions

    Merci beaucoup ça marche désormais 🙂

     

    #2092179
    jpauldulot
    Participant
    Initié WordPress
    2 contributions

    Bonjour

    J’ai eu le même problème avec le thème Graphene.

    En fait, ce sont les fichiers graphene-fr_FR.po et graphene-fr_FR.mo (dans wp-content/languages/themes) qui mettent la pagaille. Il faut les supprimer. J’ai conservé uniquement les fichiers fr_FR.po et fr_FR.mo sous /wp-content/themes/graphene/languages en les complétant et en les corrigeant, et ça marche mieux ainsi.

    #2092695
    jpauldulot
    Participant
    Initié WordPress
    2 contributions

    Bonjour

    En fait, la réponse que j’ai apportée précédemment ne marche que temporairement. En effet, au bout d’un certain temps, les fichiers graphene-fr_FR.po et graphene-fr_FR.mo (dans wp-content/languages/themes) se régénèrent automatiquement, et le problème revient : certaines traductions ne sont plus reconnues. Or, les traductions contenues dans graphene-fr_FR.po et graphene-fr_FR.mo datent du 29 août 2016. Elles sont donc plus anciennes que celles de fr_FR.po et fr_FR.mo sous /wp-content/themes/graphene/languages qui datent du 24 novembre 2017.

    Comment faire pour que ce ne soit plus la version obsolète qui soit prise en compte ou qu’elle ne soit pas régénérée automatiquement ?

    #2092904
    WP Traduction
    Modérateur
    Maître WordPress
    1730 contributions

    @jpauldulot : si un modérateur conseille d’installer les fichiers de traduction dans le dossier /wp-content/languages/themes, ce n’est pas pour rien, mais tout simplement parce que ça vous évite de perdre vos fichiers lors des mises à jour du thème, tout simplement.

    J’ai vu que vous aviez proposé vos traductions sur https://translate.wordpress.org/locale/fr/default/wp-themes/graphene, j’ai donc prévenu les Global Translation Editors afin qu’ils vérifient vos suggestions et les valident si elles sont bonnes (patience, la plupart sont déjà en week-end et ils sont tous bénévoles).

    Je vous invite donc à rejoindre le Slack WordPress (vous trouverez le formulaire d’inscription en bas à gauche de l’accueil du forum) afin de pouvoir communiquer avec eux 😉

15 sujets de 1 à 15 (sur un total de 16)
  • Vous devez être connecté pour répondre à ce sujet.