Traduction partielle d’un thème WP

  • WordPress :4.7
  • Statut : non résolu
8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #1643419

    Asaiel
    Participant
    Initié WordPress
    5 contributions

    Bonjour à tous,

    Il s’agit de mon 1er post sur ce forum, j’ai pris connaissance des règles du forum, et j’espère sincèrement ne rien oublier :-).

    Tout d’abord un point sur ma configuration WP (en utilisant le plugin spécifié):

    • – Version de WordPress : 4.8
    • – Version de PHP/MySQL : 5.6.30 / 5.1.73
    • – Thème utilisé : Luminescence Lite Child (Thème enfant issu du thème principal Luminescence Lite)
    • – Thème URI : http://demo.styledthemes.com/luminescence-free/
    • – Extensions en place : Add From Server (3.3.3), All In One SEO Pack (2.3.13.2), BackWPup (3.4.0), Broken Link Checker (1.11.3), BulletProof Security (1.1), Contact Form 7 (4.8), Cookie Notice (1.2.38), Flamingo (1.6), Forum_wordpress_fr (4.1), MainWP Child (3.4.1), MCE Table Buttons (3.2), Members (1.1.3), Photo Gallery (1.3.45), Really Simple CAPTCHA (2.0), Responsive WordPress Slider – Soliloquy Lite (2.5.1.3), Theme Authenticity Checker (TAC) (1.5.3), TinyMCE Advanced (4.6.3), User Switching (1.0.9), WP Maintenance (3.0.2), WP Security Audit Log (2.6.4)
    • – Adresse du site : http://arkhaia.fr. Page du problème rencontré: http://arkhaia.fr/journees-nationales-archeologie-2017/
    • – Nom de l’hébergeur : 1&1

    Le problème rencontré est le suivant: le thème est livré avec un fichier .pot permettant la création des fichiers mo et po nécessaires à la traduction en français.

    J’ai donc téléchargé et utilisé poedit afin de créer les fichiers de traduction. Jusque la, tout fonctionne bien.

    Je constate cependant un problème concernant une page comportant des commentaires. Lorsqu’il n’y en a qu’un seul, la traduction est OK. Dès lors qu’il y en a plusieurs, la traduction ne se fait pas, et le titre s’affiche en Anglais.

    Vérification faite dans mon fichier PO (au niveau du thème), j’ai trouvé la ligne suivante:

    Texte source: One comment on “%2$s”
    
    Traduction: 1 commentaire sur “%2$s”
    Poedit

    Ce qui explique que lorsque le commentaire est unique, cela fonctionne. Par ailleurs, il semblerait que les commentaires multiples ne correspondent à aucune traduction.

    le fichier comments.php concerné pour ce thème comporte le code suivant à la ligne 32:

    <?php printf( _n( 'One comment on “%2$s”', '%1$s comments on “%2$s”', get_comments_number(), 'luminescence-lite' ), number_format_i18n(get_comments_number() ), '<span>' . get_the_title() . '</span>' ); ?>
    comments.php ligne 32

    Je comprends donc que lorsque la fonction renvoie la valeur au singulier, la traduction fonctionne. Lorsque elle renvoie la valeur plurielle, ca ne fonctionne pas.

    J’ai essayé d’ajouter manuellement la ligne %1$s comments on &ldquo;%2$s&rdquo; dans le fichier .pot, puis de créer la traduction correspondante en re-générant les fichiers po et mo, mais ca ne fonctionne pas non plus.

    A noter enfin que, le thème étant gratuit, le développeur n’en assure pas le support, c’est pourquoi je vous sollicite aujourd’hui.

     

    Merci d’avance pour votre aide,

    • Ce sujet a été modifié le il y a 5 mois et 3 semaines par  Asaiel.
    #1643477

    PhiLyon
    Modérateur
    Maître WordPress
    17106 contributions

    Bonjour.

    Je transfère dans le forum Traduction française

    🙂

    #1643664

    WP Traduction
    Modérateur
    Maître WordPress
    1306 contributions

    Bonjour,

    En fait les pluriels se trouvent au même niveau que les singuliers correspondant, mais il faut cliquer sur l’onglet « Puriel » au niveau de la chaîne en question.

    Comme ce n’est pas forcément très explicite comme cela, je vais vous faire un tutoriel vidéo 😉

    #1643697

    Asaiel
    Participant
    Initié WordPress
    5 contributions

    Bonjour, et merci beaucoup pour votre réponse.

    Je suppose que l’onglet en question se trouve dans poedit? Je viens de regarder, mais je ne l’ai pas trouvé. Peut être faut il avoir la version pro?

    Je regarderai votre tutoriel avec intérêt, et je vous remercie d’emblée de prendre le temps de le réaliser.

    #1645355

    Asaiel
    Participant
    Initié WordPress
    5 contributions

    Rebonjour WP Traduction,

     

    Suite à votre précédent message, j’avoue n’avoir pas encore trouvé l’élément que vous évoquez. Pourriez-vous svp m’en dire plus?

     

    Merci d’avance!

    #1645383

    WP Traduction
    Modérateur
    Maître WordPress
    1306 contributions

    Bonsoir,

    Veuillez m’excuser, mais le PC avec lequel je tourne mes tutoriels vidéos ne disposait plus d’assez d’espace disque … j’ai donc du faire du ménage, mais ça n’a pas été facile.

    J’ai enfin pu trouver la solution et le temps de tourner votre tuto.

    J’ai bien pris la peine de vérifier que cet élément existe aussi bien sur la version gratuite que Pro de Poedit, alors si vous ne trouvez cet élément, c’est tout simplement que la traduction a mal été préparée par le créateur du thème.

    #1645415

    Asaiel
    Participant
    Initié WordPress
    5 contributions

    Un grand merci pour le temps que vous avez pris pour créer ce tutoriel.

    Je dois donc avoir un problème dans le fichier pot (ou autre?).

    En PJ la capture d’écran (réalisée en partant du fichier pot). Comment puis-je le modifier pour faire apparaitre l’option?

     

    Pour info, ci-dessous l’extrait du fichier présentant la ligne concernée:

    #: comments.php:32
    #, php-format
    msgid "One comment on \"%2$s\""
    msgstr ""
    Lignes extraites du fichier pot

    • Cette réponse a été modifiée le il y a 5 mois et 2 semaines par  Asaiel.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #1645435

    Asaiel
    Participant
    Initié WordPress
    5 contributions

    Un complément d’information, pour les personnes qui se trouveraient dans le même cas:

    https://poedit.net/trac/wiki/Doc/PluralForms

    http://docs.translatehouse.org/projects/localization-guide/en/latest/l10n/pluralforms.html?id=l10n/pluralforms

     

    Dans mon cas, le header du fichier pot:

    "Plural-Forms: nplurals=2; plural=(n != 1);\n"
    Header pot

8 sujets de 1 à 8 (sur un total de 8)
  • Vous devez être connecté pour répondre à ce sujet.