Traduction de l’espace commentaire (leave a comment, post comment, your name..) (Créer un compte)

  • WordPress :5.3
  • Statut : non résolu
  • Ce sujet contient 12 réponses, 4 participants et a été mis à jour pour la dernière fois par AXIOME, le il y a 1 mois.
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #2337746
    AXIOME
    Participant
    Initié WordPress
    9 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : aucune idée : surement très récent car démarrage du site il y a 15 jours
    • Thème utilisé : Dabba
    • Extensions en place : Loco translate,
    • Nom de l’hébergeur : Ionos
    • Adresse du site : http://www.gwadactu.fr

    Problème(s) rencontré(s) :

    Bonjour,

    Je sais que ce sujet à déjà été abordé mais les sujets ne m’apportent pas la réponse ou alors sont trop anciens pour fonctionner comme indiqué.

    En effet : Je n’arrive pas à traduire la partie commentaire de mes articles : “Leave a comment”, “Post comment”, “Your comment…”.
    Mon thème est traduit, j’ai installé Loco Translate, et j’ai la version française de WordPress.

    J’ai regardé dans index.php et comment.php mais aucune trace de ces mots.

    Merci pour votre aide !

    Bonne journée,

    Maxime

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2337776
    Li-An
    Modérateur
    Maître WordPress
    23693 contributions

    Bonjour, c’est un peu étrange car ces termes sont en théorie traduits directement par WP (c’est peut-être pour cela que vous ne les trouvez pas dans le thème, c’est une fonction de WP qui appelle la zone de commentaires). Comme le thème est payant, nous n’y avons pas accès mais posez la question au développeur.

    #2337925
    AXIOME
    Participant
    Initié WordPress
    9 contributions

    Bonjour Li-An,

    Merci pour ta réponse. C’est en effet assez étonnant.

    J’ai trouvé une piste de reflexion… : screenshot en PJ.

    J’ai un message d’erreur sur la synchro de loco translate dans la partie WordPress, section 5.4.x – Development (défault) : “<strong class=”has-icon”>Avertissement: 27 fichiers sur 100 KB ont étés ignorés. (Le poids du plus large est de 290.4 KB). Vérifiez que toutes les chaînes sont présentes avant de sauvegarder.”

    Voilà, une idée ?

    Merci encore.

    Maxime

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2337928
    PhiLyon
    Modérateur
    Maître WordPress
    25682 contributions

    Bonjour.

    Quand as-tu fait la mise à jour de WordPress ?

    Si c’est le 1er au matin, il y avait un bug dans la traduction, celui-ci a été corrigé dans l’après-midi.

    🙂

    #2339974
    AXIOME
    Participant
    Initié WordPress
    9 contributions

    Bonjour,

    J’ai fait la mise à jour par la suite… donc le problème persiste. je ne sais toujours pas comment faire. 🙁

    Très bizarre alors !

    Si vous avez une idée, je suis toujours preneur.

    Merci beaucoup

    Maxime

    #2339975
    Li-An
    Modérateur
    Maître WordPress
    23693 contributions

    Vérifiez dans votre fichier wp-config.php que vous ayez bien
    <div>define(‘WPLANG’, ‘fr_FR’);</div>

    #2339976
    AXIOME
    Participant
    Initié WordPress
    9 contributions

    Hello,

    Nous en effet, je ne l’ai pas :

    <?php
    
    define('FS_METHOD', 'direct');
    define('FORCE_SSL_ADMIN', true);
    
    
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define( 'DB_NAME',
    
    /** MySQL database username */
    define( 'DB_USER', 
    
    /** MySQL database password */
    define( 'DB_PASSWORD', 
    
    /** MySQL hostname */
    define( 'DB_HOST', 
    
    /** Database Charset to use in creating database tables. */
    define( 'DB_CHARSET', 'utf8' );
    
    /** The Database Collate type. Don't change this if in doubt. */
    define( 'DB_COLLATE', '' );
    
    /**
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix = 
    
    
    
    
    /* That's all, stop editing! Happy publishing. */
    
    /** Absolute path to the WordPress directory. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', dirname( __FILE__ ) . '/' );
    }
    
    /** Sets up WordPress vars and included files. */
    require_once ABSPATH . 'wp-settings.php';
    WP Config

    Que dois-je donc faire ?

    Merci !

    • Cette réponse a été modifiée le il y a 1 mois par Li-An. Raison: mots de passe
    #2339978
    Li-An
    Modérateur
    Maître WordPress
    23693 contributions

    Aaaaah, ne jamais mettre en clair des mots de passe sur un forum !

    Vous pouvez rajouter

    /**
     * Langue de localisation de WordPress, par défaut en Anglais.
     *
     * Modifiez cette valeur pour localiser WordPress. Un fichier MO correspondant
     * au langage choisi doit être installé dans le dossier wp-content/languages.
     * Par exemple, pour mettre en place une traduction française, mettez le fichier
     * fr_FR.mo dans wp-content/languages, et réglez l'option ci-dessous à "fr_FR".
     */
    define('WPLANG', 'fr_FR');
    langue

    après la ligne table_prefix

    #2339987
    AXIOME
    Participant
    Initié WordPress
    9 contributions

    Ouuuups ! Merci….

    J’ai rajouté la ligne dans WP Config PHP. J’ai bien le fichier fr_FR.mo dans WP-content/languages.

    Mais rien ne change… pour le moment. (screenshot de l’opération)

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2339993
    Li-An
    Modérateur
    Maître WordPress
    23693 contributions

    Bon, je sèche là. Je vais consulter.

    #2340017
    sebastienserre
    Gestionnaire du forum
    Maître WordPress
    815 contributions

    Bonjour,

    La constante WPLANG est dépréciée depuis des années, elle n’a plus aucune action sur WordPress.

    S’agissant d’un thème les fichiers po/mo doivent être placé dans wp-content/languages/themes/

    Si ca ne fonctionne pas, c’est qu’il y a un soucis au niveau du theme certainement…

    #2340047
    Li-An
    Modérateur
    Maître WordPress
    23693 contributions

    @sebastienserre : je me posais justement la question. Voilà ce que c’est que d’avoir une vieille installation de WP 🙂

    #2340455
    AXIOME
    Participant
    Initié WordPress
    9 contributions

    Bonjour,

    Les fichiers PO/MO se trouvaient dans wp-content > languages > loco > themes.

    Je les ai donc mis dans wp-content > langages > themes, me cela n’a rien changé…

    Il doit donc y avoir un soucis au niveau du thème…. 🙁 Bien dommage car le support ne répond plus.

    Bonne journée et merci pour votre aide.

    Maxime

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.