Toujours une page blanche en installant WP sur OVH (Créer un compte)

  • Statut : non résolu
8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #456698
    andalousa
    Participant
    Initié WordPress
    1 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : la dernière version je pense
    – Thème utilisé : la version de base pour l’instant
    – Plugins en place :
    – Nom de l’hebergeur : ovh-start 1G
    – Adresse du site : http://www.fashionmaispasvictime.com

    Problème(s) rencontré(s) :

    Bonjour à tous,

    Cela va faire plusieurs jours que je tente désespérément d’installer wordpress sur mon hébergement perso.

    J’ai suivi tous les tutos glanés sur Internet en français et même en anglais, suivi les conseils de ce forum et j’obtiens toujours une page blanche.
    J’ai même utilisé à plusieurs reprises l’installation du module WP proposé par OVH et j’ai toujours cette fameuse page blanche.
    En dernier recours j’ai utilisé les services d’install4free suggéré sur le site de WP. Même eux n’y arrive pas.

    Il est vrai que je n’arrête pas d’installer, d’effacer de réinstaller. J’ai peut-être fait une bêtise. :rolleyes:😗:boulet:

    J’ai donc bien mes codes FTP pour l’utilisation de FileZilla, mes données MySQL à insérer dans mon fichier wp-config.php. (j’utilise toujours le copier/coller pour utiliser les données afin d’éviter des erreurs de frappe).

    Voici mes données sur mon fichier wp-config.php :
    // ** reglages MySQL ** //
    define(‘DB_NAME’, ‘fashionmwpdb’); // Le nom de la base de donnees
    define(‘DB_USER’, ‘fashionmwpdb’); // Votre identifiant MySQL
    define(‘DB_PASSWORD’, ‘*******’); // …et votre mot de passe
    define(‘DB_HOST’, ‘ mysql5-5’); // Dans la plupart des cas, vous n’aurez pas a modifier cette ligne
    define(‘DB_CHARSET’, ‘utf8’);
    define(‘DB_COLLATE’, ”);

    // Vous pouvez faire plusieurs installation sur une meme base de donnees en leur donnant un prefixe unique
    $table_prefix = ‘wpi4f_’; // Que des chiffres, lettres ou soulignes, s’il vous plait !

    // Modifiez la ligne suivante pour traduire WordPress. Il faut que le dossier
    // wp-includes/languages contienne une fichier .mo correspondant a la langue choisir.
    // Par exemple, installez de.me dans wp-includes/languages et preciser ‘de’ a WPLANG
    // pour mettre en place la traduction allemande.
    define (‘WPLANG’, ‘fr_FR’);

    /* C’est tout, ne touchez pas au reste ! Bloguez bien ! */

    define(‘ABSPATH’, dirname(__FILE__).’/’);
    require_once(ABSPATH.’wp-settings.php’);
    ?>

    Dans la fenêtre “site distant” de FileZilla j’ai trois dossiers :
    1- un dossier avec deux point (..)
    2- un dossier nommé “requetes” avec des choses bizzares dedans.
    3- un dossier “www”

    Dans le fameux dossier “www” on y trouve un dossier “wordpress” et un fichier test d’install4free nommé “hi.php” qui est censé faire apparaître “hello, world” lorsque je me connecte sur ma page http://www.fashionmaispasvictime.com”.

    Voilà, je tourne en rond est le plus simple est de vous demander de m’aider.
    Il y a sûrement une subtilité que je n’arrive pas à cerner et qui doit être évidente pour les initiés que vous êtes.

    Je vous remercie par avance pour vos réponses et toute l’aide que vous pourrez m’apporter.

    #619460
    arena
    Participant
    Maître WordPress
    844 contributions

    http://www.fashionmaispasvictime.com/index.php donne un résultat interessant !

    difficile de faire un diagnostic sans accès à ton ftp …

    #619461
    buzz
    Participant
    Padawan WordPress
    60 contributions

    Question bête mais comme tu ne le mentionnes pas : as tu créé ta base de données dans le manager d’OVH ? as tu effacé les anciens enregistrements qui s’y trouvaient via phpmyadmin ?

    #619462
    arena
    Participant
    Maître WordPress
    844 contributions

    dans mon type d’abonnement, la base de données était déjà créé.

    visiblement, l’adresse de ton site ne pointe pas sur wordpress, car si tu avais un problème de connexion à ta base de données tu aurais un message d’erreur wordpress.

    #619463
    ploums
    Membre
    Initié WordPress
    23 contributions

    Pas sûr de moi, mais si ton WordPress est installé dans un sous-répertoire de www, il faut d’abord que quand tu te connectes à http://www.fashionmaispasvictime.com/index.php il fasse passer directement dans WordPress.

    En matière de ré-installation, j’installerais WordPress à la racine (dans www, pas dans www/wordpress).

    Sinon, même si tu restes dans www/wordpress, il faudrait comprendre pourquoi aucun des php de otn site ne semble tourner : ./hi.php reste bloqué pour moi, ./index.php aussi. Il faut d’abord voir (peut-être avec OVH) pourquoi rien ne me semble marcher. Pas un problème WP, mais un problème OVH ?

    #619464
    Mireldar
    Membre
    Chevalier WordPress
    118 contributions

    – vide ta base de données

    – Change cette ligne define(‘DB_HOST’, ‘mysql5-5’) pour define(‘DB_HOST’, ‘localhost’)

    #619465
    monsieur_m
    Membre
    Initié WordPress
    1 contributions

    j’ai exactement le même problème… suaf que moi wordpress affiche la page d’erreur…

    #619466
    zebluesman
    Membre
    Maître WordPress
    546 contributions
    Mîreldar wrote:
    – vide ta base de données

    – Change cette ligne define(‘DB_HOST’, ‘mysql5-5’) pour define(‘DB_HOST’, ‘localhost’)

    non du tout il faut mettre l’identifiant sql fournit par ovh
    …..

    je suis sur ovh en avec un wordpress avec le même type d’hébergement : ovh-start 1G

    en effet supprime ta base de données par l’intermediaire de l’admin ovh

    tu en recrée une nouvelle

    tu modifie le config.php :

    IMPORTANT / sur la version 2.3.2 config.php s’appelle “wp-config-sample.phpIL FAUT CHANGER LE NOM PAR wp-config.php

    ensuite tu installe le contenus de wordpress (je dis bien le contenus du dossier) et tu le tranfert par ftp dans le repertoire “www”

    depuis ton navigateur tu entre l’adresse suivante : http://www.tondomaine.com/wp-admin/install.php (ceci est une adresse exemple)

    et tu laisse faire les choses.
    normalement cela ne devrait plus poser de problème.

    Bon courage

8 sujets de 1 à 8 (sur un total de 8)
  • Vous devez être connecté pour répondre à ce sujet.