[Topic unique] Polyglot: plugin de traduction en dur pour wordpress (Créer un compte)

  • Statut : non résolu
15 sujets de 46 à 60 (sur un total de 296)
  • Auteur
    Messages
  • #579954
    jaiunblog
    Participant
    Padawan WordPress
    64 contributions

    j’ai une piste 🙂 le .mo ne traduit pas toutes les dates… enfin il y a un conflit :fouet:

    dans le po

    msgid “l, F dS, Y g:i a”
    msgstr “l j F Y G:i”

    dans le template

    dans le plugin polyglot.php je desactive le date format 🙂

    // $polyglot_settings[‘date_format’][‘en’] = ‘Y-m-d’;
    // $polyglot_settings[‘date_format’][‘fr’] = ‘j F Y’;

    ✅😗

    @ jean marc : à priori ton problème de titre catégorie peut être réglé par du .po .mo mais ce n’est pas très propre ¿

    #579955
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Merci de ta proposition de traduction de catégories par .mo, mais comme ce n’est pas moi qui met ce site à jour, ce n’est pas une option que je peux retenir. Personnellement je n’ai fait que produire le site, je ne l’alimente pas.
    Pour ce qui est du site de l’auteur du plugin, j’y ai laissé plusieurs messages, mais je n’y ai jamais eu de réponse concluante.

    Enfin pour les traductions des dates, je n’ai eu aucun problème et je n’ai rien changé dans le plugin à ce niveau. Je ne sais pas pourquoi ça ne fonctionne pas chez toi, bien que je remarque que tu n’as pas mis le nom de ton thème dans ton the_time, ce qui fait qu’il ne va pas chercher la traduction dans ton .po de thème. Le problème serait là ?

    #579956
    jaiunblog
    Participant
    Padawan WordPress
    64 contributions

    Mettre le nom du thème ? je n’ai pas de .mo dans le thème, il prend celui par défaut…

    #579957
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Ce qui compte c’est que ça fonctionne, et vu l’icone que tu as mis à la fin du post #46, ça semble être résolu.

    #579958
    jaiunblog
    Participant
    Padawan WordPress
    64 contributions

    :fouet: je suis curieux 😉 ce qui compte aussi c’est de comprendre comment ça marche 🙂

    #579959
    Laurelyn
    Membre
    Initié WordPress
    30 contributions

    Bonjour,

    J’ai quelques soucis avec ce plugin:

    Depuis que je l’ai installé, mon footer s’est décalé…au lieu d’etre en bas et centré il est en bas et à droite…
    Alors que je n’ai pas touché la feuille de style, les seules choses que j’ai changé sont:
    – le .php de polyglot
    – le local.php pour la date
    – la langue de base de wp pour que la date change bien de format
    – le code de la side bar pour avoir les drapeaux

    Et dans la feuille de style je crois que rien n’a changé :

    #footer {
      background: #424942 url(‘images/foot.jpg’) no-repeat center top; 
      border: none;
    }

    Comment arranger cela ?

    Ensuite, autre petit souci, je voudrais traduire le blog en francais et anglais, et dans le premier message tu dis qu’il faut prendre le fichier : fr_FR.po
    => Je le trouve où ? Dans le dossier langage je n’ai qu’un fr_FR.mo que je ne peux pas ouvrir.
    Alors j’ai enregistré celui que tu donnais dans ton lien et là mon souci c’est que poEdit refuse de l’ouvrir il me fait une erreur :

    Failed to convert file contents to unicode

    Je me suis dis que c’était a cause des codes qui remplacaient les accents, donc j’ai remis tous les accents comme il falait, mais ca me fait toujours la meme erreur….
    Que dois-je faire ?

    Merci pour votre aide

    #579960
    Laurelyn
    Membre
    Initié WordPress
    30 contributions

    Ah et aussi un autre souci, quand je suis sur la page d’accueil et que je clique sur les drapeaux ca me fait une erreur.
    Alors qu’ils fonctionnent parfaitement bien sur n’importe quelle autre page du blog

    #579961
    jaiunblog
    Participant
    Padawan WordPress
    64 contributions

    Salut,

    Sans avoir un lien vers ton blog, c’est un peu difficile de t’aider, il faut voir ton code html, une balise mal fermée ? as-tu le même problème avec un autre thème ?

    #579962
    Laurelyn
    Membre
    Initié WordPress
    30 contributions

    Salut, merci de ta réponse

    Voila le blog : http://mantis.folio.free.fr/

    En fait il était quasiment fini si ce n’est un tit problème d’affichage dans les galeries, mais depuis que j’ai mis Poliglot, j’ai vu que mon footer s’était déplacé.
    pourtant je ne pense pas avoir touché quelque chose le concernant.

    #579963
    jaiunblog
    Participant
    Padawan WordPress
    64 contributions

    ton footer est dans la div sidebar,
    dans footer.php il doit manquer

    avant

    #579964
    Laurelyn
    Membre
    Initié WordPress
    30 contributions

    Je suis une vrai newb dsl, je ne connais rien du tout en php, excuse moi 😕

    Merci ca a fonctionné :D
    c’etait vraiment tout con en plus…parfois j’ai honte 😗

    Si je peux continuer, vu que le ridicule ne tue pas je peux te demander a quoi sert le gettext et où je dois mettre ce qu’il y a dedans ?
    Je crois avoir compris que c’etait les php modifiés de facon a afficher les traductions de mon fr_FR.mo mais je ne suis pas très sure de ma compréhension.

    #579965
    Laurelyn
    Membre
    Initié WordPress
    30 contributions

    Bon j’ai résolu quelques uns de mes problèmes, donc en fait, le seul souci qui me reste concerne la traduction de certaines petites choses comme “Search” ou le “You are currently browsing the archives for the ‘Général’ category.

    J’ai les traduction qu’il faut dans fr_FR.mo mais elles ne sont pas prises en compte.
    Je ne sais pas comment changer le php pour qu’il aille chercher les traductions quand il le faut. Si quelqu’un sait :D

    #579966
    jaiunblog
    Participant
    Padawan WordPress
    64 contributions

    oui il faut utiliser la doc ^^ que je vais voir…

    #579967
    jaiunblog
    Participant
    Padawan WordPress
    64 contributions

    Quand vous avez cette fonction de ce type:

    rajouter __(‘ devant.

    voilà c’était au début de ce thread ^^

    #579968
    Laurelyn
    Membre
    Initié WordPress
    30 contributions

    Merci,
    Mais pour moi je crois que ca ne fonctionne pas vraiment :

    ns la balise , dans des balise ‘value’ (value=””), dans des balises javascript (ça fonctionne pour mon header), dans les attributs de la balise <a> genre <a href="” title=””>, mais pas dans du php qui utilise echo()</a>

    Mon theme (mandigo-14) est en echo je crois, regarde le genre de code que je trouve :

    <li><p>You are currently browsing the <a href="/”></a> weblog 
    			archives.</p></li>

    Je fais comment dans ses cas là ?

15 sujets de 46 à 60 (sur un total de 296)
  • Vous devez être connecté pour répondre à ce sujet.