Thème enfant-Difference avec Thème Parent sur menu header responsive

  • WordPress :5.2
  • Statut : non résolu
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #2274655
    mikaelB
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    J’ai tenté de trouver une réponse sur le site mais n’y suis pas parvenu.

    J’ai commencé à créer un petit site avec wordpress, et j’ai choisi le thème BULK, https://fr.wordpress.org/themes/bulk/

    qui me satisfaisait. Suite à mes différentes lectures, j’ai compris qu’il valait mieux créer un thème enfant pour éviter tout soucis au moment des mises à jour. J’ai donc créer en suivant un tutoriel un thème enfant que j’ai activé. Tout à l’air de fonctionner bien, mais je me suis aperçu d’une petite différence entre le thème parent et le thème enfant et je ne comprends pas pourquoi il y a cette différence et si je peux y remédier.

    Le site a une en-tête avec un menu avec pour l’instant 3 “instances” de menu qui appelle 3 pages. En mode “ordinateur”, cela à l’air identique, mais quand je passe en affichage mobile, le menu devient une icône de hamburger et si je l’active, apparait sur la gauche de l’écran les 3 “instances”. Cela fonctionne de la même manière, sauf que le texte du menu qui apparait est légèrement tronqué dans le thème enfant, mais pas dans le thème parent.

    Je n’ai pas accès à un paramètre de marge quelconque, et je ne peux donc pas “jouer” sur celle-ci, mais pourquoi le thème enfant serait-il différent ?

    faudrait-il que j’efface ce menu, pour le refaire dans le thème enfant ? En effet, depuis l’installation du thème enfant, je n’ai rien changé sur la personnalisation du thème et ce type de menu qui couvre tout le site est paramétré dans la personnalisation du thème, a été effectué sur le thème parent, car je ne connaissais pas l’existence et la pertinence de créer un thème enfant.

    Ou alors, simplement affecter à ce menu dans le thème enfant une marge ?

    Si quelqu’un peut m’offrir ses lumières, j’en serai reconnaissant.

     

    Ma configuration WP actuelle

    • Version de PHP/MySQL : A jour
    • Thème utilisé : BULK
    • Extensions en place : ELEMENTOR
    • Nom de l’hébergeur : Perso
    • Adresse du site :
    #2275094
    Flobogo
    Modérateur
    Maître WordPress
    15773 contributions

    Bonjour,

    Problème curieux, peut-être lié à une interaction avec Elementor. Désactivez cette extension (ou même toutes vos extensions) pour voir si le problème vient de là.

    #2275380
    mikaelB
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    Merci de votre réponse. Le problème doit effectivement venir d’Elementor. Mais si je la désactive, le thème perd toute sa mise en place.

    J’en suis donc à essayer de faire une en-tête qui me plaise pour remplacer celle du thème choisi, car c’est sur l’en-tête qu’il y a des différences notables.

    Même si je désire faire quelque chose de simple, il y a toujours des complications qui apparaissent. Cela fera l’objet d’un autre fil si je  ne trouve pas de solution.

    #2275398
    Flobogo
    Modérateur
    Maître WordPress
    15773 contributions

    Le problème doit effectivement venir d’Elementor. Mais si je la désactive, le thème perd toute sa mise en place.

    Ce serait quand même intéressant à vérifier. Et vous pourriez éventuellement soumettre le problème au support d’Elementor, plus à même de vous aider si c’est bien un conflit avec leur extension.

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.