The theme editor is disabled

  • Statut : non résolu
12 sujets de 1 à 12 (sur un total de 12)
  • Auteur
    Messages
  • #448921
    rescator
    Membre
    Initié WordPress
    16 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.0.4 je crois (non je suis sur)
    – Thème utilisé : default
    – Plugins en place :
    – Nom de l’hebergeur : perso

    Problème(s) rencontré(s) : Bonjour, je crois avoir deja tout dis dans le sujet.

    quand j’essaye de modifier un theme, voila le message que je recois “The theme editor is disabled”
    et je n’ai rien trouvé pour activer cette fonction..

    QQ aurait une idée ??

    Grand merci d’avance

    #581923
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Ton dossier Wp-content/themes est CHMOD 0777 ?

    #581924
    rescator
    Membre
    Initié WordPress
    16 contributions

    je viens de vérifier, oui il est bien en 777

    #581925
    chsxf
    Participant
    Chevalier WordPress
    129 contributions

    La chaîne “The theme editor is disabled” est introuvable dans le code source de WP 2.0.4 anglais.
    Tu n’as vraiment aucun plusin installé et quel est le thème de ton site ?

    A quel moment exactement as-tu ce message ?

    #581926
    rescator
    Membre
    Initié WordPress
    16 contributions

    zou, des explications complètes…

    j’utilise en fait wordpress-MU, qui lui utilise wordpress 2.0.4

    le tout devrait me permettre de proposer des blogs pour les qqs visiteurs interessés de mon site (www.web-alsace.net) à la place des blogs dispo par MKPORTAL qui propulse mon site.

    Le seul plugin installé est WYSI-Wordpress, mais le problème ne vient pas de là, puisque l’edition ne fonctionnait déjà pas avant la mise en place de ce plugin.

    pour editer les themes, je n’ai jamais pu trouver le lien, et je lance directement le fichier theme-editor.php

    pout faire des test : http://blog.rescator.org/rescator

    http://blog.rescator.org/wp-admin/theme-editor.php et c’est là qu’on obtient le message cité plus haut

    login : rescator passe : 123456 pour les tests

    Je suis entrain de faire la traduction COMPLETE. je vous l’enverais quand elle sera terminée

    Il faudrait qu’un admin déplace ce sujet dans wordpress MU…. j’me suis gouré de forum…. NON pas de baffes

    #581927
    chsxf
    Participant
    Chevalier WordPress
    129 contributions

    Ah ok, WordPressMU c’est pas le même bazar que WordPress…
    Je ne l’ai jamais utilisé donc je ne te serai pas d’une grande aide, mais je suppose que l’éditeur de thème doit être désactivé via une option de WPMU

    #581928
    rescator
    Membre
    Initié WordPress
    16 contributions

    vi. j’ai vu un peu tard qu’il y avait une section MU… la buse du dimanche à frappé.

    #581929
    AmO
    Participant
    Maître WordPress
    4452 contributions

    En effet ^^

    #581930
    quentin
    Membre
    Chevalier WordPress
    315 contributions

    L ‘éditeur de themes est désactivé dans mu (c’est pour ca que tu n’as pas trouvé le lien…). Bien trop dangereux de laisser les utilisateurs changer leur thème.
    Si tu veux changer tes thèmes -> FTP.

    #581931
    rescator
    Membre
    Initié WordPress
    16 contributions

    Merci quentin, j’arrête donc de chercher midi à 14 heures.

    Dans mon MP je te parlais de l’écriture en couleur des messages. tu me dis qu’il faut modifier une option dans le fichier tiny_mce_gzip.php ….. aurais-tu l’amabilité de me dire quelle option… je n’ai rien trouvé (je suis assez débutant en PHP) ?

    encore merci aux personnes qui se sont donné la peine de me répondre

    #581932
    quentin
    Membre
    Chevalier WordPress
    315 contributions

    Dans la version de mu que j’utilise qui date d’avril (donc ca peut avoir changé…) il suffit, autour de la ligne 110, de rajouter les options nécessaires. Tu peux dispatcher les boutons sur plusieurs lignes.
    Pour unblog car essemble à ca:

    $mce_buttons = apply_filters(‘mce_buttons’, array(‘bold’, ‘italic’, ‘strikethrough’, ‘underline’,’separator’, ‘bullist’, ‘numlist’, ‘outdent’, ‘indent’, ‘separator’, ‘link’, ‘unlink’, ‘image’, ‘wordpress’, ‘separator’, ‘undo’, ‘redo’, ‘code’, ‘wphelp’));
    	$mce_buttons = implode($mce_buttons, ‘,’);
    	$mce_buttons_2 = apply_filters(‘mce_buttons_2’, array(‘justifyleft’, ‘justifycenter’, ‘justifyright’, ‘justifyfull’ ,’separator’,’fontselect’, ‘fontsizeselect’,’forecolor’, ‘charmap’, ‘cleanup’));
    	$mce_buttons_2 = implode($mce_buttons_2, ‘,’);
    	$mce_buttons_3 = apply_filters(‘mce_buttons_3’, array());
    	$mce_buttons_3 = implode($mce_buttons_3, ‘,’);

    Je crois que c’est tout ce qui a besoin d’etre changé.

    #581933
    rescator
    Membre
    Initié WordPress
    16 contributions

    vi ok. je commencec à comprendre un peu mieux. en fait c’est dans le fichier “tiny_mce_config.php” dans ma version et pas dans tiny_mce_gzip.php”

    hopla (comme on dit par chez nous) je vais essayer cela

12 sujets de 1 à 12 (sur un total de 12)
  • Vous devez être connecté pour répondre à ce sujet.