texte d’erreur en entête de page

  • WordPress :4.9.4
  • Statut : non résolu
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #2137365
    cielartisan
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    Ma configuration WP actuelle :

    – Version de WordPress : 4.9.5
    – Version de PHP/MySQL : 7.2.4-1+0~20180405085552.20+jessie~1.gbpbff9f0 / 5.5.59
    – Thème utilisé : Hestia
    – Thème URI : https://themeisle.com/themes/hestia/
    – Extensions en place : Akismet Anti-Spam (4.0.3), Beaver Builder Plugin (Lite Version) (2.0.6.4), Flickr Album And Photostream Gallery (0.0.16), Flickr Album Gallery (1.7.0), Forum_wordpress_fr (4.1), Free & Simple Contact Form Plugin – Pirateforms (2.4.0), Image Watermark (1.6.4), Jetpack by WordPress.com (6.0), Orbit Fox Companion (2.4.6), UpdraftPlus – Backup/Restore (1.14.5), WP-Optimize (2.2.3)
    – Adresse du site : http://cielartisan.org
    – Nom de l’hébergeur : Apache

    Problème(s) rencontré(s) :

    sur certaines pages

    Histoire de la compagnie

    Équipe

    ce texte d’erreur apparait

    Warning: count(): Parameter must be an array or an object that implements Countable in /var/www/legtux.org/users/cielartisan/www/wp-includes/post-template.php on line 284

    je suis allé en ftp à ce fichier, les lignes correspondantes sont

    if ( $page > count( $pages ) ) // if the requested page doesn’t exist
    $page = count( $pages ); // give them the highest numbered page that DOES exist

    Je ne sais pas ce qui peut être fait pour corriger cette erreur et qu’elle n’apparaisse plus sur le site…

    redites moi si vous avez besoin de plus d’information…

    merci de votre aide

     

    #2137547
    Li-An
    Modérateur
    Maître WordPress
    22703 contributions

    Bonjour, passez à php 7.1+ pour voir si l’erreur persiste. Sinon, désactivez les extensions, mettez un thème par défaut et testez pour voir.

    #2140055
    hocus35
    Participant
    Initié WordPress
    26 contributions

    hello,

    désactives  ça: WP Admin → Jetpack → Settings → Sharing → Sharing buttons → Add sharing buttons to your post

    source : https://github.com/Automattic/jetpack/issues/8420

    • Cette réponse a été modifiée le il y a 1 année et 6 mois par  hocus35.
    • Cette réponse a été modifiée le il y a 1 année et 6 mois par  hocus35.
    #2140107
    cielartisan
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    j’ai vu que la version php est de 7.2 donc ce n’était pas ça. j’ai désactivé les extention et testées une par une et c’est bien Jetpack qui posait soucis. Je peux tout de même l’utiliser mais en désactivant l’option.

    Merci beaucoup!

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.