tentative de Traduction = erreur 404 (Créer un compte)

  • Statut : non résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #453390
    fabprod
    Participant
    Initié WordPress
    44 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.2
    – Thème utilisé : cutline-3-column-split-11
    – Plugins en place :
    Askimet
    Global translator
    Google site map
    Random post widget
    Tag cloud widget for UTW
    UTW
    WP contactform
    WP navigation tool (navt)

    – Nom de l’hebergeur : BLuehost
    – Adresse du site : http://www.antik-collections.com

    Problème(s) rencontré(s) :

    Voilà, je voudrais que mon site soit lisible en plusieurs langues, et qu’il soit traduit automatiquement.
    J’ai donc essayé d’installer un plug in qui s’appelle translator, mais ça ne marchait pas. J’ai installé le plug “Global translator”, et ça ne marche toujours pas. J’ai bien des petits drapeaux, mais quand je clique dessus, ça me met une erreur 404.

    Je me demande : est-ce que c parceque j’ai déjà essayé d’intaller un autre plug avant (même s’il est désactivé bien sur)
    Ou bien : est-ce que c’est parceque le thème est en anglais et que les articles sont en français, et que donc le global translator ne sait plus quoi faire ?

    Ou bien : y-a-t-il un autre bug quelque part ?

    J’ai un deuxième problème, ne seraient-ils pas liés ? : le thème me met en haut de page trois liens automatiquement (HOME, ABOUT, ARCHIVES), mais seul le lien HOME fonctionne. LEs autres font aussi des 404…

    Hé ben avec tout ça. SI quelqu’un pouvait m’aider ce serait chouette.

    Sinon j’ai découvert le plug in WP navigation tool (navt), et il est vraiment génial. Mais peut-être que tout le monde le sait déjà.😐

    #606684
    fabprod
    Participant
    Initié WordPress
    44 contributions

    Ben alors personne n’a une petite idée ?:o:o

    #606685
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Met à jour tes permaliens ! (depuis la console WP)

    #606686
    fabprod
    Participant
    Initié WordPress
    44 contributions

    Merci AMo
    J’ai mis à jour les permaliens, c’est mieux mais j’ai encore un prb. Dès que je change de catégorie, ou si je pase d’une page à une catégorie, etc. il faut recliquer sur le drapeau pour la traduction, sinon ça reste en français.

    J’ai essayé de mettre différentes structures de permaliens, mais c’est à peu près le même probleme. Je n’ai pas personalisé car je ne sais pas faire ça.

    Aussi, j’ai testé, selon les preférences de global translator, de traduire avec ALta vista ou Google, il y a moins de problèmes avec google, mais suelement deux langues disponibles. (ALta vista en propose beaucou plus, mais avec des fautes énormes!!!)

    Tu connais une solutions ? Tu veux voir mon code ou quelques chose comme ça ?
    Merci encore

    #606687
    fabprod
    Participant
    Initié WordPress
    44 contributions

    et par contre, ça change rien à mes trois liens en haut qui mènent sur des 404…

    #606688
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Le problème vient de tes différentes adresses

    Pourquoi tu as ?

    http://www.antik-collections.com/
    http://69.89.31.74/~youareco/archives/

    #606689
    fabprod
    Participant
    Initié WordPress
    44 contributions

    dsl AMo j’éta

    #606690
    fabprod
    Participant
    Initié WordPress
    44 contributions

    hum…je reprends,

    dsl AMo, j’étais parti quelques jours. ALors pourquoi j’ai deux adresses comme ça, ça c’est une bonne question.
    L’adresse http://www.antik-collections.com a été crée après (direct par blue host qui l’a fait pour moi). Ma première adresse était youareconnected.com, et mon adresse IP 69.89.31.74.
    C’est y un truc bizarre : j’ai installé WP dans mon dossier antik-collection, qui est dans le dossier www de mon serveur, mais par exemple, je dois instaler mes plug ins dans le dossier www/wp-content, et non dans www/antik-collections/wp content, sinon ils ne sont pas pris en compte…
    J’y comprends rien.
    Tu veux regarder de plus près ? COmment pourrais-t- on- faire ?:boulet:

    #606691
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Dans les options générales de WP, met : http://www.antik-collections.com

    #606692
    fabprod
    Participant
    Initié WordPress
    44 contributions

    Ok j’ai changé dans les options…j’ai changé les adresses dans “adresse de wordpress url”, et “adresse du blog url”, ais-je bien fait ?
    C’est clair que ce sera surement plus propre, mais mes petits problèmes ne sont toujours pas résolus.

    -Les onglets “archives” et “About” = error 404 (mais je n’ai pas de page “about” je crois, et j’ai essayé d’écrire un page qui s’appelle about mais ça change rien)

    -Les drapeaux n’apparaissent pas quand on arrive sur le site, mais seulement après avoir cliqué sur une page ou un article

    -Et il ne reste pas sur la même langue, il faut toujours recliquer sur les drapeaux pour retraduite chaque page…

    C peut-être un problème de plug in ? j’ai du rajouter ce code dans ma sidebar :

    <?php
    if(function_exists(“gltr_build_flags_bar”)) { gltr_build_flags_bar(); }
    ?>

    (voici le début du code de la sidebar :

<img src="/images/header_1.jpg” width=”970″ height=”140″ alt=” header image 1″ title=” header image 1″ />

<img src="/images/header_2.jpg” width=”970″ height=”140″ alt=” header image 2″ title=” header image 2″ />

<img src="/images/header_3.jpg” width=”970″ height=”140″ alt=” header image 3″ title=” header image 3″ />

<img src="/images/header_4.jpg” width=”970″ height=”140″ alt=” header image 4″ title=” header image 4″ />

<img src="/images/header_5.jpg” width=”970″ height=”140″ alt=” header image 5″ title=” header image 5″ />

Merci pour tout ! C’est des petits trucs mais c’est énervant…:o

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.