Telechargement 3.1 Fr encore possible ?

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 16)
  • Auteur
    Messages
  • #498260
    Teletong
    Membre
    Initié WordPress
    12 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.0.1
    – Version de PHP/MySQL : 5.2.6-1+lenny13 / 5.0.51a-24+lenny5
    – Thème utilisé : contrast-style
    – Extensions en place : highslide 4 wp, nextgen gallery, tinymce, …
    – Nom de l’hebergeur :
    – Adresse du site : http://www.teletong.fr

    Problème(s) rencontré(s) :

    Bonjour,
    Pour des raisons de compatibilité avec mes extensions, je souhaiterais installer la version 3.1 de WordPress (3.0.1 actuellement). Or, je ne trouve que la 3.1.4 sur la page http://fr.wordpress.org/releases/.
    Donc ma question est sans doute bête, mais est-ce que je peux encore trouver la 3.1 “fr” quelque part ? (sinon je me rabattrai sur la 3.1 english que j’ai réussi à trouver).
    Merci d’avance pour votre aide, et encore désolé si la question est triviale.
    Bonne journée !

    #786205
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    En même temps la 3.1.4 est la dernière version de la branche 3.1 donc normalement tes extensions doivent supporter aussi bien 3.1 que 3.1.4… Quelles sont ces extensions qui te contraignent à ne pas mettre à jour au delà ?

    #786206
    Teletong
    Membre
    Initié WordPress
    12 contributions

    Beaucoup de mes extensions n’ont pas assez de données quant au test de compatibilité entre version WordPress et version Extension. Il y a beaucoup de 0-0 avec la 3.1.4…

    Dans le détail, mes extensions sont les suivantes :

    Importantes pour le site :
    http://wordpress.org/extend/plugins/nextgen-gallery/ (1.7.2)
    http://wordpress.org/extend/plugins/highslide-4-wordpress-reloaded/ (1.20)
    http://wordpress.org/extend/plugins/akismet/ (wp 3.1.4 est la seule version qui a 0-0…)
    http://wordpress.org/extend/plugins/exec-php/
    Un peu moins importantes
    http://wordpress.org/extend/plugins/wp-paginate/
    http://wordpress.org/extend/plugins/wp-polls/
    http://wordpress.org/extend/plugins/tinymce-advanced/ (3.4.2. Mais ne fonctionne plus tant que je reste en dessous de WP 3.1)
    “Optionnelles”
    http://wordpress.org/extend/plugins/google-sitemap-generator/ (3.2.4)
    http://wordpress.org/extend/plugins/power-code-editor/

    Et si jamais l’une d’elle ne fonctionnait pas en 3.1.4, je n’aur

    #786207
    luciole135
    Participant
    Maître WordPress
    13753 contributions
    #786208
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    luciole > c’est pour les traductions ça.

    Teletong > N’aie aucune crainte, si ca passe en 3.1, ca passera en 3.1.4. Ca reste la même branche, il s’agit de mise à jour mineure.
    Et si tu ne te fie qu’à la compatibilité affichée sur Extend tu ne te mettra jamais à jour 😉

    #786209
    Teletong
    Membre
    Initié WordPress
    12 contributions

    Bonjour,

    Merci pour cette réponse concernant la (non-)différence 3.1 / 3.1.4.
    C’est vrai que mes grilles de compatibilités ne sont pas alarmantes concernant mes extensions avec la 3.1.4, alors je vais sans doute tenter le coup. (par curiosité, pourquoi ne faut-il pas se “fier” aux compatibilités annoncées ?)

    Cette mise à jour est souhaitée “transparente”. Je ne cherche pas spécialement les nouveautés de l’interface admin ou la correction de certains bugs. Il s’agit juste de rester à peu près à jour en faisant un upgrade de temps en temps. Mais ce que je veux éviter, ce sont d’éventuelles régressions, car je n’ai -malheureusement- pas autant de temps que je voudrais à accorder au site…
    Les retours arrières sont-ils complexes en cas de souci après une mise à jour WP ?

    En tout cas je reviendrai sans doute clore cette discussion après le passage en 3.1.4, en espérant que tout se passe bien (mais je suis de nature optimiste : si un Jedi WP me dit que ça passe, j’ai toute confiance 😉)
    Merci !

    #786210
    Lumiere de Lune
    Participant
    Maître WordPress
    19385 contributions

    POur les retours en arrière il n’y a qu’une méthode simple : recharger les sauvegardes

    #786211
    Li-An
    Modérateur
    Maître WordPress
    22361 contributions

    Il y a un truc que je ne comprends pas: les plugins importants cités sont compatibles WP 3.2.1. Pourquoi ne pas mettre complètement à jour ?

    #786212
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    Vous n’êtes pas un jedi, je doute qu’il vous réponde…

    #786213
    Teletong
    Membre
    Initié WordPress
    12 contributions

    Non, non, je prends tous les avis ! 🙂
    Quant à la compatibilité des extensions avec la 3.2.1, je vois quand même beaucoup de 0-0 et de “jaune”…A moins qu’on puisse voir la compatibilité ailleurs ?

    #786214
    Hervel
    Participant
    Maître WordPress
    30119 contributions

    bonjour,
    mais ça,c’est seulement si les gens prennent le temps d’indiquer compatible ou pas avec la dernière version actuelle.

    #786215
    natchoum
    Membre
    Chevalier WordPress
    162 contributions

    de mon point de vue pour voir si c’est bien compatible, tu fais un back up et tu testes. si ça foire, tu n’a plus qu’a recharger le back up :D Je trouve ça mieux que de me fier à un site qui malheureusement n’est pas toujours à jour.

    #786204
    Teletong
    Membre
    Initié WordPress
    12 contributions

    Bonjour,

    Je reviens sur cette discussion pour signaler que comme je le craignais, j’ai quelques messages d’erreur et de compatibilité suite à la migration.

    Highslide 4 WordPress *reloaded* compatibility Warning!
    You are using NextGen Galley with enabled JS Image effects. With this settings Highslide won`t work in your site. Please go to the NextGEN Config dialogue and set JavaScript Thumbnail Effect to none.

    Alors pour le moment je ne tiens pas compte de cet avertissement, pour la simple raison que ça semble fonctionner comme avant : si on clique sur une image, elle s’agrandit comme ça l’a toujours fait, et si je mets Effect = “None” comme il me dit, l’image s’affiche seule dans le navigateur…
    Ca semble donc être un problème de compatibilité, mais tant pis, puisque concrètement ça marche.

    Warning: Cannot modify header information – headers already sent by (output started at /home/gbonnet/www/teletong.fr/www/wp-content/plugins/highslide-4-wordpress-reloaded/functions.hs4wp.php:541) in /home/gbonnet/www/teletong.fr/www/wp-includes/pluggable.php on line 897

    J’ai trouvé quelques pistes pour réparer cette erreur, notamment chercher d’éventuels espaces avant des ”, je regarderai ce que je trouve…
    C’est un peu plus bloquant car cela semble gêner pas mal d’action, notamment l’édition par l’interface admin, la purge des spams détectés par Akismet, etc.

    Bref, cette migration est transparente côté visiteur, c’est déjà ça, mais pas côté Admin…

    Merci encore pour vos conseils, je chercherai/ouvrirai des discussions appropriées pour régler mes nouveaux soucis.

    Bonne journée ! 🙂

    #786216
    Hervel
    Participant
    Maître WordPress
    30119 contributions

    bonsoir,

    Vous avez fait une mise manuelle ou automatique ?
    NextGen Gallery fonctionne avec WP 3.2.1
    votre plugin est à jour ?

    vous avez créé le fichier wp-config.php lors de l’installation de WordPress Si oui,est-il bien enregistré sous le format UTF-8 sans BOM ?

    Highslide 4 WordPress *reloaded* c’est comme lightbox ou slimbox ?

    #786217
    Teletong
    Membre
    Initié WordPress
    12 contributions

    Bonjour,

    C’était une mise à jour manuelle de la 3.0.1 vers la 3.1.4.
    NextGen Gallery 1.8.3
    Highslide for WordPress *reloaded* 1.22

    Hier soir j’ai vaguement cherché des espaces dans le fichier wp-config.php et functions.hs4wp.php, mais je n’ai rien vu de louche…je n’ai pas encore checké l’encodage, je regarderai ce soir.

    Le but de Highslide 4 WP reloaded est effectivement d’ouvrir les images dans une “popup”, un peu à la manière de Lightbox ou slimbox (d’après les captures d’écran trouvées…)

    Je n’ai plus aucun message d’erreur en désactivant cette extension, et Akismet a pu faire son boulot de purge des indésirables. Et du coup j’ai -temporairement j’espère- choisi un autre effet pour l’ouverture des images (mais j’aime moins : obligé de cliquer sur le lien “suivant”, pas de possibilité de déplacer l’image sur l’écran, de mettre la taille réelle, fond noir, etc…).
    Merci beaucoup pour la réponse en tout cas !

15 sujets de 1 à 15 (sur un total de 16)
  • Vous devez être connecté pour répondre à ce sujet.