Surcharge serveur énorme !

  • Statut : non résolu
  • Ce sujet contient 12 réponses, 5 participants et a été mis à jour pour la dernière fois par PhiLyon, le il y a 2 années.
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #492701
    Celtic Girl
    Participant
    Initié WordPress
    8 contributions

    Bonjour,

    Ma configuration WP actuelle :
    – Version de WordPress : WordPress 3.1
    – Version de PHP/MySQL : PHP 5
    – Thème utilisé : Un thème de ma composition basé sur twentyten
    – Extensions en place : SEO Smart Links, all in one SEO Pack, Breadcrumbs Navxt, Conbtact Form 7, Easy Fancybox, Exec-PHP, External RSS Reader, Google Maps Embed, Like, WP Super Cache, XML Sitemap Feed.
    – Nom de l’hebergeur : Infomaniak
    – Adresse du site : http://www.guide-irlande.com

    Problème(s) rencontré(s) : Surcharge serveur

    Bonjour à tous,

    J’ai passé mon site sous WordPress fin décembre et l’ai hébergé dans la foulée chez Infomaniak. Mais depuis le passage à la 3.1, Infomaniak a du migrer temporairement mon site sur un dédié pour cause de surcharge hallucinante.

    En gros, tout va bien tant que je me connecte pas à l’interface d’administration. Si j’ai le malheur de m’y connecter, le serveur plonge, et le site ne parvient pas à refonctionner avant une bonne heure… (Page blanche, et navigateur qui mouline ans le vide).

    Croyant que cela venait des plugins, j’ai tout désactivé mais sans résultats… J’ai également retenté une installation de WordPress, mais le résultat est identique…

    Pouvez-vous m’aider, car Infomaniak menace de résilier mon contrat si je ne trouve pas de solution ?

    Au passage, je ne sais pas si c’est intéressant, mais je dispose de plus de 780 pages, et de 200 articles… Est-ce trop lourd pour un serveur ? (J’ai tenté de regarder avec Firebug, mais je n’arrive à rien de concluant).

    Merci à tout ceux qui voudront bien m’aider…

    A bientôt

    Gwen

    #761841
    Lumiere de Lune
    Participant
    Maître WordPress
    19385 contributions

    ton nombre de pages est un peu “surprenant” par rapport au nombre d’articles, mais ça n’a pas d’importance a priori

    Regarde si cela le fait avec le thème standard, et pas un truc de ta composition
    Vérifies aussi la taille de ta base de données, désactives les révisions dans le wp config, et enlève les de la table wp posts

    ton site est extrêmement long à charger même en front end, as tu vraiment activé wp cache ?
    Perso, je pense que tu as du mettre quelque part une boucle qui tourne sans fin

    #761842
    LH
    Membre
    Chevalier WordPress
    372 contributions

    Bonjour,

    Si tu as déjà tenté d’enlever le code des plugins et que tu as aussi réinstallé le code WP, il faut regarder du côté de la base de données MySQL ?
    Est-ce que tu as un accès PhpMyAdmin ?
    Regarde la taille des tables ?

    De toutes façons, il faut aussi que tu fasses une sauvegarde de la BDD au cas où ton hébergeur coupe ton site 😕 Et aussi de tous les fichiers dans le dossier wp-content.

    Ensuite, le plus simple serait de repartir sur une nouvelle installation à vide de ton site pour vérifier que WP et l’hébergement fonctionnent correctement. Si ça marche, c’est que les problèmes doivent venir du thème, des plugins ou de la base de données. Il faut ensuite remettre en place chaque composant un par un pour voir quand le problème survient :(

    Bon courage

    #761843
    Celtic Girl
    Participant
    Initié WordPress
    8 contributions

    Merci pour vos messages rapides.

    @Lumière de Lune : mon site exigeait malheureusement la création de plus de pages que d’articles…
    J’ai en tout cas suivit tes conseils : test avec le thème standard, contrôle de ma base de donnée (qui fait 26Mo), et suppression des révisions sur la base de donnée… Pour WP-Cache, je l’avais effectivement désactivé au moment où j’ai posté mon message…

    @LH : Je n’ai pas manqué de regarder du côté de la base, mais pas évident non plus de trouver le problème du faot de la densité de la base.

    J’ai toutefois réinstallé un WordPress, et installée une sauvegarde sql du site. Résultat : tout tourne, jusqu’à ce que j’arrive sur l’administration, et que je clique sur “Créer une Page”…

    Le problème pourrait-il venir de là ?

    Merci à tous et à toutes pour votre gentillesse…

    #761844
    LH
    Membre
    Chevalier WordPress
    372 contributions

    Pour être sur… Est-ce que tu as effacé tous les plugins (ou carrément tout le dossier /plugins/).
    Pour être bien sur d’avoir désactivé tous les plugins…

    #761845
    Celtic Girl
    Participant
    Initié WordPress
    8 contributions

    Oui oui, je l’ai bien fait. 😉

    C’est à n’y rien comprendre d’ailleurs… Pour résumer ma situation, le site est accessible seulement de par son interface d’administration… Le site en lui même lui, présente des pages blanches, où le navigateur mouline dans le vide…

    #761846
    Lumiere de Lune
    Participant
    Maître WordPress
    19385 contributions
    Celtic Girl wrote:
    @LH : Je n’ai pas manqué de regarder du côté de la base, mais pas évident non plus de trouver le problème du faot de la densité de la base..

    Quelle est la taille de la table wp_posts et la taille de la table wp_options

    Sinon autre possibilité, tu réinstalles un wp “vide”, et tu importes via xml le contenu de ton ancien blog. Il te faudra reparamétrer les options, mais au moins tu auras une base vraiment propre

    #761847
    LH
    Membre
    Chevalier WordPress
    372 contributions
    Celtic Girl wrote:
    Oui oui, je l’ai bien fait. 😉

    C’est à n’y rien comprendre d’ailleurs… Pour résumer ma situation, le site est accessible seulement de par son interface d’administration… Le site en lui même lui, présente des pages blanches, où le navigateur mouline dans le vide…

    Si le plugin wp-super-cache était activé, il faut aussi nettoyer les fichiers de cache et puis pour être clean, le fichier .htaccess aussi.

    #761848
    Celtic Girl
    Participant
    Initié WordPress
    8 contributions

    Merci beaucoup à vous deux ! Le problème est résolu !

    Merci à Lumière de Lune qui m’a donné la piste du WP vide, et de l’importation XML… Le site a retrouvé sa rapidité !

    Merci également à LH pour avoir posé les bonnes questions, et qui m’a permit de bien cogiter ! :-D

    #761849
    Lumiere de Lune
    Participant
    Maître WordPress
    19385 contributions

    🙂 surveilles quand même régulièrement tes tables….

    #761850
    LH
    Membre
    Chevalier WordPress
    372 contributions

    … Fan de longue date des Pogues et des Dubliners 🍺

    #2028122
    civitch
    Participant
    Chevalier WordPress
    160 contributions

    Bonjour , moi meme avoir exporter le fichier xml , j’ai du mal à l’importer plus tard car ca pese .

    #2028125
    PhiLyon
    Modérateur
    Maître WordPress
    24380 contributions

    @ civitch – Tu nous fais quoi là, je ferme le sujet qui date de 2011.

    Si tu as un problème, ouvres ton propre sujet https://wpfr.net/support/sujet/ouvrir-nouveau-sujet-forum/

    🙂

13 sujets de 1 à 13 (sur un total de 13)
  • Le sujet ‘Surcharge serveur énorme !’ est fermé à de nouvelles réponses.