Supression /wordpress/index.php/ (Créer un compte)

  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #455353
    moimoi123456
    Participant
    Padawan WordPress
    95 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress :2.3.1
    – Thème utilisé :pas encore descider
    – Plugins en place : d’origine
    – Nom de l’hebergeur : OVH
    – Adresse du site : localhost

    Problème(s) rencontré(s) : suppression de wordpress/index.php/

    Bonjour jour tout le monde,
    j’ai donc mis mon dossier wordpress a la racine (www chez ovh)
    mais je n’arrive pas a supprimer le wordpress/ et le index.php/ dans mon url
    Comment puis je faire svp?

    #614615
    Rafik
    Membre
    Chevalier WordPress
    311 contributions

    tu mets les fichiers à la racine de ton hébergement (pas dans le dossier /wordpress/)
    ensuite, tu joue sur les permalinks l’index.php, si tu as mod_rewrite biensur.

    #614616
    moimoi123456
    Participant
    Padawan WordPress
    95 contributions

    merci rafik déjà une première réponse c’est cool:).

    Par contre, je viens de tout mettre a la racine
    No problémo jai pu le wordpress (je lai suprimmé aussi dans OPTIONS/GéNéRAL)
    -les deux champs ou il y avait /worpress/

    Donc sur mon index plus de wordpress …

    J’ai activer le premier mode de permaliens “Baser sur la date et le titre”

    Retour a l index…cool plus de wordpress ni de index php…
    mais le problème c’est si je sélectionne quoi que se soit
    -un post
    -une catégorie…etc

    page blanche (en local)

    y a que l index qui marche
    y a autre choses a mettre dans le htacces??

    #614617
    Rafik
    Membre
    Chevalier WordPress
    311 contributions

    je te conseille de refaire l’installation en racine en fait
    pour les permalinks, il faut que mod_rewrite soit actif, t’es en local t’as dis ? ou bien chez ovh ?

    #614618
    moimoi123456
    Participant
    Padawan WordPress
    95 contributions

    pour l instant je suis en local
    (je suis arriver hier sur wordpress)

    donc j ‘ai juste voulu voir un peu le fonctionnement “grossier” pour le faire tourner )

    je pense prendre un hébergement chez ovh (je dois prendre une hebergeure très rapidement)…

    donc je vais essayer de refaire une instal a la racine du localhost

    #614619
    Rafik
    Membre
    Chevalier WordPress
    311 contributions

    Tu dois activer mod_rewrite dans le fichier httpd.conf pour que les permalinks fonctionnent.
    Cherche “LoadModule rewrite_module” dans ce fichier, et décommente la ligne (supprime le # au début)

    Comme c’est un test, tu peux te permettre de jouer avec !

    #614620
    moimoi123456
    Participant
    Padawan WordPress
    95 contributions

    merci de ton suivit rafik …frenchement

    bon j’ai refais mon instal avec tout les fichier a la racine

    c’est idem

    dans Options/Général ===> http://127.0.0.1 (normal suis en local)

    et dans permaliens:
    Basé sur le titre et la date

    Si je fais ca j’ai acces a mon index mais si je clic sur l’article de demo
    j’ai bien un url rewriter mais une page blanche

    par contre, je viens de tester un permalier perso
    /index.php/%year%/%monthnum%/%day%/%postname%/

    la ca marche
    -l index
    -et aussi les articles catégories etc

    Mais il me reste se “INDEX.PHP” (je sais pas comment le virer)

    Pour le httpd je sais pas ou le trouver tout ca en local

    #614621
    Rafik
    Membre
    Chevalier WordPress
    311 contributions

    easyphp ?

    #614622
    moimoi123456
    Participant
    Padawan WordPress
    95 contributions

    exact oui 🙂

    ok jai fais une recherche mais le probleme c ets que je trouve 2 httpd.conf

    – dans C: / prog-files/ Easy-php / conf_files
    – l’autre C: / prog-files/ Easy-php / appache / conf

    le quel est le bon???

    RE EDIT: bon je viens de le faire au deux je vais tester

    #614623
    dolbysound
    Participant
    Initié WordPress
    14 contributions

    Même problème,
    j’utilise easyphp

    impossible de virer index.php dans mon url !

    j’ai activé LoadModule rewrite_module dans httpd.conf mais rien y fait, impossible d’afficher les categories/pages sur mon blog sans ce foutu index.php

    Sur l’admin de WP, je mets /%category%/%postname%/ => marche pas
    par contre index.php/%category%/%postname%/ => ca roule

    mon fichier httacess :

    # BEGIN WordPress
    
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    
    
    # END WordPress

    Que faire pour virer ce foutu index.php ?

    Merci

    #614624
    jp_samson
    Membre
    Initié WordPress
    5 contributions

    Toujours pas de solution à ce problème d’index.php?
    J’ai le même problème!

    Merci pour votre aide.

    #614625
    karmix
    Membre
    Initié WordPress
    4 contributions

    UP ! Il y a enormement de gens sur le forum qui ont ce problème svp !

    #614626
    Lumiere de Lune
    Participant
    Maître WordPress
    19365 contributions

    upper un message de 2009…

    Merci de faire votre propre message, en précisant bien les réponses aux questions au moment de la création du sujet

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.